summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-07-29 11:22:36 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-07-29 11:22:36 +0000
commit9ffaee4d60c888f15dc7becaae314dbb8c818d64 (patch)
tree88eb21cc634d1a27ddab5a41fc88de3fbeed11ed /media-libs
parentforgot to update RDEPEND (diff)
downloadgentoo-2-9ffaee4d60c888f15dc7becaae314dbb8c818d64.tar.gz
gentoo-2-9ffaee4d60c888f15dc7becaae314dbb8c818d64.tar.bz2
gentoo-2-9ffaee4d60c888f15dc7becaae314dbb8c818d64.zip
moved from gnome-base to media-libs, also look for USE=gnome to see where to place it. if gnome is installed it will also build GnomeCanvasPixbuf and install in /opt/gnome
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
index ae98e712f2dd..d1a071dde4ee 100644
--- a/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild
@@ -1,29 +1,34 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild,v 1.2 2001/06/11 08:11:28 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.11.0.ebuild,v 1.3 2001/07/29 11:22:36 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="GNOME Image Library"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/"${A}
-DEPEND=">=gnome-base/gnome-libs-1.2.13"
+DEPEND=">=x11-libs/gtk+-1.2.0
+ gnome? ( >=gnome-base/gnome-libs-1.2.13 )"
src_compile() {
-
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome
+ local myprefix
+ local mysysconfdir
+
+ if [ "`use gnome`" ] ; then
+ myprefix=/opt/gnome
+ mysysconfdir=/etc/opt/gnome
+ else
+ myprefix=/usr/X11R6
+ mysysconfdir=/etc/X11/gdk-pixbuf
+ fi
+
+ try ./configure --host=${CHOST} --prefix=${myprefix} --sysconfdir=${mysysconfdir}
try pmake
}
src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ try make prefix=${D}${myprefix} sysconfdir=${D}${mysysconfdir} install
dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
}
-
-
-
-
-
-