summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-23 00:55:55 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-23 00:55:55 +0000
commitf24b2e6214a4bfc57ca9a3e36a5ea7c4b9a5e044 (patch)
treed6180a4230a27929ce60b1fd495b30e83fef1a06 /media-libs
parentgconf-editor, and editor for gconf data (diff)
downloadgentoo-2-f24b2e6214a4bfc57ca9a3e36a5ea7c4b9a5e044.tar.gz
gentoo-2-f24b2e6214a4bfc57ca9a3e36a5ea7c4b9a5e044.tar.bz2
gentoo-2-f24b2e6214a4bfc57ca9a3e36a5ea7c4b9a5e044.zip
The ebuild creates /etc/vga directory now. This closes bug #2912.
While I was at it, cleaned up some indentation and style.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/svgalib/ChangeLog18
-rw-r--r--media-libs/svgalib/files/digest-svgalib-1.4.3-r1 (renamed from media-libs/svgalib/files/digest-svgalib-1.4.3)0
-rw-r--r--media-libs/svgalib/svgalib-1.4.3-r1.ebuild (renamed from media-libs/svgalib/svgalib-1.4.3.ebuild)16
3 files changed, 12 insertions, 22 deletions
diff --git a/media-libs/svgalib/ChangeLog b/media-libs/svgalib/ChangeLog
index e9538605046e..69a4d2d7122d 100644
--- a/media-libs/svgalib/ChangeLog
+++ b/media-libs/svgalib/ChangeLog
@@ -1,20 +1,14 @@
# ChangeLog for media-libs/svgalib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.2 2002/05/01 01:15:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.3 2002/05/23 00:55:55 agenkin Exp $
*svgalib-1.4.3 (30 Apr 2002)
+ 22 May 2002; Arcady Genkin <agenkin@thpoon.com> svgalib-1.4.3-r1.ebuild :
+
+ Creates directory /etc/vga.
+
30 Apr 2002; Seemant Kulleen <seemant@gentoo.org> svgalib-1.4.3.ebuild :
Fixed sandbox violation, because the makefile does not understand that
- /usr/include can be relocated for a fake install.
-
-*svgalib-1.4.3 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ /usr/include can be relocated for a fake install. \ No newline at end of file
diff --git a/media-libs/svgalib/files/digest-svgalib-1.4.3 b/media-libs/svgalib/files/digest-svgalib-1.4.3-r1
index 0d27a405e4c3..0d27a405e4c3 100644
--- a/media-libs/svgalib/files/digest-svgalib-1.4.3
+++ b/media-libs/svgalib/files/digest-svgalib-1.4.3-r1
diff --git a/media-libs/svgalib/svgalib-1.4.3.ebuild b/media-libs/svgalib/svgalib-1.4.3-r1.ebuild
index d511386ec593..62c3f6ee5bc6 100644
--- a/media-libs/svgalib/svgalib-1.4.3.ebuild
+++ b/media-libs/svgalib/svgalib-1.4.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/svgalib-1.4.3.ebuild,v 1.5 2002/05/01 01:29:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/svgalib-1.4.3-r1.ebuild,v 1.1 2002/05/23 00:55:55 agenkin Exp $
S=${WORKDIR}/${P}
DESCRIPTION="a library for running svga graphics on the console"
@@ -18,23 +18,19 @@ src_unpack() {
src_compile() {
- make OPTIMIZE="${CFLAGS}" static || die
- make OPTIMIZE="${CFLAGS}" shared || die
- make OPTIMIZE="${CFLAGS}" textutils || die
- make OPTIMIZE="${CFLAGS}" lrmi || die
- make OPTIMIZE="${CFLAGS}" utils || die
+ make OPTIMIZE="${CFLAGS}" static shared textutils lrmi utils || die
# Build the gl stuff tpp
- make OPTIMIZE="${CFLAGS}" -C gl || die
- make OPTIMIZE="${CFLAGS}" -C gl libvgagl.so.${PV} || die
+ make OPTIMIZE="${CFLAGS}" -C gl || die
+ make OPTIMIZE="${CFLAGS}" -C gl libvgagl.so.${PV} || die
cp Makefile Makefile.orig
- sed 's/\(install: $(INSTALLAOUTLIB) \)installheaders \(.*\)/\1\2/g' \
+ sed 's/\(install: $(INSTALLAOUTLIB) \)installheaders \(.*\)/\1\2/g' \
Makefile.orig > Makefile
}
src_install () {
- dodir /etc/svga /usr/{include,lib,bin,share/man}
+ dodir /etc/{vga,svga} /usr/{include,lib,bin,share/man}
make TOPDIR=${D} OPTIMIZE="${CFLAGS}" install || die
insinto /usr/include
doins gl/vgagl.h