summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-09-20 15:41:08 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-09-20 15:41:08 +0000
commit9ca0bff5aed9269b39f8b6b9357c8e81013edeb4 (patch)
tree835f3153b4ed89ce736130f1b76b6bf18ae91d3f /media-plugins/bmp-itouch
parentarm/hppa/ia64 stable for security (diff)
downloadgentoo-2-9ca0bff5aed9269b39f8b6b9357c8e81013edeb4.tar.gz
gentoo-2-9ca0bff5aed9269b39f8b6b9357c8e81013edeb4.tar.bz2
gentoo-2-9ca0bff5aed9269b39f8b6b9357c8e81013edeb4.zip
Adding missing 0.1.4.2-keyboard-config.patch
Diffstat (limited to 'media-plugins/bmp-itouch')
-rw-r--r--media-plugins/bmp-itouch/ChangeLog6
-rw-r--r--media-plugins/bmp-itouch/files/0.1.4.2-keyboard-config.patch27
2 files changed, 32 insertions, 1 deletions
diff --git a/media-plugins/bmp-itouch/ChangeLog b/media-plugins/bmp-itouch/ChangeLog
index 1d3aa17ab16f..88a57345e6d9 100644
--- a/media-plugins/bmp-itouch/ChangeLog
+++ b/media-plugins/bmp-itouch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/bmp-itouch
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/bmp-itouch/ChangeLog,v 1.2 2004/09/04 20:00:11 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/bmp-itouch/ChangeLog,v 1.3 2004/09/20 15:41:08 chainsaw Exp $
+
+ 20 Sep 2004; Tony Vroon <chainsaw@gentoo.org>
+ +files/0.1.4.2-keyboard-config.patch:
+ Add missing 0.1.4.2-keyboard-config.patch file.
*bmp-itouch-0.1.4.2-r1 (04 Sep 2004)
diff --git a/media-plugins/bmp-itouch/files/0.1.4.2-keyboard-config.patch b/media-plugins/bmp-itouch/files/0.1.4.2-keyboard-config.patch
new file mode 100644
index 000000000000..3332a406993c
--- /dev/null
+++ b/media-plugins/bmp-itouch/files/0.1.4.2-keyboard-config.patch
@@ -0,0 +1,27 @@
+diff -uNr bmp-itouch-0.1.4.2.ORIG/configure.ac bmp-itouch-0.1.4.2/configure.ac
+--- bmp-itouch-0.1.4.2.ORIG/configure.ac 2004-09-02 21:37:13.904436384 +0100
++++ bmp-itouch-0.1.4.2/configure.ac 2004-09-02 21:37:40.514391056 +0100
+@@ -46,6 +46,11 @@
+ AC_SUBST(BEEP_DATA_DIR)
+ CPPFLAGS="$CPPFLAGS $BEEP_CFLAGS"
+
++dnl make BEEP_DATA_DIR a variable in config.h
++AH_TEMPLATE(BEEP_DATA_DIR, "Path to bmp-touch.config")
++AC_DEFINE_UNQUOTED(BEEP_DATA_DIR, "$BEEP_DATA_DIR")
++
++
+ AM_GNU_GETTEXT_VERSION([0.10.35])
+ AM_GNU_GETTEXT
+ AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$PACKAGE", [defined to gettext domain])
+diff -uNr bmp-itouch-0.1.4.2.ORIG/itouch.c bmp-itouch-0.1.4.2/itouch.c
+--- bmp-itouch-0.1.4.2.ORIG/itouch.c 2004-09-02 21:37:13.912435168 +0100
++++ bmp-itouch-0.1.4.2/itouch.c 2004-09-02 21:38:42.790923584 +0100
+@@ -1031,7 +1031,7 @@
+ ConfigFile *cfgfile;
+ gint i;
+
+- if (cfgfile = xmms_cfg_open_file("/xmms-itouch.config")) {
++ if (cfgfile = xmms_cfg_open_file(BEEP_DATA_DIR "/bmp-itouch.config")) {
+ xmms_cfg_read_int(cfgfile, "Global", "config_count",
+ &kbdcount);
+