summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-15 18:00:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-15 18:00:58 +0000
commit533f2e4ecc1fb80b45e1f7f0cad2419ce4f4a430 (patch)
treeff265322a14b0a2e16a3299300841a0a94143f70 /media-plugins
parentVersion bump wrt #309881 by Alexander Brüning. (diff)
downloadgentoo-2-533f2e4ecc1fb80b45e1f7f0cad2419ce4f4a430.tar.gz
gentoo-2-533f2e4ecc1fb80b45e1f7f0cad2419ce4f4a430.tar.bz2
gentoo-2-533f2e4ecc1fb80b45e1f7f0cad2419ce4f4a430.zip
Link to -lasound and put objs before libs for -Wl,--as-needed wrt #295005 by Sebastian M.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsaequal/ChangeLog7
-rw-r--r--media-plugins/alsaequal/alsaequal-0.4.ebuild31
-rw-r--r--media-plugins/alsaequal/alsaequal-0.6.ebuild8
-rw-r--r--media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch16
4 files changed, 28 insertions, 34 deletions
diff --git a/media-plugins/alsaequal/ChangeLog b/media-plugins/alsaequal/ChangeLog
index 4616d8007836..d0b71f798924 100644
--- a/media-plugins/alsaequal/ChangeLog
+++ b/media-plugins/alsaequal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsaequal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.3 2010/05/15 17:55:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/ChangeLog,v 1.4 2010/05/15 18:00:58 ssuominen Exp $
+
+ 15 May 2010; Samuli Suominen <ssuominen@gentoo.org> alsaequal-0.6.ebuild,
+ +files/alsaequal-0.6-asneeded.patch:
+ Link to -lasound and put objs before libs for -Wl,--as-needed wrt #295005
+ by Sebastian M.
*alsaequal-0.6 (15 May 2010)
diff --git a/media-plugins/alsaequal/alsaequal-0.4.ebuild b/media-plugins/alsaequal/alsaequal-0.4.ebuild
deleted file mode 100644
index bde320ab3790..000000000000
--- a/media-plugins/alsaequal/alsaequal-0.4.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/alsaequal-0.4.ebuild,v 1.2 2009/09/30 08:40:41 fauli Exp $
-
-inherit multilib toolchain-funcs
-
-DESCRIPTION="a real-time adjustable equalizer plugin for ALSA"
-HOMEPAGE="http://www.thedigitalmachine.net/alsaequal.html"
-SRC_URI="http://www.thedigitalmachine.net/tools/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="media-libs/alsa-lib
- media-plugins/caps-plugins"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall -fPIC -DPIC" \
- LD="$(tc-getCC)" LDFLAGS="${LDFLAGS} -shared" || die "emake failed"
-}
-
-src_install() {
- exeinto /usr/$(get_libdir)/alsa-lib
- doexe *.so || die "doexe failed"
- dodoc README || die "dodoc failed"
-}
diff --git a/media-plugins/alsaequal/alsaequal-0.6.ebuild b/media-plugins/alsaequal/alsaequal-0.6.ebuild
index b0656e820396..f12b69b9b633 100644
--- a/media-plugins/alsaequal/alsaequal-0.6.ebuild
+++ b/media-plugins/alsaequal/alsaequal-0.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/alsaequal-0.6.ebuild,v 1.1 2010/05/15 17:55:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsaequal/alsaequal-0.6.ebuild,v 1.2 2010/05/15 18:00:58 ssuominen Exp $
EAPI=2
-inherit multilib toolchain-funcs
+inherit eutils multilib toolchain-funcs
DESCRIPTION="a real-time adjustable equalizer plugin for ALSA"
HOMEPAGE="http://www.thedigitalmachine.net/alsaequal.html"
@@ -19,6 +19,10 @@ DEPEND="media-libs/alsa-lib
S=${WORKDIR}/${PN}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \
diff --git a/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch b/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch
new file mode 100644
index 000000000000..50a95e6a5c95
--- /dev/null
+++ b/media-plugins/alsaequal/files/alsaequal-0.6-asneeded.patch
@@ -0,0 +1,16 @@
+--- Makefile
++++ Makefile
+@@ -29,11 +29,11 @@
+
+ $(SND_PCM_BIN): $(SND_PCM_OBJECTS)
+ @echo LD $@
+- $(Q)$(LD) $(LDFLAGS) $(SND_PCM_LIBS) $(SND_PCM_OBJECTS) -o $(SND_PCM_BIN)
++ $(Q)$(LD) $(LDFLAGS) $(SND_PCM_OBJECTS) -o $(SND_PCM_BIN) $(SND_PCM_LIBS)
+
+ $(SND_CTL_BIN): $(SND_CTL_OBJECTS)
+ @echo LD $@
+- $(Q)$(LD) $(LDFLAGS) $(SND_CTL_LIBS) $(SND_CTL_OBJECTS) -o $(SND_CTL_BIN)
++ $(Q)$(LD) $(LDFLAGS) $(SND_CTL_OBJECTS) -o $(SND_CTL_BIN) $(SND_CTL_LIBS)
+
+ %.o: %.c
+ @echo GCC $<