summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-11-30 22:02:14 +0000
committerMichał Górny <mgorny@gentoo.org>2013-11-30 22:02:14 +0000
commit6e90ad0fd491e9ba955c2597599c47df23cfbcc2 (patch)
tree02aa363bd19bf6110897ce39a22a6de2dec9e8ca /media-plugins
parentRequire matching abi_x86_32 flag on dependant emul-linux packages due to pote... (diff)
downloadgentoo-2-6e90ad0fd491e9ba955c2597599c47df23cfbcc2.tar.gz
gentoo-2-6e90ad0fd491e9ba955c2597599c47df23cfbcc2.tar.bz2
gentoo-2-6e90ad0fd491e9ba955c2597599c47df23cfbcc2.zip
Fix pulseaudio plugin for multilib, bug #410261, comment 5+.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog7
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index e44e385589cd..c7530113ff68 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.179 2013/09/01 18:36:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.180 2013/11/30 22:02:14 mgorny Exp $
+
+*alsa-plugins-1.0.27-r1 (30 Nov 2013)
+
+ 30 Nov 2013; Michał Górny <mgorny@gentoo.org> +alsa-plugins-1.0.27-r1.ebuild:
+ Fix pulseaudio plugin for multilib, bug #410261, comment 5+.
01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> alsa-plugins-1.0.27.ebuild:
Stable for alpha, wrt bug #473404
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild
new file mode 100644
index 000000000000..5cd9952cab33
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r1.ebuild,v 1.1 2013/11/30 22:02:14 mgorny Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ ffmpeg? ( virtual/ffmpeg )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch \
+ "${FILESDIR}"/${PN}-1.0.23-automagic.patch \
+ "${FILESDIR}"/${PN}-1.0.27-ffmpeg-version-check.patch
+
+ epatch_user
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myspeex=no
+ use speex && myspeex=lib
+
+ econf \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ --with-speex=${myspeex}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd doc
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ # bug #410261, comment 5+
+ # seems to work fine without any path
+ sed -i \
+ -e "s:/usr/lib/alsa-lib/::" \
+ "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
+ fi
+
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}