summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-15 11:26:03 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-15 11:26:03 +0000
commitee46a6e1675543046cc81f0830bef09e6f3b58d3 (patch)
treef39fae125ec3c1c164fea17190713d12136e87c4 /media-sound/beast/beast-0.6.0.ebuild
parent (Manifest recommit) (diff)
downloadgentoo-2-ee46a6e1675543046cc81f0830bef09e6f3b58d3.tar.gz
gentoo-2-ee46a6e1675543046cc81f0830bef09e6f3b58d3.tar.bz2
gentoo-2-ee46a6e1675543046cc81f0830bef09e6f3b58d3.zip
version bump
Diffstat (limited to 'media-sound/beast/beast-0.6.0.ebuild')
-rw-r--r--media-sound/beast/beast-0.6.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/beast/beast-0.6.0.ebuild b/media-sound/beast/beast-0.6.0.ebuild
new file mode 100644
index 000000000000..9e7dd1efb53b
--- /dev/null
+++ b/media-sound/beast/beast-0.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.6.0.ebuild,v 1.1 2004/02/15 11:26:03 liquidx Exp $
+
+IUSE="debug mad static"
+
+DESCRIPTION="BEAST - the Bedevilled Sound Engine"
+HOMEPAGE="http://beast.gtk.org"
+SRC_URI="ftp://beast.gtk.org/pub/beast/v${PV%.[0-9]}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0.0
+ >=sys-libs/zlib-1.1.3
+ >=dev-util/guile-1.6
+ >=media-libs/libart_lgpl-2.3.8
+ >=gnome-base/libgnomecanvas-2.0
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0
+ mad? ( media-sound/mad )"
+
+DEPEND="dev-util/pkgconfig
+ dev-lang/perl
+ media-libs/ladspa-cmt
+ media-libs/ladspa-sdk
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-docs.patch
+}
+
+src_compile() {
+ local myconf="--with-gnu-ld"
+
+ use debug || myconf="${myconf} --disable-debug"
+
+ use static || myconf="${myconf} --disable-static"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+}