summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-30 22:19:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-30 22:19:09 +0000
commitb89541d19d01943a2d0f65417b61005cf5d86fdd (patch)
treea0a5a569f0a3094f47b8eaaae0ad212d8135c32e /media-sound/ecasound
parentSmall fix to boost depends to be future-proof (diff)
downloadgentoo-2-b89541d19d01943a2d0f65417b61005cf5d86fdd.tar.gz
gentoo-2-b89541d19d01943a2d0f65417b61005cf5d86fdd.tar.bz2
gentoo-2-b89541d19d01943a2d0f65417b61005cf5d86fdd.zip
Remove old
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ecasound')
-rw-r--r--media-sound/ecasound/ChangeLog7
-rw-r--r--media-sound/ecasound/ecasound-2.4.3.ebuild108
-rw-r--r--media-sound/ecasound/ecasound-2.4.4.ebuild108
-rw-r--r--media-sound/ecasound/ecasound-2.4.5.ebuild108
-rw-r--r--media-sound/ecasound/ecasound-2.4.6.1.ebuild98
-rw-r--r--media-sound/ecasound/ecasound-2.5.0.ebuild98
6 files changed, 6 insertions, 521 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 293a3948bc8d..4c1beb7535bb 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ecasound
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.52 2009/04/30 22:14:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.53 2009/04/30 22:19:09 patrick Exp $
+
+ 30 Apr 2009; Patrick Lauer <patrick@gentoo.org> -ecasound-2.4.3.ebuild,
+ -ecasound-2.4.4.ebuild, -ecasound-2.4.5.ebuild, -ecasound-2.4.6.1.ebuild,
+ -ecasound-2.5.0.ebuild:
+ Remove old
*ecasound-2.6.0 (30 Apr 2009)
diff --git a/media-sound/ecasound/ecasound-2.4.3.ebuild b/media-sound/ecasound/ecasound-2.4.3.ebuild
deleted file mode 100644
index ede10bed0f00..000000000000
--- a/media-sound/ecasound/ecasound-2.4.3.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.3.ebuild,v 1.9 2008/01/16 18:22:20 grobian Exp $
-
-inherit multilib
-
-IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-DESCRIPTION="A package for multitrack audio processing"
-SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
-HOMEPAGE="http://eca.cx/"
-LICENSE="GPL-2"
-
-SLOT="1"
-KEYWORDS="amd64 ~ppc sparc x86"
-
-DEPEND="jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )"
-
-# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
-# use flags for them.
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i 's:map.h:map:g' configure
-}
-
-src_compile () {
- local myconf
-
- myconf="${myconf} --enable-shared --with-largefile"
-
- if use python; then
- #
- # ecasound is braindead about finding python includes/libdirs and
- # about where to install modules. Luckily, it allows us to specify
- # all this.
- #
- local python_version python_prefix python_includes python_modules
- if use userland_Darwin ; then
- myconf="$myconf --enable-pyecasound=python"
- else
- myconf="$myconf --enable-pyecasound=c"
- fi
- python_version="`python -c 'import sys; print sys.version[:3]'`"
- python_prefix="`python -c 'import sys; print sys.prefix'`"
-
- python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/$(get_libdir)/python$python_version"
-
- myconf="$myconf --with-python-includes=$python_includes"
- myconf="$myconf --with-python-modules=$python_modules"
- else
- myconf="$myconf --disable-pyecasound"
- fi
-
- econf \
- $(use_enable alsa) \
- $(use_enable arts) \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- ${myconf} \
- || die "configure failed"
- make || die "build failed"
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- if use python; then
- cd pyecasound || die
- python -c "import compileall; compileall.compile_dir('.')" || die
- python -O -c "import compileall; compileall.compile_dir('.')" || die
- python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
- install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
- cd ..
- fi
-
- dodoc BUGS NEWS README TODO
- dohtml `find Documentation -name "*.html"`
- dodoc Documentation/edi-list.txt
-}
-
-pkg_postinst() {
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and will go away in"
- ewarn "future releases."
- fi
-}
diff --git a/media-sound/ecasound/ecasound-2.4.4.ebuild b/media-sound/ecasound/ecasound-2.4.4.ebuild
deleted file mode 100644
index 3c326cd2bffc..000000000000
--- a/media-sound/ecasound/ecasound-2.4.4.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.4.ebuild,v 1.3 2008/01/16 18:22:20 grobian Exp $
-
-inherit multilib
-
-IUSE="alsa arts audiofile debug jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-DESCRIPTION="A package for multitrack audio processing"
-SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
-HOMEPAGE="http://eca.cx/"
-LICENSE="GPL-2"
-
-SLOT="1"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )"
-
-# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
-# use flags for them.
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i 's:map.h:map:g' configure
-}
-
-src_compile () {
- local myconf
-
- myconf="${myconf} --enable-shared --with-largefile"
-
- if use python; then
- #
- # ecasound is braindead about finding python includes/libdirs and
- # about where to install modules. Luckily, it allows us to specify
- # all this.
- #
- local python_version python_prefix python_includes python_modules
- if use userland_Darwin ; then
- myconf="$myconf --enable-pyecasound=python"
- else
- myconf="$myconf --enable-pyecasound=c"
- fi
- python_version="`python -c 'import sys; print sys.version[:3]'`"
- python_prefix="`python -c 'import sys; print sys.prefix'`"
-
- python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/$(get_libdir)/python$python_version"
-
- myconf="$myconf --with-python-includes=$python_includes"
- myconf="$myconf --with-python-modules=$python_modules"
- else
- myconf="$myconf --disable-pyecasound"
- fi
-
- econf \
- $(use_enable alsa) \
- $(use_enable arts) \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- ${myconf} \
- || die "configure failed"
- make || die "build failed"
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- if use python; then
- cd pyecasound || die
- python -c "import compileall; compileall.compile_dir('.')" || die
- python -O -c "import compileall; compileall.compile_dir('.')" || die
- python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
- install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
- cd ..
- fi
-
- dodoc BUGS NEWS README TODO
- dohtml `find Documentation -name "*.html"`
- dodoc Documentation/edi-list.txt
-}
-
-pkg_postinst() {
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and will go away in"
- ewarn "future releases."
- fi
-}
diff --git a/media-sound/ecasound/ecasound-2.4.5.ebuild b/media-sound/ecasound/ecasound-2.4.5.ebuild
deleted file mode 100644
index e3e36954138f..000000000000
--- a/media-sound/ecasound/ecasound-2.4.5.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.5.ebuild,v 1.4 2008/01/16 18:22:20 grobian Exp $
-
-inherit multilib eutils
-
-DESCRIPTION="a package for multitrack audio processing"
-SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
-HOMEPAGE="http://eca.cx"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )
- sys-libs/readline"
-DEPEND="${RDEPEND}"
-
-# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
-# use flags for them.
-
-pkg_setup() {
- if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
- eerror ""
- eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
- eerror "need to have built media-libs/alsa-lib with midi USE flag."
- die "Missing midi USE flag on media-libs/alsa-lib"
- fi
-}
-
-src_compile () {
- local myconf
-
- myconf="${myconf} --enable-shared --with-largefile --enable-sys-readline"
-
- if use python; then
- # ecasound is braindead about finding python includes/libdirs and
- # about where to install modules. Luckily, it allows us to specify
- # all this.
- local python_version python_prefix python_includes python_modules
- if use userland_Darwin ; then
- myconf="$myconf --enable-pyecasound=python"
- else
- myconf="$myconf --enable-pyecasound=c"
- fi
- python_version="`python -c 'import sys; print sys.version[:3]'`"
- python_prefix="`python -c 'import sys; print sys.prefix'`"
-
- python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/$(get_libdir)/python$python_version"
-
- myconf="$myconf --with-python-includes=$python_includes"
- myconf="$myconf --with-python-modules=$python_modules"
- else
- myconf="$myconf --disable-pyecasound"
- fi
-
- econf \
- $(use_enable alsa) \
- $(use_enable arts) \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- ${myconf}
-
- emake || die "emake failed."
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed."
-
- if use python; then
- cd pyecasound
- python -c "import compileall; compileall.compile_dir('.')" || die
- python -O -c "import compileall; compileall.compile_dir('.')" || die
- python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
- install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
- cd ..
- fi
-
- dodoc BUGS NEWS README TODO Documentation/*.txt
- use doc && dohtml Documentation/*.html
-}
-
-pkg_postinst() {
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and will go away in"
- ewarn "future releases."
- fi
-}
diff --git a/media-sound/ecasound/ecasound-2.4.6.1.ebuild b/media-sound/ecasound/ecasound-2.4.6.1.ebuild
deleted file mode 100644
index 3b9efe7b385d..000000000000
--- a/media-sound/ecasound/ecasound-2.4.6.1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.6.1.ebuild,v 1.2 2008/05/29 14:26:59 hawking Exp $
-
-inherit eutils multilib python
-
-DESCRIPTION="a package for multitrack audio processing"
-HOMEPAGE="http://ecasound.seul.org/ecasound"
-SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-DEPEND="python? ( dev-lang/python )
- jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )
- sys-libs/readline"
-
-pkg_setup() {
- if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
- die "Re-emerge media-libs/alsa-lib with USE midi."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- local PYConf
-
- if use python; then
- python_version
- PYConf="--enable-pyecasound=c
- --with-python-includes=/usr/include/python${PYVER}
- --with-python-modules=/usr/$(get_libdir)/python${PYVER}"
- else
- PYConf="$myconf --disable-pyecasound"
- fi
-
- econf $(use_enable alsa) \
- $(use_enable arts) \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- --enable-shared \
- --with-largefile \
- --enable-sys-readline \
- ${PYConf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc BUGS NEWS README TODO Documentation/*.txt
- use doc && dohtml Documentation/*.html
-}
-
-pkg_postinst() {
- if use python; then
- ebegin "Byte-compiling ${CATEGORY}/${PF} python modules"
- python_version
- local PYMODULE
- for PYMODULE in ecacontrol.py pyeca.py eci.py; do
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/${PYMODULE}
- done
- eend $?
- fi
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and will go away in"
- ewarn "future releases."
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}
diff --git a/media-sound/ecasound/ecasound-2.5.0.ebuild b/media-sound/ecasound/ecasound-2.5.0.ebuild
deleted file mode 100644
index 3e128986235f..000000000000
--- a/media-sound/ecasound/ecasound-2.5.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.5.0.ebuild,v 1.1 2008/08/17 12:52:40 aballier Exp $
-
-inherit eutils multilib python
-
-DESCRIPTION="a package for multitrack audio processing"
-HOMEPAGE="http://ecasound.seul.org/ecasound"
-SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
-
-DEPEND="python? ( dev-lang/python )
- jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- vorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- libsamplerate? ( media-libs/libsamplerate )
- mikmod? ( media-libs/libmikmod )
- ruby? ( dev-lang/ruby )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )
- sndfile? ( media-libs/libsndfile )
- sys-libs/readline"
-
-pkg_setup() {
- if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
- die "Re-emerge media-libs/alsa-lib with USE midi."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- local PYConf
-
- if use python; then
- python_version
- PYConf="--enable-pyecasound=c
- --with-python-includes=/usr/include/python${PYVER}
- --with-python-modules=/usr/$(get_libdir)/python${PYVER}"
- else
- PYConf="$myconf --disable-pyecasound"
- fi
-
- econf $(use_enable alsa) \
- $(use_enable arts) \
- $(use_enable audiofile) \
- $(use_enable debug) \
- $(use_enable jack) \
- $(use_enable libsamplerate) \
- $(use_enable ncurses) \
- $(use_enable oss) \
- $(use_enable ruby rubyecasound) \
- $(use_enable sndfile) \
- --enable-shared \
- --with-largefile \
- --enable-sys-readline \
- ${PYConf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc BUGS NEWS README TODO Documentation/*.txt
- use doc && dohtml Documentation/*.html
-}
-
-pkg_postinst() {
- if use python; then
- ebegin "Byte-compiling ${CATEGORY}/${PF} python modules"
- python_version
- local PYMODULE
- for PYMODULE in ecacontrol.py pyeca.py eci.py; do
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/${PYMODULE}
- done
- eend $?
- fi
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and will go away in"
- ewarn "future releases."
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}