summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2006-10-08 03:01:56 +0000
committerEldad Zack <eldad@gentoo.org>2006-10-08 03:01:56 +0000
commitcfaccefd108f7b87190b075fed29ff460de06983 (patch)
treec5be47e17452077b22e0e888ca9670f731f8bd65 /media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild
parentMarking amd64, sparc stable (diff)
downloadgentoo-2-cfaccefd108f7b87190b075fed29ff460de06983.tar.gz
gentoo-2-cfaccefd108f7b87190b075fed29ff460de06983.tar.bz2
gentoo-2-cfaccefd108f7b87190b075fed29ff460de06983.zip
Version bump, added cpudetection useflag (see bug #136565).
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild')
-rw-r--r--media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild
index acc31d1d4bfa..8d34b6c19d23 100644
--- a/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild
+++ b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild,v 1.3 2006/08/12 15:00:43 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.101.1-r1.ebuild,v 1.4 2006/10/08 03:01:56 eldad Exp $
inherit flag-o-matic eutils multilib
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/jackit/${P}.tar.gz http://netjack.sourceforge.net/
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
-IUSE="altivec alsa caps coreaudio doc debug jack-tmpfs mmx oss portaudio sndfile sse netjack"
+IUSE="altivec alsa caps coreaudio doc debug jack-tmpfs mmx oss portaudio sndfile sse netjack cpudetection"
RDEPEND="dev-util/pkgconfig
sndfile? ( >=media-libs/libsndfile-1.0.0 )
@@ -85,6 +85,17 @@ src_compile() {
-maltivec -mabi=altivec -mhard-float -mpowerpc-gfxopt
fi
+ # CPU Detection (dynsimd) uses asm routines which requires 3dnow.
+ # we test if it is present before enabling the configure flag.
+ if use cpudetection ; then
+ if (! grep 3dnow /proc/cpuinfo >/dev/null) ; then
+ ewarn "Can't build cpudetection (dynsimd) without cpu 3dnow support. see bug #136565."
+ else
+ einfo "Enabling cpudetection (dynsimd)"
+ myconf="${myconf} --enable-dynsimd"
+ fi
+ fi
+
use sndfile && \
export SNDFILE_CFLAGS="-I/usr/include" \
export SNDFILE_LIBS="-L/usr/$(get_libdir) -lsndfile"
@@ -99,7 +110,7 @@ src_compile() {
$(use_enable mmx) \
$(use_enable oss) \
$(use_enable portaudio) \
- $(use_enable sse) $(use_enable sse dynsimd) \
+ $(use_enable sse) \
--with-pic \
${myconf} || die "configure failed"
emake || die "compilation failed"