summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 06:52:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 06:52:28 +0000
commitabf1362d8a80efb011dfdff055658572795671b1 (patch)
tree1c1cc058fb1c7b03816942951d4e98d34148714a /media-sound/kid3
parentAdd SVN snapshot and updated extras in preparation for reference policy. (diff)
downloadgentoo-2-abf1362d8a80efb011dfdff055658572795671b1.tar.gz
gentoo-2-abf1362d8a80efb011dfdff055658572795671b1.tar.bz2
gentoo-2-abf1362d8a80efb011dfdff055658572795671b1.zip
Version bump, this closes bug #112583 too.
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog7
-rw-r--r--media-sound/kid3/files/digest-kid3-0.73
-rw-r--r--media-sound/kid3/kid3-0.7.ebuild34
3 files changed, 43 insertions, 1 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index 47431fcd6c97..f9f0f376820e 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.19 2006/07/25 08:02:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.20 2006/10/05 06:52:28 flameeyes Exp $
+
+*kid3-0.7 (05 Oct 2006)
+
+ 05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> +kid3-0.7.ebuild:
+ Version bump, this closes bug #112583 too.
25 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
-files/kid3-0.6-tunepimp04.patch, kid3-0.6.ebuild:
diff --git a/media-sound/kid3/files/digest-kid3-0.7 b/media-sound/kid3/files/digest-kid3-0.7
new file mode 100644
index 000000000000..ca861c389f96
--- /dev/null
+++ b/media-sound/kid3/files/digest-kid3-0.7
@@ -0,0 +1,3 @@
+MD5 e5f8262e3456d9b0bdba4e4b56ca3aee kid3-0.7.tar.gz 897741
+RMD160 9f7f4a17b5e048bfb4336b1cfe86afcf4c2f20cf kid3-0.7.tar.gz 897741
+SHA256 05d01593f3b5cfd94fb4404cf7cc384a45b133595d6b9abc6cc43f67fe628a2b kid3-0.7.tar.gz 897741
diff --git a/media-sound/kid3/kid3-0.7.ebuild b/media-sound/kid3/kid3-0.7.ebuild
new file mode 100644
index 000000000000..18486e89bda4
--- /dev/null
+++ b/media-sound/kid3/kid3-0.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.7.ebuild,v 1.1 2006/10/05 06:52:28 flameeyes Exp $
+
+inherit kde
+
+DESCRIPTION="A simple ID3 tag editor for QT/KDE."
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kid3/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac vorbis"
+
+DEPEND=">=media-libs/id3lib-3.8.3
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )"
+RDEPEND="${DEPEND}"
+
+need-kde 3
+
+# Support for the KDE libraries is optional,
+# but the configure step that detects them
+# cannot be avoided. So KDE support is forced on.
+
+src_compile() {
+ local myconf="--with-kde
+ $(use_with vorbis)
+ $(use_with flac)
+ --without-musicbrainz"
+
+ kde_src_compile
+}