summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-08 22:48:18 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-08 22:48:18 +0000
commitf53f96c0bdc801c5fca230ada196da72db132397 (patch)
tree16460532b4f5634e76d6c670751e47e0b89f8ac1 /media-sound/mp3blaster
parentjosm desktop and icon file (diff)
downloadgentoo-2-f53f96c0bdc801c5fca230ada196da72db132397.tar.gz
gentoo-2-f53f96c0bdc801c5fca230ada196da72db132397.tar.bz2
gentoo-2-f53f96c0bdc801c5fca230ada196da72db132397.zip
Properly control oss/sdl according to USE flags.
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-sound/mp3blaster')
-rw-r--r--media-sound/mp3blaster/ChangeLog6
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild27
2 files changed, 21 insertions, 12 deletions
diff --git a/media-sound/mp3blaster/ChangeLog b/media-sound/mp3blaster/ChangeLog
index aaf55f5b84a2..a5feac5f6bc8 100644
--- a/media-sound/mp3blaster/ChangeLog
+++ b/media-sound/mp3blaster/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mp3blaster
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.33 2007/08/28 15:31:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.34 2007/09/08 22:48:18 vapier Exp $
+
+ 08 Sep 2007; Mike Frysinger <vapier@gentoo.org>
+ mp3blaster-3.2.3-r1.ebuild:
+ Properly control oss/sdl according to USE flags.
28 Aug 2007; Mike Frysinger <vapier@gentoo.org>
mp3blaster-3.2.3-r1.ebuild:
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild
index fec0e836f273..73c717e314b6 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild,v 1.6 2007/08/28 15:31:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3-r1.ebuild,v 1.7 2007/09/08 22:48:18 vapier Exp $
DESCRIPTION="Text console based program for playing audio files"
HOMEPAGE="http://mp3blaster.sourceforge.net/"
@@ -9,7 +9,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 -ppc ~ppc64 ~sparc ~x86"
-IUSE="esd lirc sdl sid vorbis"
+IUSE="esd lirc oss sdl sid vorbis"
RDEPEND=">=sys-libs/ncurses-5.2
lirc? ( app-misc/lirc )
@@ -30,25 +30,30 @@ src_unpack() {
src_compile() {
local myconf
-
- # newthreads and libpth support is broken.
- if use sdl; then
- myconf="${myconf} --disable-newthreads --without-pth --with-sdl --with-oss"
- else
- myconf="${myconf} --disable-newthreads --without-pth --with-oss"
+ if ! use esd && ! use sdl && ! use oss ; then
+ ewarn "You've disabled esd, sdl, and oss. Enabling oss for you."
+ myconf="--with-oss"
fi
- econf --without-nas ${myconf} \
+ # newthreads and libpth support is broken.
+ econf \
+ --disable-newthreads \
+ --without-pth \
+ --without-nas \
$(use_with lirc) \
$(use_with vorbis oggvorbis) \
$(use_with sid sidplay) \
- $(use_with esd)
+ $(use_with esd) \
+ $(use_with sdl) \
+ $(use_with oss) \
+ ${myconf} \
+ || die
emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
# File collision with media-sound/splay.
- mv "${D}"/usr/bin/splay "${D}"/usr/bin/splay_mp3blaster
+ mv "${D}"/usr/bin/splay "${D}"/usr/bin/splay_mp3blaster || die
dodoc AUTHORS BUGS ChangeLog CREDITS FAQ NEWS README TODO
}