summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
commitc676ea5558bf9bd02aa9397693de6f3829798b05 (patch)
treec10129ee9a02b59eb7e2862a1cdf2552e5922c3e /media-sound/normalize
parentadded X to DEPEND (diff)
downloadgentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.gz
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.bz2
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.zip
Version bumps
Diffstat (limited to 'media-sound/normalize')
-rw-r--r--media-sound/normalize/ChangeLog7
-rw-r--r--media-sound/normalize/files/digest-normalize-0.7.61
-rw-r--r--media-sound/normalize/normalize-0.7.6.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/normalize/ChangeLog b/media-sound/normalize/ChangeLog
index 2173275888bd..6c8bd3ec003b 100644
--- a/media-sound/normalize/ChangeLog
+++ b/media-sound/normalize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/normalize
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.2 2002/08/14 08:51:19 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.3 2002/11/05 19:29:05 aliz Exp $
+
+*normalize-0.7.6 (05 Nov 2002)
+
+ 05 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*normalize-0.7.4 (5 May 2002)
14 Aug 2002; Pieter Van den Abeele <pvdabeel@gentoo.org> :
diff --git a/media-sound/normalize/files/digest-normalize-0.7.6 b/media-sound/normalize/files/digest-normalize-0.7.6
new file mode 100644
index 000000000000..ee037f359f68
--- /dev/null
+++ b/media-sound/normalize/files/digest-normalize-0.7.6
@@ -0,0 +1 @@
+MD5 7476f028304791595e91610bb0cd4e97 normalize-0.7.6.tar.bz2 299091
diff --git a/media-sound/normalize/normalize-0.7.6.ebuild b/media-sound/normalize/normalize-0.7.6.ebuild
new file mode 100644
index 000000000000..51895657ee67
--- /dev/null
+++ b/media-sound/normalize/normalize-0.7.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/normalize-0.7.6.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+IUSE="xmms"
+
+DESCRIPTION="Audio file volume normalizer"
+HOMEPAGE="http://www.cs.columbia.edu/~cvaill/normalize"
+SRC_URI="http://www.cs.columbia.edu/~cvaill/normalize/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="xmms? ( >=media-sound/xmms-1.2.7-r6 )
+ >=media-libs/audiofile-0.2.3-r1
+ >=media-sound/mad-0.14.2b-r1"
+
+# NOTE: the "audiofile" and "mad" dependencies are NOT
+# actually *required*, they are optional, but there are no
+# appropriate USE variables.
+#
+# The libraries are quite small, so it does not seem to be that
+# big a deal to force installation of them.
+#
+
+src_compile() {
+ econf \
+ --with-audiofile \
+ --with-mad || die
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}