summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2007-02-02 21:50:32 +0000
committerJoe McCann <joem@gentoo.org>2007-02-02 21:50:32 +0000
commitf5a944def2bbaa24407dfcd31c76413eb0b211d6 (patch)
tree4c817fce79244eb098de5094f7fbf47b63a9b27c /media-sound/rhythmbox
parentprune older releases (diff)
downloadgentoo-2-f5a944def2bbaa24407dfcd31c76413eb0b211d6.tar.gz
gentoo-2-f5a944def2bbaa24407dfcd31c76413eb0b211d6.tar.bz2
gentoo-2-f5a944def2bbaa24407dfcd31c76413eb0b211d6.zip
Adding patch to fix playback from daap shares. See bug 162956 for more info. Also added gst-plugins-cdparanoia dep as per bug 164983
(Portage version: 2.1.2-r6)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog9
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r13
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.9.7-daap_fix.patch38
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.7-r1.ebuild121
4 files changed, 170 insertions, 1 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 1d1386575c7c..dad883337793 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.85 2007/01/23 03:57:21 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.86 2007/02/02 21:50:32 joem Exp $
+
+*rhythmbox-0.9.7-r1 (02 Feb 2007)
+
+ 02 Feb 2007; Joe McCann <joem@gentoo.org>
+ +files/rhythmbox-0.9.7-daap_fix.patch, +rhythmbox-0.9.7-r1.ebuild:
+ Adding patch to fix playback from daap shares. See bug 162956 for more info.
+ Also added gst-plugins-cdparanoia dep as per bug 164983
23 Jan 2007; Joe McCann <joem@gentoo.org> rhythmbox-0.9.6.ebuild,
rhythmbox-0.9.7.ebuild:
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r1 b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r1
new file mode 100644
index 000000000000..9b731a17d661
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r1
@@ -0,0 +1,3 @@
+MD5 3ca989c655c5931ce056af7ff311885b rhythmbox-0.9.7.tar.bz2 3231718
+RMD160 547643b40b36e4e0c18b6d817c37426ce585119f rhythmbox-0.9.7.tar.bz2 3231718
+SHA256 2fac1912a15c19841d4ca3188df7aa8c7aaa37dbbffb279b24259cc1281ff995 rhythmbox-0.9.7.tar.bz2 3231718
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.9.7-daap_fix.patch b/media-sound/rhythmbox/files/rhythmbox-0.9.7-daap_fix.patch
new file mode 100644
index 000000000000..817add8c7bed
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.9.7-daap_fix.patch
@@ -0,0 +1,38 @@
+--- daapsharing/rb-daap-src.c 2007/01/07 12:16:12 4725
++++ daapsharing/rb-daap-src.c 2007/01/27 02:34:51 4760
+@@ -601,6 +601,7 @@
+ gchar *request;
+ gchar *response;
+ gchar *end_headers;
++ gchar first_byte;
+ size_t readsize;
+ gboolean ok = TRUE;
+ guint http_status;
+@@ -704,10 +705,13 @@
+ }
+
+ /* libsoup wants the headers null-terminated, despite taking a parameter
+- * specifying how long they are.
++ * specifying how long they are. since the byte we overwrite to null-
++ * terminate the headers is the first byte of the response body, we need
++ * to restore it once we've parsed the response headers.
+ */
+- end_headers[2] = '\0';
+- end_headers += 4;
++ first_byte = end_headers[4];
++ end_headers[4] = '\0';
++ end_headers += 2;
+
+ header_table = g_hash_table_new (soup_str_case_hash, soup_str_case_equal);
+ if (soup_headers_parse_response (response,
+@@ -758,6 +762,10 @@
+ g_free (http_status_phrase);
+ g_hash_table_destroy (header_table);
+
++ /* restore the first response body byte and move on */
++ end_headers += 2;
++ *end_headers = first_byte;
++
+ /* copy remaining data into a new buffer */
+ if (ok) {
+ src->buffer_size = readsize - (end_headers - response);
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.7-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..ca7e28c1e9b0
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.9.7-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.7-r1.ebuild,v 1.1 2007/02/02 21:50:32 joem Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vorbis flac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
+tagwriting python keyring"
+#I want tagwriting to be on by default in the future. It is just a local flag
+#now because it is still considered experimental by upstream and doesn't work
+#well with all formats due to gstreamer limitation.
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2.7.4
+ >=gnome-base/libbonobo-2
+ >=gnome-extra/nautilus-cd-burner-2.11.3
+ >=media-video/totem-1.1.5
+ >=x11-libs/libsexy-0.1.5
+ >=gnome-extra/gnome-media-2.14.0
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ musicbrainz? ( >=media-libs/musicbrainz-2.1 )
+ >=net-libs/libsoup-2.2.99
+ hal? ( ipod? ( >=media-libs/libgpod-0.4 )
+ >=sys-apps/hal-0.5 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 ) ) )
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10
+ >=media-plugins/gst-plugins-ogg-0.10 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ python? ( >=dev-lang/python-2.4.2
+ >=dev-python/pygtk-2.8
+ >=dev-python/gnome-python-2.12 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ app-text/scrollkeeper"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+
+ if ! use avahi && ! use howl; then
+ if use daap ; then
+ ewarn "Daap support requires either howl or avahi"
+ ewarn "to be installed. Please remerge with either"
+ ewarn "USE=avahi or USE=howl"
+ fi
+ fi
+ if use howl || use avahi ; then
+ G2CONF="${G2CONF} $(use_enable daap)"
+ fi
+
+ if use howl ; then
+ G2CONF="${G2CONF} --with-mdns=howl"
+ fi
+
+ if use avahi ; then
+ G2CONF="${G2CONF} --with-mdns=avahi"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_enable tagwriting tag-writing) \
+ $(use_with ipod) \
+ $(use_enable ipod ipod-writing) \
+ $(use_enable musicbrainz) \
+ $(use_with dbus) \
+ $(use_enable python) \
+ $(use_enable libnotify) \
+ $(use_enable lirc) \
+ $(use_with keyring gnome-keyring)
+ --with-playback=gstreamer-0-10 \
+ --with-cd-burning
+ --enable-mmkeys \
+ --enable-audioscrobbler \
+ --enable-track-transfer \
+ --with-metadata-helper \
+ --disable-schemas-install"
+
+DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
+ MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+export GST_INSPECT=/bin/true
+USE_DESTDIR=1
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-daap_fix.patch
+ gnome2_omf_fix
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog "See bug #159538 for more information"
+}