summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-01-07 12:44:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-01-07 12:44:56 +0000
commitf54fd4fd18c6587c6dc4883ed75202a3aede4f84 (patch)
treea068784bc6d8ba789034ca68a60f3bc1cc53b9b7 /media-sound/soundtracker
parentAdding the omited xsl patch. (diff)
downloadgentoo-2-f54fd4fd18c6587c6dc4883ed75202a3aede4f84.tar.gz
gentoo-2-f54fd4fd18c6587c6dc4883ed75202a3aede4f84.tar.bz2
gentoo-2-f54fd4fd18c6587c6dc4883ed75202a3aede4f84.zip
Version bump, bug #129019
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'media-sound/soundtracker')
-rw-r--r--media-sound/soundtracker/ChangeLog10
-rw-r--r--media-sound/soundtracker/files/digest-soundtracker-0.6.83
-rw-r--r--media-sound/soundtracker/soundtracker-0.6.8.ebuild74
3 files changed, 85 insertions, 2 deletions
diff --git a/media-sound/soundtracker/ChangeLog b/media-sound/soundtracker/ChangeLog
index ebc80376a1fe..f440ee18ec8c 100644
--- a/media-sound/soundtracker/ChangeLog
+++ b/media-sound/soundtracker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/soundtracker
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/ChangeLog,v 1.22 2006/11/18 02:12:15 compnerd Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/ChangeLog,v 1.23 2007/01/07 12:44:56 aballier Exp $
+
+*soundtracker-0.6.8 (07 Jan 2007)
+
+ 07 Jan 2007; Alexis Ballier <aballier@gentoo.org>
+ +soundtracker-0.6.8.ebuild:
+ Version bump, bug #129019
18 Nov 2006; Saleem Abdulrasool <compnerd@gentoo.org>
soundtracker-0.6.7.ebuild, soundtracker-0.6.7-r1.ebuild:
diff --git a/media-sound/soundtracker/files/digest-soundtracker-0.6.8 b/media-sound/soundtracker/files/digest-soundtracker-0.6.8
new file mode 100644
index 000000000000..d52879a19484
--- /dev/null
+++ b/media-sound/soundtracker/files/digest-soundtracker-0.6.8
@@ -0,0 +1,3 @@
+MD5 1e5a2ef689e214933e53f687b3a199bb soundtracker-0.6.8.tar.gz 1016718
+RMD160 b86bf86013e5d2959e1a8dbb19a9255c116b68d0 soundtracker-0.6.8.tar.gz 1016718
+SHA256 03b2f2c0edba48457ec6178b0a10edfe3481254112936715603a21f638822f50 soundtracker-0.6.8.tar.gz 1016718
diff --git a/media-sound/soundtracker/soundtracker-0.6.8.ebuild b/media-sound/soundtracker/soundtracker-0.6.8.ebuild
new file mode 100644
index 000000000000..684e8e820103
--- /dev/null
+++ b/media-sound/soundtracker/soundtracker-0.6.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.8.ebuild,v 1.1 2007/01/07 12:44:56 aballier Exp $
+
+IUSE="alsa esd jack nls oss sdl"
+
+inherit eutils
+
+S=${WORKDIR}/${P/_/-}
+
+DESCRIPTION="SoundTracker is a music tracking tool for UNIX/X11 (MOD tracker)"
+SRC_URI="http://www.soundtracker.org/dl/v0.6/${P/_/-}.tar.gz"
+HOMEPAGE="http://www.soundtracker.org"
+
+RDEPEND="sys-libs/zlib
+ =x11-libs/gtk+-1.2*
+ >=media-libs/audiofile-0.2.1
+ media-libs/libsndfile
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ jack? ( media-sound/jack-audio-connection-kit )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/unzip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.6.7-execstack.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use oss || myconf="--disable-oss"
+ use esd || myconf="${myconf} --disable-esd"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa"
+ myconf="${myconf} --disable-gnome"
+ use x86 && myconf="${myconf} --enable-asm"
+ use jack || myconf="${myconf} --disable-jack"
+ use sdl || myconf="${myconf} --disable-sdl"
+
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die "make install failed"
+ #borks make DESTDIR=${D} install || die "make install failed"
+
+ # strip suid from binary
+ chmod -s ${D}/usr/bin/soundtracker
+
+ # documentation
+ dodoc AUTHORS ChangeLog* FAQ NEWS README TODO
+ dodoc doc/*.txt
+ dohtml -r doc
+
+ doicon soundtracker_splash.png
+ make_desktop_entry soundtracker SoundTracker soundtracker_splash.png
+}