summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-19 16:31:07 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-19 16:31:07 +0000
commit5f3d64c0e4342ca1a025ac4d27dcda65141e16fa (patch)
treee751c5bfd0eb41d07c307fd125335e727cc30d4a /media-sound/tomahawk
parentMove udev rules file to FILESDIR and install with udev.eclass. Remove old ebu... (diff)
downloadgentoo-2-5f3d64c0e4342ca1a025ac4d27dcda65141e16fa.tar.gz
gentoo-2-5f3d64c0e4342ca1a025ac4d27dcda65141e16fa.tar.bz2
gentoo-2-5f3d64c0e4342ca1a025ac4d27dcda65141e16fa.zip
Update live ebuild by upstream changes.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-sound/tomahawk')
-rw-r--r--media-sound/tomahawk/ChangeLog6
-rw-r--r--media-sound/tomahawk/metadata.xml1
-rw-r--r--media-sound/tomahawk/tomahawk-9999.ebuild47
3 files changed, 35 insertions, 19 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index 5a0a74403af9..7ef768d80c83 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.32 2013/07/23 14:07:55 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.33 2013/10/19 16:31:07 johu Exp $
+
+ 19 Oct 2013; Johannes Huber <johu@gentoo.org> metadata.xml,
+ tomahawk-9999.ebuild:
+ Update live ebuild by upstream changes.
23 Jul 2013; Michael Palimaka <kensington@gentoo.org> tomahawk-0.6.1.ebuild,
tomahawk-0.7.0.ebuild, tomahawk-9999.ebuild:
diff --git a/media-sound/tomahawk/metadata.xml b/media-sound/tomahawk/metadata.xml
index df344c1b4b05..c2ec31ad259b 100644
--- a/media-sound/tomahawk/metadata.xml
+++ b/media-sound/tomahawk/metadata.xml
@@ -7,6 +7,7 @@
<name>Johannes Huber</name>
</maintainer>
<use>
+ <flag name="telepathy">Enable support for the real-time communication framework telepathy</flag>
<flag name="twitter">Enable twitter support</flag>
</use>
</pkgmetadata>
diff --git a/media-sound/tomahawk/tomahawk-9999.ebuild b/media-sound/tomahawk/tomahawk-9999.ebuild
index fb5448c99c87..7a33d9280e32 100644
--- a/media-sound/tomahawk/tomahawk-9999.ebuild
+++ b/media-sound/tomahawk/tomahawk-9999.ebuild
@@ -1,30 +1,29 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.19 2013/07/23 14:07:55 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-9999.ebuild,v 1.20 2013/10/19 16:31:07 johu Exp $
EAPI=5
-QT_MINIMAL="4.7.0"
-
-CMAKE_MIN_VERSION="2.8.6"
+KDE_REQUIRED="optional"
+inherit kde4-base ${GIT_ECLASS}
if [[ ${PV} != *9999* ]]; then
SRC_URI="http://download.tomahawk-player.org/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
else
- GIT_ECLASS="git-2"
+ GIT_ECLASS="git-r3"
EGIT_REPO_URI="git://github.com/tomahawk-player/${PN}.git"
KEYWORDS=""
fi
-inherit cmake-utils qt4-r2 ${GIT_ECLASS}
-
DESCRIPTION="Qt playdar social music player"
HOMEPAGE="http://tomahawk-player.org/"
LICENSE="GPL-3 BSD"
SLOT="0"
-IUSE="debug jabber twitter"
+IUSE="debug jabber kde qt5 telepathy twitter"
+
+REQUIRED_USE="telepathy? ( kde )"
DEPEND="
app-crypt/qca:2
@@ -33,19 +32,30 @@ DEPEND="
>=dev-libs/libattica-0.4.0
dev-libs/qjson
dev-libs/quazip
- dev-libs/qtkeychain
- >=dev-qt/qtcore-${QT_MINIMAL}:4
- >=dev-qt/qtdbus-${QT_MINIMAL}:4
- || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
- >=dev-qt/qtsql-${QT_MINIMAL}:4[sqlite]
- >=dev-qt/qtsvg-${QT_MINIMAL}:4
- >=dev-qt/qtwebkit-${QT_MINIMAL}:4
- >=media-libs/liblastfm-1.0.1
+ dev-libs/qtkeychain[qt5?]
>=media-libs/libechonest-2.1.0
+ >=media-libs/liblastfm-1.0.1
>=media-libs/phonon-4.5.0
>=media-libs/taglib-1.6.0
x11-libs/libX11
jabber? ( >=net-libs/jreen-1.1.1 )
+ !qt5? (
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[sqlite]
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ )
+ telepathy? ( net-libs/telepathy-qt )
twitter? ( net-libs/qtweetlib )
"
RDEPEND="${DEPEND}
@@ -57,11 +67,12 @@ DOCS=( AUTHORS ChangeLog README.md )
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with jabber Jreen)
+ $(cmake-utils_use_with kde KDE4)
+ $(cmake-utils_use_build !qt5 WITH_QT4)
+ $(cmake-utils_use_with telepathy TelepathyQt)
$(cmake-utils_use_with twitter QTweetLib)
)
- mycmakeargs+=( -DBUILD_WITH_QT4=ON )
-
if [[ ${PV} != *9999* ]]; then
mycmakeargs+=( -DBUILD_RELEASE=ON )
fi