summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2011-08-31 21:25:28 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2011-08-31 21:25:28 +0000
commit55f0a2c41225bd5691a2446d798fb73c70d76a4c (patch)
tree277e764129bcf00c520f4cfb9bbbb3a705070a90 /media-sound/xwax
parentFix as-needed issue (bug #381345). (diff)
downloadgentoo-2-55f0a2c41225bd5691a2446d798fb73c70d76a4c.tar.gz
gentoo-2-55f0a2c41225bd5691a2446d798fb73c70d76a4c.tar.bz2
gentoo-2-55f0a2c41225bd5691a2446d798fb73c70d76a4c.zip
Addressed the inadvertent use of git during compile
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/xwax')
-rw-r--r--media-sound/xwax/ChangeLog7
-rw-r--r--media-sound/xwax/xwax-1.0.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/media-sound/xwax/ChangeLog b/media-sound/xwax/ChangeLog
index 2eff0b5a165c..447245196088 100644
--- a/media-sound/xwax/ChangeLog
+++ b/media-sound/xwax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/xwax
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.34 2011/08/04 02:43:12 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.35 2011/08/31 21:25:28 nixphoeni Exp $
+
+ 31 Aug 2011; Joe Sapp <nixphoeni@gentoo.org> xwax-1.0.ebuild:
+ Compressed sed in src_prepare() and use it to really eliminate the dependency
+ on git. Combined with passing VERSION to emake, this sets the right version
+ without git.
*xwax-1.0 (04 Aug 2011)
diff --git a/media-sound/xwax/xwax-1.0.ebuild b/media-sound/xwax/xwax-1.0.ebuild
index 504f8ffbe900..6a5daefbad4d 100644
--- a/media-sound/xwax/xwax-1.0.ebuild
+++ b/media-sound/xwax/xwax-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-1.0.ebuild,v 1.1 2011/08/04 02:43:12 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-1.0.ebuild,v 1.2 2011/08/31 21:25:28 nixphoeni Exp $
EAPI=4
inherit toolchain-funcs
@@ -16,7 +16,8 @@ IUSE="alsa jack oss cdda mp3 +fallback"
REQUIRED_USE="|| ( cdda mp3 fallback )
|| ( alsa jack oss )"
-RDEPEND="media-libs/libsdl
+RDEPEND="sys-libs/glibc
+ media-libs/libsdl
media-libs/sdl-ttf
media-fonts/dejavu
alsa? ( media-libs/alsa-lib )
@@ -31,10 +32,10 @@ DOCS="README CHANGES"
src_prepare() {
# Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
# the Makefile
- # Also replace VERSION so we don't have to depend on git...
- sed -i -e 's:\(^CFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- -e 's:\(^LDFLAGS.*\)-O[0-9]\(.*\):\1\2:' \
- -e "s:\(^VERSION =\).*:\1 ${PV}:" \
+ # Also remove the dependency on the .version target so we don't need
+ # git just to build
+ sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
+ -e 's/^xwax\.o:.*\.version//' \
Makefile || die "sed failed"
# Replace any decoder commands in the import script, if necessary
@@ -66,7 +67,7 @@ src_configure() {
src_compile() {
# EXECDIR is the default directory in which xwax will look for
# the 'xwax-import' and 'xwax-scan' scripts
- emake EXECDIR="${EROOT}usr/bin"
+ emake EXECDIR="\$(BINDIR)" VERSION="${PV}"
}
src_install() {