summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-15 08:24:21 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-15 08:24:21 +0000
commitb08def676874766c91a096047c06756ea617121e (patch)
treeb03e1cf506718318c703b51ae91285e1e5670415 /media-sound/zinf
parentversion bump, closes #52484 (Manifest recommit) (diff)
downloadgentoo-2-b08def676874766c91a096047c06756ea617121e.tar.gz
gentoo-2-b08def676874766c91a096047c06756ea617121e.tar.bz2
gentoo-2-b08def676874766c91a096047c06756ea617121e.zip
Fixups for configure to handle --disable-corba to close bug #56569.
Diffstat (limited to 'media-sound/zinf')
-rw-r--r--media-sound/zinf/ChangeLog6
-rw-r--r--media-sound/zinf/files/zinf-2.2.5-configure.patch154
-rw-r--r--media-sound/zinf/zinf-2.2.5-r1.ebuild23
3 files changed, 180 insertions, 3 deletions
diff --git a/media-sound/zinf/ChangeLog b/media-sound/zinf/ChangeLog
index d2d5f82c680c..34d9ee973127 100644
--- a/media-sound/zinf/ChangeLog
+++ b/media-sound/zinf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/zinf
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.28 2004/07/01 07:44:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.29 2004/07/15 08:24:21 eradicator Exp $
+
+ 15 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/zinf-2.2.5-configure.patch:
+ Fixups for configure to handle --disable-corba to close bug #56569.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> zinf-2.2.5-r1.ebuild:
Stable amd64.
diff --git a/media-sound/zinf/files/zinf-2.2.5-configure.patch b/media-sound/zinf/files/zinf-2.2.5-configure.patch
new file mode 100644
index 000000000000..83485a3c10a2
--- /dev/null
+++ b/media-sound/zinf/files/zinf-2.2.5-configure.patch
@@ -0,0 +1,154 @@
+diff -Naur zinf-2.2.5.orig/configure.ac zinf-2.2.5/configure.ac
+--- zinf-2.2.5.orig/configure.ac 2004-02-17 14:09:01.000000000 -0800
++++ zinf-2.2.5/configure.ac 2004-07-15 01:16:18.803000641 -0700
+@@ -260,7 +260,11 @@
+ AC_ARG_ENABLE(x86opts,
+ AC_HELP_STRING([--disable-x86opts],
+ [Don't use any x86 assembly optimizations]),
+- true, enable_x86=yes)
++ [case "${enableval}" in
++ yes) enable_x86="yes" ;;
++ no) enable_x86="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-x86opts) ;;
++ esac], enable_x86=yes)
+
+ if test "x$enable_x86" = "xyes"; then
+ if expr "$host_cpu" : "i.86$" > /dev/null; then
+@@ -387,7 +391,11 @@
+ dnl ALSA
+ AC_ARG_ENABLE(alsa, AC_HELP_STRING([--disable-alsa],
+ [Don't compile the ALSA output plugin]),
+- true, enable_alsa=yes)
++ [case "${enableval}" in
++ yes) enable_alsa="yes" ;;
++ no) enable_alsa="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-alsa) ;;
++ esac], enable_alsa=yes)
+
+ if test "$enable_alsa" = "yes"; then
+ dnl AM_PATH_ALSA sets some vars we don't want set
+@@ -405,7 +413,11 @@
+
+ AC_ARG_ENABLE(esd, AC_HELP_STRING([--disable-esd],
+ [Don't compile the EsounD output plugin]),
+- true, enable_esd=yes)
++ [case "${enableval}" in
++ yes) enable_esd="yes" ;;
++ no) enable_esd="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-esd) ;;
++ esac], enable_esd=yes)
+
+ if test "$enable_esd" = "yes"; then
+ AM_PATH_ESD(0.2.12, have_esound=true, have_esound=false)
+@@ -420,7 +432,11 @@
+
+ AC_ARG_ENABLE(arts, AC_HELP_STRING([--disable-arts],
+ [Don't try to compile the arts plugin]),
+- true, enable_arts=yes)
++ [case "${enableval}" in
++ yes) enable_arts="yes" ;;
++ no) enable_arts="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-esd) ;;
++ esac], enable_arts=yes)
+
+ if test "x$enable_arts" = "xyes"; then
+ AC_PATH_PROG(ARTSCCONFIG, artsc-config, [not found])
+@@ -519,17 +535,19 @@
+ dnl corba UI
+ AC_ARG_ENABLE(corba, AC_HELP_STRING([--enable-corba],
+ [Compile the CORBA UI plugin]),
+- [AM_PATH_ORBIT(0.5.0, have_orbit=true, have_orbit=false)
+- if "$have_orbit" = yes; then
+- enable_corba_ui=yes
+- else
+- enable_corba_ui=no
+- AC_MSG_ERROR(Need ORBIT to build the corba UI)
+- fi],
+- [enable_corba_ui=no])
++ [case "${enableval}" in
++ yes) enable_corba_ui="yes" ;;
++ no) enable_corba_ui="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-corba) ;;
++ esac], enable_corba_ui=no)
+
+ if test "$enable_corba_ui" = "yes"; then
+- UI_PLUGINS="$UI_PLUGINS corba"
++ AM_PATH_ORBIT(0.5.0, have_orbit=true, have_orbit=false)
++ if "$have_orbit" = yes; then
++ UI_PLUGINS="$UI_PLUGINS corba"
++ else
++ AC_MSG_ERROR(Need ORBIT to build the corba UI)
++ fi
+ else
+ AC_MSG_NOTICE(Not building the CORBA UI plugin)
+ fi
+@@ -537,22 +555,22 @@
+ dnl xosd
+ AC_ARG_ENABLE(xosd, AC_HELP_STRING([--enable-xosd],
+ [Compile the XOSD On Screen Display]),
+- [AM_PATH_LIBXOSD(have_xosd=true,have_xosd=false)
+- if test "$have_xosd" = "true" ; then
+- enable_xosd_ui=yes
+- else
+- enable_xosd_ui=no
+- AC_MSG_ERROR(Need libxosd to build xosd)
+- fi],
+- [enable_xosd_ui=no])
+-
+-if test "$enable_xosd_ui" == "yes"; then
++ [case "${enableval}" in
++ yes) enable_xosd_ui="yes" ;;
++ no) enable_xosd_ui="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-corba) ;;
++ esac], enable_xosd_ui=no)
++
++if test "$enable_xosd_ui" = "yes"; then
++ AM_PATH_LIBXOSD(have_xosd=true,have_xosd=false)
++ if "$have_xosd" = yes; then
+ UI_PLUGINS="$UI_PLUGINS xosd"
++ else
++ AC_MSG_ERROR(Need xosd to build the xosd UI)
++ fi
+ else
+ AC_MSG_NOTICE(Not building the XOSD plugin)
+-fi
+-
+-
++fi
+
+ AC_SUBST(UI_PLUGINS)
+
+diff -Naur zinf-2.2.5.orig/m4/libxosd.m4 zinf-2.2.5/m4/libxosd.m4
+--- zinf-2.2.5.orig/m4/libxosd.m4 1969-12-31 16:00:00.000000000 -0800
++++ zinf-2.2.5/m4/libxosd.m4 2004-07-15 01:16:41.275272219 -0700
+@@ -0,0 +1,30 @@
++# Oron Peled (Sun Jun 30 2002)
++# Taken from libglade.m4
++
++# a macro to get the libs/cflags for libxosd
++
++dnl AM_PATH_LIBXOSD([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
++dnl Test to see if libxosd is installed, and define LIBXOSD_CFLAGS, LIBXOSDLIBS
++dnl
++AC_DEFUN(AM_PATH_LIBXOSD,
++[dnl
++dnl Get the cflags and libraries from the xosd-config script
++dnl
++AC_ARG_WITH(xosd-config,
++AC_HELP_STRING([--with-xosd-config=LIBXOSD_CONFIG],[Location of xosd-config]),
++LIBXOSD_CONFIG="$withval")
++
++AC_PATH_PROG(LIBXOSD_CONFIG, xosd-config, no)
++AC_MSG_CHECKING(for libxosd)
++if test "$LIBXOSD_CONFIG" = "no"; then
++ AC_MSG_RESULT(no)
++ ifelse([$2], , :, [$2])
++else
++ LIBXOSD_CFLAGS=`$LIBXOSD_CONFIG --cflags`
++ LIBXOSD_LIBS=`$LIBXOSD_CONFIG --libs`
++ AC_MSG_RESULT(yes)
++ ifelse([$1], , :, [$1])
++fi
++AC_SUBST(LIBXOSD_CFLAGS)
++AC_SUBST(LIBXOSD_LIBS)
++])
diff --git a/media-sound/zinf/zinf-2.2.5-r1.ebuild b/media-sound/zinf/zinf-2.2.5-r1.ebuild
index 0df5dcea0d8c..ef5d03e6be7d 100644
--- a/media-sound/zinf/zinf-2.2.5-r1.ebuild
+++ b/media-sound/zinf/zinf-2.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.5-r1.ebuild,v 1.4 2004/07/01 07:44:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.5-r1.ebuild,v 1.5 2004/07/15 08:24:21 eradicator Exp $
inherit kde-functions eutils flag-o-matic
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
>=media-libs/id3lib-3.8.0
dev-libs/boost
dev-db/metakit
+ >=sys-devel/automake-1.7
dev-lang/perl"
src_unpack() {
@@ -40,11 +41,29 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-cdplay.patch
+ epatch ${FILESDIR}/${P}-configure.patch
+
+ export WANT_AUTOMAKE=1.7
+ export WANT_AUTOCONF=2.5
+
+ ebegin "Running aclocal (${WANT_AUTOMAKE})"
+ aclocal -I m4
+ eend $?
+
+ ebegin "Running automake (${WANT_AUTOMAKE})"
+ automake
+ eend $?
+
+ ebegin "Running autoconf (${WANT_AUTOCONF})"
+ autoconf
+ eend $?
}
src_compile() {
local myconf="--enable-cmdline"
+ use x86 || myconf="${myconf} --disable-x86opts"
+
myconf="${myconf} `use_enable debug`"
myconf="${myconf} `use_enable esd`"
myconf="${myconf} `use_enable arts`"
@@ -52,7 +71,7 @@ src_compile() {
myconf="${myconf} `use_enable gnome corba`"
myconf="${myconf} `use_enable ipv6`"
- if [ $ARCH == "amd64" ]; then
+ if use amd64; then
replace-flags -O? -O
append-flags -frerun-cse-after-loop
fi