summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-08 23:43:48 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-08 23:43:48 +0000
commit0eee9e5b69f1b96c5f4ca299a46725daa412ac7b (patch)
tree9f7f6f7367119bdc75a988f3bb43a85d422e3e6c /media-sound
parentInitial import. (diff)
downloadgentoo-2-0eee9e5b69f1b96c5f4ca299a46725daa412ac7b.tar.gz
gentoo-2-0eee9e5b69f1b96c5f4ca299a46725daa412ac7b.tar.bz2
gentoo-2-0eee9e5b69f1b96c5f4ca299a46725daa412ac7b.zip
Version bump.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gnump3d/ChangeLog7
-rw-r--r--media-sound/gnump3d/files/digest-gnump3d-2.21
-rw-r--r--media-sound/gnump3d/files/gnump3d-2.2.rc619
-rw-r--r--media-sound/gnump3d/gnump3d-2.2.ebuild49
4 files changed, 75 insertions, 1 deletions
diff --git a/media-sound/gnump3d/ChangeLog b/media-sound/gnump3d/ChangeLog
index 8844ebf5fdf2..66e965e6be7b 100644
--- a/media-sound/gnump3d/ChangeLog
+++ b/media-sound/gnump3d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/gnump3d
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.7 2003/02/12 07:28:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.8 2003/03/08 23:43:48 aliz Exp $
+
+*gnump3d-2.2 (09 Mar 2003)
+
+ 09 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*gnump3d-1.0 (18 Dec 2002)
diff --git a/media-sound/gnump3d/files/digest-gnump3d-2.2 b/media-sound/gnump3d/files/digest-gnump3d-2.2
new file mode 100644
index 000000000000..532498c73dc0
--- /dev/null
+++ b/media-sound/gnump3d/files/digest-gnump3d-2.2
@@ -0,0 +1 @@
+MD5 10849cbaaa2c4a1589ec69b30fd04e47 gnump3d-2.2.tar.gz 173740
diff --git a/media-sound/gnump3d/files/gnump3d-2.2.rc6 b/media-sound/gnump3d/files/gnump3d-2.2.rc6
new file mode 100644
index 000000000000..23d2b705f9d3
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d-2.2.rc6
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting gnump3d"
+ start-stop-daemon --start --quiet --exec /usr/bin/gnump3d -- --background --quiet
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gnump3d"
+ start-stop-daemon --stop --quiet --exec /usr/bin/gnump3d
+ eend $?
+}
diff --git a/media-sound/gnump3d/gnump3d-2.2.ebuild b/media-sound/gnump3d/gnump3d-2.2.ebuild
new file mode 100644
index 000000000000..ef663dac8a2b
--- /dev/null
+++ b/media-sound/gnump3d/gnump3d-2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-2.2.ebuild,v 1.1 2003/03/08 23:43:48 aliz Exp $
+
+inherit eutils
+
+DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
+SRC_URI="mirror://sourceforge/gnump3d/${P}.tar.gz"
+HOMEPAGE="http://gnump3d.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-devel/perl-5.6.1"
+
+src_install() {
+ eval `perl '-V:installarchlib'`
+ ARCH_LIB=${installarchlib}
+
+ insinto ${ARCH_LIB}/gnump3d
+ doins lib/gnump3d/*.pm
+
+ insinto ${ARCH_LIB}/gnump3d/plugins
+ doins lib/gnump3d/plugins/*.pm
+
+ into /usr
+
+ dobin bin/gnump3d2 bin/gnump3d-top
+ dosym /usr/bin/gnump3d2 /usr/bin/gnump3d
+
+ doman man/*.1
+
+ for a in templates/*; do
+ insinto /usr/share/gnump3d/${a/templates}
+ doins templates/${a/templates}/*
+ done
+
+ insinto /etc/init.d
+ newins ${FILESDIR}/gnump3d-${PV}.rc6 gnump3d
+
+ insinto /etc/gnump3d
+ doins etc/gnump3d.conf etc/mime.types
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+}
+