summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-01 07:17:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-01 07:17:22 +0000
commitd5fd45eb368562ab0dd36ee3dfa9204ae1e531cc (patch)
tree35b81dabd37efe46c735b4365f3a39b039ad89d6 /media-sound
parentNew package (diff)
downloadgentoo-2-d5fd45eb368562ab0dd36ee3dfa9204ae1e531cc.tar.gz
gentoo-2-d5fd45eb368562ab0dd36ee3dfa9204ae1e531cc.tar.bz2
gentoo-2-d5fd45eb368562ab0dd36ee3dfa9204ae1e531cc.zip
Fixed localization file problem.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lopster/ChangeLog10
-rw-r--r--media-sound/lopster/files/digest-lopster-1.0.1-r21
-rw-r--r--media-sound/lopster/lopster-1.0.1-r2.ebuild34
3 files changed, 43 insertions, 2 deletions
diff --git a/media-sound/lopster/ChangeLog b/media-sound/lopster/ChangeLog
index 6a3643ea8eb2..d6d5727a948a 100644
--- a/media-sound/lopster/ChangeLog
+++ b/media-sound/lopster/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for media-sound/lopster
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lopster/ChangeLog,v 1.2 2002/04/18 07:18:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lopster/ChangeLog,v 1.3 2002/05/01 07:17:22 rphillips Exp $
+
+*lopster-1.0.1-r2 (30 Apr 2002)
+
+ 30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> lopster-1.0.1-r2.ebuild :
+
+ Fixed ebuild to install localization files into the correct place.
*lopster-1.0.1-r1 (18 Apr 2002)
- 18 Apr 2002; Ryan Phillips <rphillips@gentoo.org> lopster-1.0.1-r1.ebuild
+ 18 Apr 2002; Ryan Phillips <rphillips@gentoo.org> lopster-1.0.1-r1.ebuild :
Copied lopster-0.9.9-r1.ebuild to newer stable version. Bug (#1717)
diff --git a/media-sound/lopster/files/digest-lopster-1.0.1-r2 b/media-sound/lopster/files/digest-lopster-1.0.1-r2
new file mode 100644
index 000000000000..48523545d52a
--- /dev/null
+++ b/media-sound/lopster/files/digest-lopster-1.0.1-r2
@@ -0,0 +1 @@
+MD5 536e31b0864e0f5af2fe50807225e797 lopster-1.0.1.tar.gz 554722
diff --git a/media-sound/lopster/lopster-1.0.1-r2.ebuild b/media-sound/lopster/lopster-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..53d48f7d6b0b
--- /dev/null
+++ b/media-sound/lopster/lopster-1.0.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lopster/lopster-1.0.1-r2.ebuild,v 1.1 2002/05/01 07:17:22 rphillips Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Napster Client using GTK"
+SRC_URI="http://download.sourceforge.net/lopster/${A}"
+HOMEPAGE="http://lopster.sourceforge.net"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+ >=x11-libs/gtk+-1.2.10-r4
+ virtual/x11"
+
+RDEPEND="virtual/glibc
+ >=x11-libs/gtk+-1.2.10-r4
+ virtual/x11"
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} gnulocaledir=/usr/share/locale install
+ dodoc AUTHORS BUGS COPYING README ChangeLog NEWS
+}
+