summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-13 05:25:04 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-13 05:25:04 +0000
commit45883b615fadd42399e80d2a8fdfbec51561b4b2 (patch)
treeea9f7c8342dd1eb1733a6083e1d337a0323de760 /media-video/em8300-libraries
parentforgot to add this (diff)
downloadgentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.tar.gz
gentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.tar.bz2
gentoo-2-45883b615fadd42399e80d2a8fdfbec51561b4b2.zip
bump
Diffstat (limited to 'media-video/em8300-libraries')
-rw-r--r--media-video/em8300-libraries/ChangeLog9
-rw-r--r--media-video/em8300-libraries/em8300-libraries-0.13.0.ebuild82
-rw-r--r--media-video/em8300-libraries/files/digest-em8300-libraries-0.13.01
3 files changed, 90 insertions, 2 deletions
diff --git a/media-video/em8300-libraries/ChangeLog b/media-video/em8300-libraries/ChangeLog
index 7fe312215c0c..b6496d758157 100644
--- a/media-video/em8300-libraries/ChangeLog
+++ b/media-video/em8300-libraries/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/em8300-libraries
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.3 2002/05/11 17:15:45 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.4 2002/12/13 05:25:04 lostlogic Exp $
+
+*em8300-libraries-0.13.0 (12 Dec 2002)
+
+ 12 Dec 2002; Brandon Low <lostlogic@gentoo.org> em8300-libraries-0.13.0 :
+ Bump
*em8300-libraries-0.12.0-r1 (April 29, 2002)
@@ -17,4 +22,4 @@
22 April 2002; Arcady Genkin <agenkin@thpoon.com> em8300-libraries-0.12.0 :
- Initial version, submitted by Brandon Low <lostlogic@lostlogicx.com>. \ No newline at end of file
+ Initial version, submitted by Brandon Low <lostlogic@lostlogicx.com>.
diff --git a/media-video/em8300-libraries/em8300-libraries-0.13.0.ebuild b/media-video/em8300-libraries/em8300-libraries-0.13.0.ebuild
new file mode 100644
index 000000000000..461fdfa4b98c
--- /dev/null
+++ b/media-video/em8300-libraries/em8300-libraries-0.13.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/em8300-libraries-0.13.0.ebuild,v 1.1 2002/12/13 05:25:04 lostlogic Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card libraries"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${P/-libraries/}.tar.gz"
+
+DEPEND="media-video/em8300-modules
+ x11-libs/gtk+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ mv ${A/.tar.gz/} ${P}
+
+ cd ${S}
+ #Eliminate extra compiling and prune out some disk space usage
+ sed -e "s:modules/\ ::g" \
+ -e "s:\ modules.tar.gz::g" \
+ Makefile.in > Makefile.in.hacked
+ mv Makefile.in.hacked Makefile.in
+
+}
+
+src_compile () {
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share || die
+ make all || die
+
+}
+
+src_install () {
+
+ cd ${S}/scripts
+ mv microcode_upload.pl microcode_upload.pl.old
+ sed -e "s:/usr/share/misc/em8300.uc:/usr/share/em8300/em8300.uc:g" \
+ < microcode_upload.pl.old > microcode_upload.pl
+ rm microcode_upload.pl.old
+ cd ${S}
+
+ make em8300incdir=${D}/usr/include/linux/ \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ sysconfdir=/etc \
+ oldincludedir=${D}/usr/include \
+ install || die
+
+ insinto /usr/share/em8300
+ doins modules/em8300.uc
+
+ #this isn't how the installer does this, but it makes more
+ #sense than copying it like they do.
+ dosym /usr/share/em8300/microcode_upload.pl /usr/bin/em8300init
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "The em8300 libraries and modules have now beein installed,"
+ einfo "you will probably want to add /usr/bin/em8300init to your"
+ einfo "/etc/conf.d/local.start so that your em8300 card is "
+ einfo "properly initialized on boot."
+ einfo
+ einfo "If you still need a microcode other than the one included"
+ einfo "with the package, you can simply use em8300init <microcode.ux>"
+ einfo
+
+}
diff --git a/media-video/em8300-libraries/files/digest-em8300-libraries-0.13.0 b/media-video/em8300-libraries/files/digest-em8300-libraries-0.13.0
new file mode 100644
index 000000000000..16fb28e78d14
--- /dev/null
+++ b/media-video/em8300-libraries/files/digest-em8300-libraries-0.13.0
@@ -0,0 +1 @@
+MD5 306984dfd4f0f29538179cbbf391f5a8 em8300-0.13.0.tar.gz 383592