summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-21 13:29:40 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-21 13:29:40 +0000
commit90e778e11b27691ca701f0768b2c0f4a5f0a18b5 (patch)
tree4fda3a4b5944905499a6d19b3c4ae9d1c507d165 /media-video/ffdiaporama
parentPin dev-qt/designer to SLOT 4. (diff)
downloadgentoo-2-90e778e11b27691ca701f0768b2c0f4a5f0a18b5.tar.gz
gentoo-2-90e778e11b27691ca701f0768b2c0f4a5f0a18b5.tar.bz2
gentoo-2-90e778e11b27691ca701f0768b2c0f4a5f0a18b5.zip
fix build with media-video/ffmpeg-2.0 wrt #476530
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-video/ffdiaporama')
-rw-r--r--media-video/ffdiaporama/ChangeLog6
-rw-r--r--media-video/ffdiaporama/ffdiaporama-1.6.ebuild3
-rw-r--r--media-video/ffdiaporama/files/ffdiaporama-1.6-ffmpeg-2.0.patch32
3 files changed, 39 insertions, 2 deletions
diff --git a/media-video/ffdiaporama/ChangeLog b/media-video/ffdiaporama/ChangeLog
index 7e1e83033b01..32a8d3a017a9 100644
--- a/media-video/ffdiaporama/ChangeLog
+++ b/media-video/ffdiaporama/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffdiaporama
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.10 2013/07/05 21:56:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.11 2013/07/21 13:29:40 hasufell Exp $
+
+ 21 Jul 2013; Julian Ospald <hasufell@gentoo.org> ffdiaporama-1.6.ebuild,
+ +files/ffdiaporama-1.6-ffmpeg-2.0.patch:
+ fix build with media-video/ffmpeg-2.0 wrt #476530
05 Jul 2013; Julian Ospald <hasufell@gentoo.org> ffdiaporama-1.6.ebuild,
metadata.xml:
diff --git a/media-video/ffdiaporama/ffdiaporama-1.6.ebuild b/media-video/ffdiaporama/ffdiaporama-1.6.ebuild
index f5ac7b9ebb68..34e0171833a0 100644
--- a/media-video/ffdiaporama/ffdiaporama-1.6.ebuild
+++ b/media-video/ffdiaporama/ffdiaporama-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ffdiaporama-1.6.ebuild,v 1.2 2013/07/05 21:56:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ffdiaporama-1.6.ebuild,v 1.3 2013/07/21 13:29:40 hasufell Exp $
EAPI=5
@@ -29,6 +29,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
DOCS=( authors.txt )
+PATCHES=( "${FILESDIR}"/${P}-ffmpeg-2.0.patch )
src_unpack() {
# S=${WORKDIR} would result in unremoved files in
diff --git a/media-video/ffdiaporama/files/ffdiaporama-1.6-ffmpeg-2.0.patch b/media-video/ffdiaporama/files/ffdiaporama-1.6-ffmpeg-2.0.patch
new file mode 100644
index 000000000000..6142cd5a37f8
--- /dev/null
+++ b/media-video/ffdiaporama/files/ffdiaporama-1.6-ffmpeg-2.0.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/show_bug.cgi?id=476530
+
+--- src/engine/cDeviceModelDef.h 2013-06-19 18:22:52.000000000 +0200
++++ src/engine/cDeviceModelDef.h 2013-07-21 14:11:48.014827071 +0200
+@@ -64,6 +64,11 @@
+ #include <libavformat/avformat.h>
+ #include <libavformat/avio.h>
+
++ #if (LIBAVCODEC_VERSION_INT>=AV_VERSION_INT(55,18,0))
++ typedef AVCodecID CodecID;
++ #define AVCODEC_MAX_AUDIO_FRAME_SIZE 192
++ #endif
++
+ #if ((LIBAVUTIL_VERSION_INT>=AV_VERSION_INT(51,73,0))&&(LIBAVCODEC_VERSION_INT>=AV_VERSION_INT(54,31,0))&&(LIBAVFORMAT_VERSION_INT>=AV_VERSION_INT(54,19,0)))
+ #define LIBAV_09
+ #if defined(USELIBAVRESAMPLE)
+
+--- src/engine/cBaseMediaFile.cpp 2013-06-19 18:22:52.000000000 +0200
++++ src/engine/cBaseMediaFile.cpp 2013-07-21 14:15:18.754228717 +0200
+@@ -2167,7 +2167,11 @@
+ }
+
+ #else
+- int Ret=av_buffersrc_add_frame(VideoFilterIn,FrameBufferYUV,0);
++ #if (LIBAVFILTER_VERSION_INT < AV_VERSION_INT(3,79,0))
++ int Ret=av_buffersrc_add_frame(VideoFilterIn,FrameBufferYUV,0);
++ #else
++ int Ret=av_buffersrc_add_frame(VideoFilterIn,FrameBufferYUV);
++ #endif
+ if (Ret<0) {
+ ToLog(LOGMSG_CRITICAL,QString("Error in cVideoFile::VideoFilter_Process : av_buffersrc_add_frame"));
+ return VC_ERROR;