summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-09-05 15:22:35 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-09-05 15:22:35 +0000
commita3384c412cf01e4afb2b3af041573dd067c22cf1 (patch)
tree1a3848e7e9ff8e4d95becf50bc4616dd2fc08ed2 /media-video/lives
parentMarking hoe-2.3.2 ppc64 for bug 280851 (diff)
downloadgentoo-2-a3384c412cf01e4afb2b3af041573dd067c22cf1.tar.gz
gentoo-2-a3384c412cf01e4afb2b3af041573dd067c22cf1.tar.bz2
gentoo-2-a3384c412cf01e4afb2b3af041573dd067c22cf1.zip
Version Bump
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-video/lives')
-rw-r--r--media-video/lives/ChangeLog9
-rw-r--r--media-video/lives/lives-1.0.0.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/media-video/lives/ChangeLog b/media-video/lives/ChangeLog
index 53c028d4570a..f9e4097d1c46 100644
--- a/media-video/lives/ChangeLog
+++ b/media-video/lives/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/lives
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.27 2008/06/13 21:14:05 yngwin Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.28 2009/09/05 15:22:35 lu_zero Exp $
+
+*lives-1.0.0 (05 Sep 2009)
+
+ 05 Sep 2009; Luca Barbato <lu_zero@gentoo.org> +lives-1.0.0.ebuild:
+ Version Bump
*lives-0.9.8.12 (13 Jun 2008)
diff --git a/media-video/lives/lives-1.0.0.ebuild b/media-video/lives/lives-1.0.0.ebuild
new file mode 100644
index 000000000000..da61e3e312db
--- /dev/null
+++ b/media-video/lives/lives-1.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-1.0.0.ebuild,v 1.1 2009/09/05 15:22:35 lu_zero Exp $
+
+inherit flag-o-matic
+
+MY_P="LiVES-${PV}"
+DESCRIPTION="LiVES is a Video Editing System"
+HOMEPAGE="http://lives.sf.net"
+SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
+ # sf.net only has rpms for this version
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="matroska ogg theora libvisual nls" #sdl jack dv"
+DEPEND=">=media-video/mplayer-0.90-r2
+ >=media-gfx/imagemagick-5.5.6
+ >=dev-lang/perl-5.8.0-r12
+ >=x11-libs/gtk+-2.2.1
+ media-libs/libsdl
+ >=media-video/ffmpeg-0.4.8
+ >=media-libs/jpeg-6b-r3
+ >=media-sound/sox-12.17.3-r3
+ virtual/cdrtools
+ theora? ( media-libs/libtheora )
+ >=dev-lang/python-2.3.4
+ matroska? ( media-video/mkvtoolnix
+ media-libs/libmatroska )
+ ogg? ( media-sound/ogmtools )
+ >=media-video/mjpegtools-1.6.2
+ libvisual? ( media-libs/libvisual )
+ media-sound/jack-audio-connection-kit
+ sys-libs/libavc1394"
+
+src_unpack() {
+ unpack ${A}
+ # hardcoding -03 is wrong!
+ sed -i -e "s:-O3::g" \
+ "${S}"/{,src,lives-plugins,lives-plugins/plugins/playback/video,lives-plugins/weed-plugins}/Makefile*
+}
+
+src_compile() {
+ econf \
+ $(use_enable libvisual) \
+ $(use_enable nls) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS FEATURES GETTING.STARTED
+}