summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Bevitt <cyfred@gentoo.org>2004-07-02 05:34:24 +0000
committerAndrew Bevitt <cyfred@gentoo.org>2004-07-02 05:34:24 +0000
commit0a489a4d8ec58e8a06fc9c1636a18d83c39e6367 (patch)
tree3aecdfe5a8fd5259aa95c202669744f7b43aad2b /media-video/nvidia-kernel
parentAdding nvidia-kernel-1.0.6106 (Manifest recommit) (diff)
downloadgentoo-2-0a489a4d8ec58e8a06fc9c1636a18d83c39e6367.tar.gz
gentoo-2-0a489a4d8ec58e8a06fc9c1636a18d83c39e6367.tar.bz2
gentoo-2-0a489a4d8ec58e8a06fc9c1636a18d83c39e6367.zip
"pulling 6106 for a minute, digest generation is broken"
Diffstat (limited to 'media-video/nvidia-kernel')
-rw-r--r--media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.61061
-rw-r--r--media-video/nvidia-kernel/nvidia-kernel-1.0.6106.ebuild122
2 files changed, 0 insertions, 123 deletions
diff --git a/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.6106 b/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.6106
deleted file mode 100644
index 3e0157fffab3..000000000000
--- a/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.6106
+++ /dev/null
@@ -1 +0,0 @@
-MD5 024f21a3fa134bee8339adac64bdc77a NVIDIA-Linux-x86_64-1.0-6106-pkg2.run 7331301
diff --git a/media-video/nvidia-kernel/nvidia-kernel-1.0.6106.ebuild b/media-video/nvidia-kernel/nvidia-kernel-1.0.6106.ebuild
deleted file mode 100644
index 7f8741514376..000000000000
--- a/media-video/nvidia-kernel/nvidia-kernel-1.0.6106.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvidia-kernel/nvidia-kernel-1.0.6106.ebuild,v 1.1 2004/07/02 05:26:46 cyfred Exp $
-
-inherit eutils kmod
-
-if use x86; then
- PKG_V="pkg1"
-elif use amd64 ; then
- PKG_V="pkg2"
-fi
-NV_V="${PV/1.0./1.0-}"
-if use x86; then
- NV_PACKAGE="NVIDIA-Linux-x86-${NV_V}"
-elif use amd64 ; then
- NV_PACKAGE="NVIDIA-Linux-x86_64-${NV_V}"
-fi
-S="${WORKDIR}/${NV_PACKAGE}-${PKG_V}/usr/src/nv"
-DESCRIPTION="Linux kernel module for then NVIDIA X11 driver"
-HOMEPAGE="http://www.nvidia.com/"
-SRC_URI="x86? (ftp://download.nvidia.com/XFree86/Linux-x86/${NV_V}/${NV_PACKAGE}-${PKG_V}.run)
- amd64? (http://download.nvidia.com/XFree86/Linux-x86_64/${NV_V}/${NV_PACKAGE}-${PKG_V}.run)"
-
-# The slot needs to be set to $KV to prevent unmerges of modules for other kernels.
-LICENSE="NVIDIA"
-SLOT="${KV}"
-KEYWORDS="-* ~x86 ~amd64"
-RESTRICT="nostrip"
-IUSE=""
-
-DEPEND="virtual/linux-sources"
-export _POSIX2_VERSION="199209"
-
-KMOD_SOURCES="none"
-
-mtrr_check() {
- if [ ! -f /proc/mtrr ]
- then
- eerror "This version needs MTRR support for most chipsets!"
- eerror "Please enable MTRR support in your kernel config, found at:"
- eerror
- eerror " Processor type and features -> [*] MTRR (Memory Type Range Register) support"
- eerror
- eerror "and recompile your kernel ..."
- die "MTRR support not detected!"
- fi
-}
-
-pkg_setup() {
- mtrr_check
-}
-
-src_unpack() {
- # Let the kmod eclass set the variables for us
- kmod_src_unpack
-
- cd ${WORKDIR}
- bash ${DISTDIR}/${NV_PACKAGE}-${PKG_V}.run --extract-only
-
- # Add patches below, with a breif description.
- # 1) SYSFS supported by nvidia
- # 2) minion.de patches not released yet
-
- cd ${S}
-
- # Add koutput compile time support... this is hackish
- epatch ${FILESDIR}/${PV}/NVIDIA_kernel-${NV_V}-koutput-support.patch
-
- # if you set this then it's your own fault when stuff breaks :)
- [ ! -z "${USE_CRAZY_OPTS}" ] && sed -i "s:-O:${CFLAGS}:" Makefile.*
-}
-
-src_compile() {
- # IGNORE_CC_MISMATCH disables a sanity check that's needed when gcc has been
- # updated but the running kernel is still compiled with an older gcc. This is
- # needed for chrooted building, where the sanity check detects the gcc of the
- # kernel outside the chroot rather than within.
- if is_kernel 2 5 || is_kernel 2 6
- then
- unset ARCH
- fi
- make IGNORE_CC_MISMATCH="yes" SYSSRC="${KERNEL_DIR}" KVOUT="${KV_OUTPUT}" \
- clean module V=1 || die "Failed to build module"
-}
-
-src_install() {
- # The driver goes into the standard modules location
- insinto /lib/modules/${KV}/video
-
- # Insert the module
- doins nvidia.${KV_OBJ}
-
- # Add the aliases
- insinto /etc/modules.d
- newins ${FILESDIR}/nvidia-1.1 nvidia
-
- # Docs
- dodoc ${S}/README
-
- # The device creation script
- into /
- newsbin ${S}/makedevices.sh NVmakedevices.sh
-}
-
-pkg_postinst() {
- if [ "${ROOT}" = "/" ]
- then
- # Update module dependency
- [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- if [ ! -e /dev/.devfsd ] && [ ! -e /dev/.udev ] && [ -x /sbin/NVmakedevices.sh ]
- then
- /sbin/NVmakedevices.sh >/dev/null 2>&1
- fi
- fi
-
- echo
- einfo "If you need to load the module automatically on boot up you need"
- einfo "to add \"nvidia\" to /etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
- echo
- einfo "Please note that the driver name is \"nvidia\", not \"NVdriver\""
- echo
-}