summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-12-28 13:57:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-12-28 13:57:20 +0000
commitf0df01748423a5f93b426c6cdbd0c176ea453dcf (patch)
tree36d6c139d736d513b5d5cc53e230996c944f4704 /media-video/parole
parentLet people pass more options to spamd process (#496254 by Evert) (diff)
downloadgentoo-2-f0df01748423a5f93b426c6cdbd0c176ea453dcf.tar.gz
gentoo-2-f0df01748423a5f93b426c6cdbd0c176ea453dcf.tar.bz2
gentoo-2-f0df01748423a5f93b426c6cdbd0c176ea453dcf.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/ChangeLog7
-rw-r--r--media-video/parole/parole-0.5.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-video/parole/ChangeLog b/media-video/parole/ChangeLog
index dedebcd06956..ca35cad4ddca 100644
--- a/media-video/parole/ChangeLog
+++ b/media-video/parole/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/parole
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.40 2013/07/25 12:33:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/ChangeLog,v 1.41 2013/12/28 13:57:20 ssuominen Exp $
+
+*parole-0.5.4 (28 Dec 2013)
+
+ 28 Dec 2013; Samuli Suominen <ssuominen@gentoo.org> +parole-0.5.4.ebuild:
+ Version bump.
*parole-0.5.2 (25 Jul 2013)
diff --git a/media-video/parole/parole-0.5.4.ebuild b/media-video/parole/parole-0.5.4.ebuild
new file mode 100644
index 000000000000..354565383e85
--- /dev/null
+++ b/media-video/parole/parole-0.5.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/parole/parole-0.5.4.ebuild,v 1.1 2013/12/28 13:57:20 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="a simple media player based on the GStreamer framework for the Xfce4 desktop"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/parole/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="debug libnotify taglib"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.32
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ taglib? ( >=media-libs/taglib-1.4 )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable taglib)
+ $(use_enable libnotify notify-plugin)
+ $(xfconf_use_debug)
+ --with-gstreamer=1.0
+ )
+
+ DOCS=( AUTHORS ChangeLog README THANKS TODO )
+}