summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-29 11:14:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-29 11:14:23 +0000
commit9114dac1f113baf1adfeae49baeceec50af4276a (patch)
tree22dfb56577a7b8086bc1ae90c5233a7d8b62088b /media-video/spcaview
parentAllow using heirloom-doctools instead of groff. (diff)
downloadgentoo-2-9114dac1f113baf1adfeae49baeceec50af4276a.tar.gz
gentoo-2-9114dac1f113baf1adfeae49baeceec50af4276a.tar.bz2
gentoo-2-9114dac1f113baf1adfeae49baeceec50af4276a.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-video/spcaview')
-rw-r--r--media-video/spcaview/ChangeLog10
-rw-r--r--media-video/spcaview/files/spcaview-20071224-Makefile.patch122
-rw-r--r--media-video/spcaview/spcaview-20071224.ebuild32
3 files changed, 162 insertions, 2 deletions
diff --git a/media-video/spcaview/ChangeLog b/media-video/spcaview/ChangeLog
index bf8667b2fe18..df0a6d1e44c0 100644
--- a/media-video/spcaview/ChangeLog
+++ b/media-video/spcaview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/spcaview
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spcaview/ChangeLog,v 1.10 2007/07/13 22:04:15 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spcaview/ChangeLog,v 1.11 2009/09/29 11:14:22 ssuominen Exp $
+
+*spcaview-20071224 (29 Sep 2009)
+
+ 29 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +spcaview-20071224.ebuild, +files/spcaview-20071224-Makefile.patch:
+ Version bump.
13 Jul 2007; Mike Frysinger <vapier@gentoo.org>
+files/spcaview-20061208-build.patch, spcaview-20061208.ebuild:
diff --git a/media-video/spcaview/files/spcaview-20071224-Makefile.patch b/media-video/spcaview/files/spcaview-20071224-Makefile.patch
new file mode 100644
index 000000000000..4ef289f2cbe0
--- /dev/null
+++ b/media-video/spcaview/files/spcaview-20071224-Makefile.patch
@@ -0,0 +1,122 @@
+diff -ur spcaview-20071224.orig/Makefile spcaview-20071224/Makefile
+--- spcaview-20071224.orig/Makefile 2005-09-24 23:57:52.000000000 +0300
++++ spcaview-20071224/Makefile 2009-09-29 14:18:00.000000000 +0300
+@@ -2,33 +2,18 @@
+ # spcaview Makefile
+ ##############################
+
+-INSTALLROOT=$(PWD)
++CC ?= gcc
++CFLAGS += $(shell sdl-config --cflags)
++CPPFLAGS += -DUSE_SDL -DLINUX
+
+-CC=gcc
+-CPP=g++
+ INSTALL=install
+ APP_BINARY=spcaview
+ BIN=/usr/local/bin
+ #SDLLIBS= -lSDL -lpthread -lSDL_image
+ SDLLIBS = $(shell sdl-config --libs)
+-SDLFLAGS = $(shell sdl-config --cflags)
+-
+-SERVFLAGS= -O2 -DLINUX $(WARNINGS)
+ MATH_LIB=-lm
+ SERVLIBS= $(MATH_LIB) -lpthread
+
+-#WARNINGS = -Wall \
+-# -Wundef -Wpointer-arith -Wbad-function-cast \
+-# -Wcast-align -Wwrite-strings -Wstrict-prototypes \
+-# -Wmissing-prototypes -Wmissing-declarations \
+-# -Wnested-externs -Winline -Wcast-qual -W \
+-# -Wno-unused
+-# -Wunused
+-
+-CFLAGS = -DUSE_SDL -O2 -DLINUX $(SDLFLAGS) $(WARNINGS)
+-CPPFLAGS = $(CFLAGS)
+-SHCFLAGS= -O2 -ffast-math -fforce-addr -fstrict-aliasing -fomit-frame-pointer
+-#CLIBFLAGS= -O9 -falign-functions=4 -march=athlon
+ #LIB_ENCODE = libjpgenc.a
+ #LIB_ENCODE_OBJECTS = encoder.o huffman.o marker.o quant.o
+
+@@ -52,63 +37,63 @@
+
+ # Applications:
+ spcaview: $(OBJECTS)
+- $(CC) $(CFLAGS) $(OBJECTS) $(X11_LIB) $(XPM_LIB)\
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJECTS) $(X11_LIB) $(XPM_LIB)\
+ $(MATH_LIB) \
+ $(SDLLIBS)\
+ -o $(APP_BINARY)
+ chmod 755 $(APP_BINARY)
+
+ spcaserv: $(OBJSERVER)
+- gcc $(SERVFLAGS) -o spcaserv $(OBJSERVER) $(SERVLIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o spcaserv $(OBJSERVER) $(SERVLIBS)
+
+ spcacat: $(OBJCAT)
+- gcc $(SERVFLAGS) -o spcacat $(OBJCAT) $(SERVLIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o spcacat $(OBJCAT) $(SERVLIBS)
+
+ spcaview.o: spcaview.c jconfig.h dpsh.h utils.h SDL_audioin.h
+
+
+ shc.o : shc.c shc.h
+- $(CC) $(SHCFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+ shclib.o: shclib.c shclib.h
+- $(CC) $(SHCFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+ dpsh.o: dpsh.c dpsh.h
+- $(CC) $(SHCFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ avilib.o: avilib.c avilib.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ server.o: server.c
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ spcacat.o: spcacat.c
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ spcav4l.o: spcav4l.c spcav4l.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ utils.o: utils.c utils.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ picture.o: picture.c picture.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ pargpio.o: pargpio.c pargpio.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ tcputils.o: tcputils.c tcputils.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ encoder.o: encoder.c encoder.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ huffman.o: huffman.c huffman.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ marker.o: marker.c marker.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ quant.o: quant.c quant.h
+- $(CC) $(SERVFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ install_spcaserv: spcaserv
+ $(INSTALL) -s -m 755 -g root -o root spcaserv $(BIN)
diff --git a/media-video/spcaview/spcaview-20071224.ebuild b/media-video/spcaview/spcaview-20071224.ebuild
new file mode 100644
index 000000000000..38f312d1e653
--- /dev/null
+++ b/media-video/spcaview/spcaview-20071224.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spcaview/spcaview-20071224.ebuild,v 1.1 2009/09/29 11:14:22 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A webcam viewer for the spca5xx driver"
+HOMEPAGE="http://mxhaard.free.fr/sview.html"
+SRC_URI="http://mxhaard.free.fr/spca50x/Download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin spca{view,serv,cat} || die
+ dodoc Changelog README
+}