summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-11-11 19:53:59 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-11-11 19:53:59 +0000
commit3c8dbd363625d168a3b12ee401847702e3a0e397 (patch)
tree8f75a63dd83ef76c4d1b2bba0d6b7c3ed4005f30 /media-video/ttcut
parentversion bump; this version supports now also vdr-xineliboutput as output device (diff)
downloadgentoo-2-3c8dbd363625d168a3b12ee401847702e3a0e397.tar.gz
gentoo-2-3c8dbd363625d168a3b12ee401847702e3a0e397.tar.bz2
gentoo-2-3c8dbd363625d168a3b12ee401847702e3a0e397.zip
Added live ebuild.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'media-video/ttcut')
-rw-r--r--media-video/ttcut/ChangeLog7
-rw-r--r--media-video/ttcut/ttcut-9999.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-video/ttcut/ChangeLog b/media-video/ttcut/ChangeLog
index d2f9837b5efd..6b72424f9450 100644
--- a/media-video/ttcut/ChangeLog
+++ b/media-video/ttcut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ttcut
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.17 2008/07/26 21:30:59 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.18 2008/11/11 19:53:59 zzam Exp $
+
+*ttcut-9999 (11 Nov 2008)
+
+ 11 Nov 2008; Matthias Schwarzott <zzam@gentoo.org> +ttcut-9999.ebuild:
+ Added live ebuild.
26 Jul 2008; Carsten Lohrke <carlo@gentoo.org> ttcut-0.19.6-r1.ebuild:
Fix broken split Qt 4.4 dependencies, cf. bug 217161 comment 11.
diff --git a/media-video/ttcut/ttcut-9999.ebuild b/media-video/ttcut/ttcut-9999.ebuild
new file mode 100644
index 000000000000..610f86d4ef3e
--- /dev/null
+++ b/media-video/ttcut/ttcut-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ttcut-9999.ebuild,v 1.1 2008/11/11 19:53:59 zzam Exp $
+
+EAPI="1"
+inherit eutils qt4 subversion
+
+DESCRIPTION="Tool for removing advertisements from recorded MPEG files"
+HOMEPAGE="http://ttcut.tritime.org/"
+ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/ttcut/branches/refactor"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64"
+IUSE=""
+
+DEPEND="|| ( ( x11-libs/qt-gui:4 x11-libs/qt-opengl:4 ) =x11-libs/qt-4.3*:4 )
+ >=media-libs/libmpeg2-0.4.0
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/transcode"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use media-video/transcode mjpeg ; then
+ eerror "In order to have encoding mode working with ttcut"
+ eerror "you need to recompile transcode with mjpeg USE flag enabled."
+ die "Recompile transcode with mjpeg USE flag enabled"
+ fi
+}
+
+src_compile() {
+ eqmake4 ttcut_linux.pro -o Makefile.ttcut
+ emake -f Makefile.ttcut || die "emake failed"
+}
+
+src_install() {
+ dobin TTCut || die "Couldn't install TTCut"
+ make_desktop_entry TTCut TTCut "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make TTCut desktop entry"
+
+ dodoc AUTHORS BUGS CHANGELOG \
+ README.DE README.EN TODO || die "Couldn't install documentation"
+}