summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 17:36:21 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 17:36:21 +0000
commit63efde4ab7385b1f67c8afd1635d1ab7604eb0be (patch)
tree1cbeb6074c1a0e8e6258649ac85a578f00e1751b /media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
parentchanged so it compiles on gentoo 1.3+ (diff)
downloadgentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.tar.gz
gentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.tar.bz2
gentoo-2-63efde4ab7385b1f67c8afd1635d1ab7604eb0be.zip
gcc-3.1 compile fixes (finally figured this one out)
Diffstat (limited to 'media-video/xine-ui/xine-ui-0.9.9-r1.ebuild')
-rw-r--r--media-video/xine-ui/xine-ui-0.9.9-r1.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild b/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
index 50c304f75762..b3c24a492a91 100644
--- a/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
+++ b/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild,v 1.5 2002/05/31 13:41:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.9-r1.ebuild,v 1.6 2002/06/16 17:36:21 lostlogic Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
@@ -23,20 +23,31 @@ src_unpack() {
unpack ${P}.tar.gz
+ cd ${S}
+
# for some reason upstream skipped on including some files for the
# DirectFB front-end for this.
use directfb && ( \
unpack ${PN}-gentoo-extra.tar.bz2
mv ${WORKDIR}/dfb/* ${S}/src/dfb
+ ) || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
)
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
}
src_compile() {
# Most of these are not working currently, but are here for completeness
local myconf
- use X || myconf="${myconf} --disable-x11 --disable-xv"
- use nls || myconf="${myconf} --disable-nls"
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
./configure --host=${CHOST} \
--prefix=/usr \