summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-10 16:36:56 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-10 16:36:56 +0000
commit6d39d231a86e615db1ed4d59be817ccf120d73b3 (patch)
tree82a20013735ccc9d8c833767ba8ff4c918d7199e /media-video
parentrestored. (diff)
downloadgentoo-2-6d39d231a86e615db1ed4d59be817ccf120d73b3.tar.gz
gentoo-2-6d39d231a86e615db1ed4d59be817ccf120d73b3.tar.bz2
gentoo-2-6d39d231a86e615db1ed4d59be817ccf120d73b3.zip
Patch for gcc-3.1 compile fixage.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/drip/ChangeLog8
-rw-r--r--media-video/drip/drip-0.8.1-r5.ebuild119
-rw-r--r--media-video/drip/files/digest-drip-0.8.1-r51
-rw-r--r--media-video/drip/files/drip-0.8.1-gcc-3.1.patch12
4 files changed, 139 insertions, 1 deletions
diff --git a/media-video/drip/ChangeLog b/media-video/drip/ChangeLog
index a2fb5f7045ef..d2a0724f4d18 100644
--- a/media-video/drip/ChangeLog
+++ b/media-video/drip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/drip
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.6 2002/05/27 19:44:17 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.7 2002/06/10 16:36:56 lostlogic Exp $
+
+*drip-0.8.1-r5 (10 Jun 2002)
+
+ 10 Jun 2002; Brandon Low <lostlogic@gentoo.org> drip-0.8.1-r5.ebuild :
+
+ Fix compile on gcc-3.1 (1-line patch).
*drip-0.8.1-r4 (27 May 2002)
diff --git a/media-video/drip/drip-0.8.1-r5.ebuild b/media-video/drip/drip-0.8.1-r5.ebuild
new file mode 100644
index 000000000000..1ae7db028550
--- /dev/null
+++ b/media-video/drip/drip-0.8.1-r5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@cvs.gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.8.1-r5.ebuild,v 1.1 2002/06/10 16:36:56 lostlogic Exp $
+
+AF_MINOR_VER="$(avifile-config --data-dir | cut -d. -f2)"
+S=${WORKDIR}/${P}
+DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
+SRC_URI="${SRC_URI} http://drip.sourceforge.net/files/${P}.tar.gz"
+HOMEPAGE="http://drip.sourceforge.net/"
+
+RDEPEND="gnome-base/gnome-libs
+ >=media-video/avifile-0.7.4.20020426-r2
+ >=media-libs/a52dec-0.7.3
+ >=media-libs/divx4linux-20020418
+ >=media-libs/libdvdcss-1.1.1
+ >=media-libs/libdvdread-0.9.2
+ media-libs/gdk-pixbuf"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ >=sys-devel/automake-1.5-r1"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ # Fix the problem that if the /dev/dvd symlink is not absolute,
+ # drip fails to start.
+ patch -p1 < ${FILESDIR}/${P}-fix-dvd-symlink.patch || die
+
+ # Fix hardcoded path of plugins
+ cd ${S}
+ cp encoder/plugin-loader.cpp encoder/plugin-loader.cpp.orig
+ sed -e "s:/usr/local/lib:/usr/lib:g" \
+ encoder/plugin-loader.cpp.orig >encoder/plugin-loader.cpp
+
+ # Fix missing #include <stdio.h>
+ patch -p1 < ${FILESDIR}/${P}-missing-stdio.patch || die
+
+ # Fix missing #include <stdio.h>
+ patch -p1 < ${FILESDIR}/${P}-gcc-3.1.patch || die "Failed gcc-3.1 compatibility patch"
+
+ # Fixup to work with avifile-0.${AF_MINOR_VER}
+ cd ${S}/encoder
+ for x in encoder.hh main.hh encoder.cpp external.cpp
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:AVIFILE_MINOR_VERSION==6:AVIFILE_MINOR_VERSION==${AF_MINOR_VER}:g" \
+ ${x}.orig >${x}
+ done
+
+ # Fix it to work with the suffix the new avifile introduces.
+# cd ${S}
+# for x in $(find . -name 'Makefile.am') configure.in
+# do
+# cp ${x} ${x}.orig
+# sed -e "s:avifile-config:avifile-config0.${AF_MINOR_VER}:g" \
+# ${x}.orig >${x}
+# done
+
+ cd ${S}
+ # Remove stale script ... "automake --add-missing" will add it again
+ rm -f ${S}/missing
+ export WANT_AUTOMAKE_1_5=1
+ aclocal -I macros
+ automake --add-missing
+ autoconf
+}
+
+src_compile() {
+
+ export WANT_AUTOMAKE_1_5=1
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ CFLAGS= \
+ CXXFLAGS= \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ sysconfdir=${D}/etc \
+ drip_helpdir=${D}/usr/share/gnome/help/drip/C \
+ drip_pixmapdir=${D}/usr/share/pixmaps \
+ install || die
+
+ # Remove liba52.so.* as ac52dec provides this
+ rm ${D}/usr/lib/liba52*
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+ # Custom script for drip to get the *real* dvd device
+ # It is a bit rough around the edges, but hopefully will do the trick.
+ dobin ${FILESDIR}/dripgetdvd.sh
+
+ insinto /usr/share/pixmaps
+ newins ${S}/pixmaps/drip_logo.jpg drip.jpg
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/drip.desktop
+}
+
diff --git a/media-video/drip/files/digest-drip-0.8.1-r5 b/media-video/drip/files/digest-drip-0.8.1-r5
new file mode 100644
index 000000000000..53af5b8fffdc
--- /dev/null
+++ b/media-video/drip/files/digest-drip-0.8.1-r5
@@ -0,0 +1 @@
+MD5 b88e9731f7266f0e0b9ff412c13a3624 drip-0.8.1.tar.gz 603487
diff --git a/media-video/drip/files/drip-0.8.1-gcc-3.1.patch b/media-video/drip/files/drip-0.8.1-gcc-3.1.patch
new file mode 100644
index 000000000000..3b96401a7db9
--- /dev/null
+++ b/media-video/drip/files/drip-0.8.1-gcc-3.1.patch
@@ -0,0 +1,12 @@
+diff -Nru drip-0.8.1.bad/encoder/pulldown.cpp drip-0.8.1/encoder/pulldown.cpp
+--- drip-0.8.1.bad/encoder/pulldown.cpp Sun Mar 24 06:36:36 2002
++++ drip-0.8.1/encoder/pulldown.cpp Mon Jun 10 11:20:30 2002
+@@ -70,7 +70,7 @@
+ bool oddeven;
+ int framenumOffset;
+
+-int pulldown_init(int width, int height, bool oddfirst = false, int foffset = 0){
++int pulldown_init(int width, int height, bool oddfirst, int foffset){
+ if((framethree = new guchar[width * height * 3]) == NULL)
+ return -1;
+ if((outframe = new guchar[width * height * 3]) == NULL)