summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-13 14:32:28 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-13 14:32:28 +0000
commitd4fa1298e7c087e5e65ce90c7715db97b456b223 (patch)
tree090e65f928fff8a5e7de331a25d7dd5ddfdf2004 /media-video
parentNew version. (diff)
downloadgentoo-2-d4fa1298e7c087e5e65ce90c7715db97b456b223.tar.gz
gentoo-2-d4fa1298e7c087e5e65ce90c7715db97b456b223.tar.bz2
gentoo-2-d4fa1298e7c087e5e65ce90c7715db97b456b223.zip
New package. QA-checked with repoman.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vcr/ChangeLog18
-rw-r--r--media-video/vcr/files/digest-vcr-1.091
-rw-r--r--media-video/vcr/files/vcr-1.09-avifile-0.7x.patch185
-rw-r--r--media-video/vcr/vcr-1.09.ebuild30
4 files changed, 234 insertions, 0 deletions
diff --git a/media-video/vcr/ChangeLog b/media-video/vcr/ChangeLog
new file mode 100644
index 000000000000..070150244483
--- /dev/null
+++ b/media-video/vcr/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for media-video/vcr
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vcr/ChangeLog,v 1.1 2002/07/13 14:32:28 phoenix Exp $
+
+*vcr-1.09 (13 July 2002)
+
+ 13 Jul 2002; phoen][x <phoenix@gentoo.org> ChangeLog, vcr-1.09.ebuild,
+ files/digest-vcr-1.09, files/vcr-1.09-avifile-0.7x.patch :
+
+ Initial cvs commit. Ebuild contributed by Alastair Tse <gentoo@liquidx.net>.
+ Thanks for the contribution.
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/media-video/vcr/files/digest-vcr-1.09 b/media-video/vcr/files/digest-vcr-1.09
new file mode 100644
index 000000000000..0bbe994874db
--- /dev/null
+++ b/media-video/vcr/files/digest-vcr-1.09
@@ -0,0 +1 @@
+MD5 18a41f998647b8e32f07de3c9f899009 vcr-1.09.tar.gz 117377
diff --git a/media-video/vcr/files/vcr-1.09-avifile-0.7x.patch b/media-video/vcr/files/vcr-1.09-avifile-0.7x.patch
new file mode 100644
index 000000000000..48dcf6d994f9
--- /dev/null
+++ b/media-video/vcr/files/vcr-1.09-avifile-0.7x.patch
@@ -0,0 +1,185 @@
+--- vcr-1.09/src/main.cc Mon Nov 12 01:38:36 2001
++++ vcr-1.10a/src/main.cc Thu Jun 27 22:16:47 2002
+@@ -266,7 +266,7 @@
+ v4l,
+ filename,
+ -1,
+- codecID,
++ video_codecs[codecID].fourcc,
+ quality * 100,
+ keyframes,
+ soundfreq,
+@@ -539,19 +539,15 @@
+ }
+
+ void
+-list_attributes(int fourcc)
++list_attributes(int codec_idx)
+ {
+ int defval;
+ char def_str[256];
+
+- int idx = get_codec_index(fourcc);
+- if (idx < 0)
+- return;
+-
+ #ifdef OLDAVIFILE
+- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ vector<AttributeInfo> encinfo = video_codecs[codec_idx].encoder_info;
+ #else
+- avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ avm::vector<AttributeInfo> encinfo = video_codecs[codec_idx].encoder_info;
+ #endif
+
+ fprintf(stderr, "These attributes are supported for this codec:\n\n");
+@@ -569,18 +565,18 @@
+ {
+ case AttributeInfo::Integer:
+ #ifdef OLDAVIFILE
+- IVideoEncoder::GetExtendedAttr(fourcc, it->name.c_str(), defval);
++ IVideoEncoder::GetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), defval);
+ #else
+- GetCodecAttr(video_codecs[idx], it->GetName(), defval);
++ GetCodecAttr(video_codecs[codec_idx], it->GetName(), defval);
+ #endif
+ fprintf(stderr, "\tType: integer (default value: %d)\n", defval);
+ break;
+ case AttributeInfo::Select:
+ {
+ #ifdef OLDAVIFILE
+- IVideoEncoder::GetExtendedAttr(fourcc, it->name.c_str(), defval);
++ IVideoEncoder::GetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), defval);
+ #else
+- GetCodecAttr(video_codecs[idx], it->GetName(), defval);
++ GetCodecAttr(video_codecs[codec_idx], it->GetName(), defval);
+ #endif
+ fprintf(stderr, "\tType: select (default value: %s)\n",
+ it->options[defval].c_str());
+@@ -599,9 +595,9 @@
+ }
+ case AttributeInfo::String:
+ #ifdef OLDAVIFILE
+- IVideoEncoder::GetExtendedAttr(fourcc, it->name.c_str(), def_str, 256);
++ IVideoEncoder::GetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), def_str, 256);
+ #else
+- GetCodecAttr(video_codecs[idx], it->GetName(), def_str, 256);
++ GetCodecAttr(video_codecs[codec_idx], it->GetName(), def_str, 256);
+ #endif
+ fprintf(stderr, "\tType: string (default value: %s)\n", def_str);
+ break;
+@@ -794,7 +790,7 @@
+ }
+
+ /* returns -1 if codec does not exist.
+- * Otherwise, the codec's unique ID
++ * Otherwise, the codec's index in video_codec[]
+ */
+ int
+ is_valid_codec(const char *cname)
+@@ -802,15 +798,19 @@
+ if (!cname)
+ return -1;
+
+- int
+- found_codec = -1;
++ int found_codec = -1;
++ int idx = 0;
+
+ vector<CodecInfo>::iterator it;
+
+ for (it = video_codecs.begin(); it != video_codecs.end(); it++)
+ {
+- if ( it->kind == CodecInfo::DShow_Dec)
++ if ( it->kind == CodecInfo::DShow_Dec)
++ {
++ idx++;
+ continue;
++ }
++
+
+ #ifdef OLDAVIFILE
+ if (!strcasecmp(cname, it->name.c_str()))
+@@ -818,10 +818,11 @@
+ if (!strcasecmp(cname, it->GetName()))
+ #endif
+ {
+- found_codec = it->fourcc;
++ found_codec = idx;
+ encoder_info = it->encoder_info;
+ break;
+ }
++ idx++;
+ }
+
+ return found_codec;
+@@ -1018,20 +1019,17 @@
+
+ //TODO: It ignores fourcc currently..
+ short
+-set_attribute(int fourcc, const char *attr, const char *val)
++set_attribute(int codec_idx, const char *attr, const char *val)
+ {
+ int setval = 0;
+ int retval = 0;
+
+ vector<AttributeInfo>::const_iterator it;
+- int idx = get_codec_index(fourcc);
+- if (idx < 0)
+- return 0;
+
+ #ifdef OLDAVIFILE
+- vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ vector<AttributeInfo> encinfo = video_codecs[codec_idx].encoder_info;
+ #else
+- avm::vector<AttributeInfo> encinfo = video_codecs[idx].encoder_info;
++ avm::vector<AttributeInfo> encinfo = video_codecs[codec_idx].encoder_info;
+ #endif
+
+ for (it = encinfo.begin(); it != encinfo.end(); it++)
+@@ -1047,23 +1045,23 @@
+ {
+ case AttributeInfo::Integer:
+ #ifdef OLDAVIFILE
+- IVideoEncoder::SetExtendedAttr(fourcc, it->name.c_str(), atoi(val));
++ IVideoEncoder::SetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), atoi(val));
+ #else
+- SetCodecAttr(video_codecs[idx], it->GetName(), atoi(val));
++ SetCodecAttr(video_codecs[codec_idx], it->GetName(), atoi(val));
+ #endif
+ break;
+ case AttributeInfo::String:
+ #ifdef OLDAVIFILE
+- IVideoEncoder::SetExtendedAttr(fourcc, it->name.c_str(), val);
++ IVideoEncoder::SetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), val);
+ #else
+- SetCodecAttr(video_codecs[idx], it->GetName(), val);
++ SetCodecAttr(video_codecs[codec_idx], it->GetName(), val);
+ #endif
+ break;
+ case AttributeInfo::Select:
+ #ifdef OLDAVIFILE
+- IVideoEncoder::SetExtendedAttr(fourcc, it->name.c_str(), val);
++ IVideoEncoder::SetExtendedAttr(video_codecs[codec_idx].fourcc, it->name.c_str(), val);
+ #else
+- SetCodecAttr(video_codecs[idx], it->GetName(), val);
++ SetCodecAttr(video_codecs[codec_idx], it->GetName(), val);
+ #endif
+ break;
+ }
+@@ -1074,14 +1072,14 @@
+ }
+
+ short
+-set_attributes(int fourcc)
++set_attributes(int codec_idx)
+ {
+ const char *cname = NULL;
+ int i;
+
+ for (i = 0; i < attr_count; i++)
+ {
+- if (!set_attribute(fourcc, attributes[i].name, attributes[i].val))
++ if (!set_attribute(codec_idx, attributes[i].name, attributes[i].val))
+ return 0;
+ }
+
diff --git a/media-video/vcr/vcr-1.09.ebuild b/media-video/vcr/vcr-1.09.ebuild
new file mode 100644
index 000000000000..42a08aea6141
--- /dev/null
+++ b/media-video/vcr/vcr-1.09.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+DESCRIPTION="VCR - Linux Console VCR"
+SRC_URI="http://www.stack.nl/~brama/${PN}/src/vcr-1.09.tar.gz"
+HOMEPAGE="http://www.stack.nl/~brama/vcr/"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND=">=media-video/avifile-0.6"
+SLOT="0"
+
+src_unpack () {
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p0 ${S}/src/main.cc < ${FILESDIR}/${P}-avifile-0.7x.patch || die
+}
+
+src_compile () {
+ local myconf
+ myconf="--enable-avifile-0_6"
+ econf ${myconf} || die "econf died"
+ emake || die "emake died"
+}
+
+src_install () {
+
+ einstall || die "einstall died"
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}