summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-06-11 15:28:54 +0000
committerTroy Dack <tad@gentoo.org>2003-06-11 15:28:54 +0000
commit16a47f3da2739e1205bc10dc4a688faf8bf3b3ef (patch)
treef3145372f9f0a29d027446ea67d360a50844f0e0 /net-analyzer/cacti
parentVersion Bump (unstable). (diff)
downloadgentoo-2-16a47f3da2739e1205bc10dc4a688faf8bf3b3ef.tar.gz
gentoo-2-16a47f3da2739e1205bc10dc4a688faf8bf3b3ef.tar.bz2
gentoo-2-16a47f3da2739e1205bc10dc4a688faf8bf3b3ef.zip
Version Bump (unstable).
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest4
-rw-r--r--net-analyzer/cacti/cacti-0.8.1.ebuild113
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.11
4 files changed, 123 insertions, 3 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index f1a6d702bc74..87775a0bbdd9 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.7 2003/05/13 19:15:25 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.8 2003/06/11 15:28:38 tad Exp $
+
+*cacti-0.8.1 (12 Jun 2003)
+
+ 12 Jun 2003; Troy Dack <tad@gentoo.org> cacti-0.8.1.ebuild:
+ Version Bump. Now works with net-snmp (default for virtual/snmp) and ucd-snmp.
+ Updated postinst einfo message.
*cacti-0.6.8a (23 Oct 2002)
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 139b4186ea6a..fa9cea70e4eb 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,5 +1,5 @@
-MD5 984387c2550a66418ae2360716ac69d4 cacti-0.8.1.ebuild 4113
+MD5 25d050e757da564980dae74b3da31fbc cacti-0.8.1.ebuild 4099
MD5 57395465876dc8e6c61d0cc68f6c3620 cacti-0.6.8a.ebuild 1465
-MD5 1b3b101d2e59a4afaf363c07aaa63af8 ChangeLog 794
+MD5 68ba28b575a17e1a4d4e8e6ea4a8da0e ChangeLog 996
MD5 f1e420ab088a8222b4020ab76a92c387 files/digest-cacti-0.8.1 63
MD5 36cff775a40a01ca080d9b290109a795 files/digest-cacti-0.6.8a 64
diff --git a/net-analyzer/cacti/cacti-0.8.1.ebuild b/net-analyzer/cacti/cacti-0.8.1.ebuild
new file mode 100644
index 000000000000..fb0413aa737d
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.1.ebuild,v 1.1 2003/06/11 15:28:38 tad Exp $
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${P}.tar.gz"
+
+IUSE="snmp"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ dev-php/php
+ dev-php/mod_php"
+
+# Allow users to move the default data directory by setting the
+# home directory of the 'apache' user elsewhere.
+HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+
+INSTALL_DEST="${HTTPD_ROOT}/cacti"
+
+src_install() {
+ dohtml docs/{INSTALL,UPGRADE}.htm
+ dodoc docs/{CHANGELOG,CONTRIB}
+ dodoc {LICENSE}
+
+ rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ rm docs/{README,CHANGELOG,CONTRIB}
+ rm LICENSE README
+
+ mv docs/manual .
+ rm -fr docs
+
+ dodir ${INSTALL_DEST}
+ chown apache.apache * -R
+ mv * ${D}/${INSTALL_DEST}/
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ minor_inst= $(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)
+ rel_inst= $(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)
+ if [ '${minor_inst}${rel_inst}' -lt '81' ]
+ then
+ einfo
+ einfo "The cacti has been installed to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "5. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ eingo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.1 b/net-analyzer/cacti/files/digest-cacti-0.8.1
new file mode 100644
index 000000000000..3ec1397a3b8d
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.1
@@ -0,0 +1 @@
+MD5 d87613690e82e025412de6d747b0674e cacti-0.8.1.tar.gz 513944