summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-20 08:07:05 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-20 08:07:05 +0000
commit3553f7dc6037aa4014e288c0458b813160389273 (patch)
tree00d84c8596bda1bbc5d87061de62970cf250ecf4 /net-analyzer/nbwmon
parentVersion bump: https://www.ruby-lang.org/en/news/2014/09/19/ruby-2-1-3-is-rele... (diff)
downloadgentoo-2-3553f7dc6037aa4014e288c0458b813160389273.tar.gz
gentoo-2-3553f7dc6037aa4014e288c0458b813160389273.tar.bz2
gentoo-2-3553f7dc6037aa4014e288c0458b813160389273.zip
Version bump.
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/nbwmon')
-rw-r--r--net-analyzer/nbwmon/ChangeLog8
-rw-r--r--net-analyzer/nbwmon/files/nbwmon-0.4.3-tinfo.patch11
-rw-r--r--net-analyzer/nbwmon/nbwmon-0.4.3.ebuild27
3 files changed, 45 insertions, 1 deletions
diff --git a/net-analyzer/nbwmon/ChangeLog b/net-analyzer/nbwmon/ChangeLog
index f4d7053d3f95..a4ec0eea1c3c 100644
--- a/net-analyzer/nbwmon/ChangeLog
+++ b/net-analyzer/nbwmon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nbwmon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbwmon/ChangeLog,v 1.1 2014/09/04 19:16:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbwmon/ChangeLog,v 1.2 2014/09/20 08:07:05 jer Exp $
+
+*nbwmon-0.4.3 (20 Sep 2014)
+
+ 20 Sep 2014; Jeroen Roovers <jer@gentoo.org> +nbwmon-0.4.3.ebuild,
+ +files/nbwmon-0.4.3-tinfo.patch:
+ Version bump.
*nbwmon-0.3.2 (04 Sep 2014)
diff --git a/net-analyzer/nbwmon/files/nbwmon-0.4.3-tinfo.patch b/net-analyzer/nbwmon/files/nbwmon-0.4.3-tinfo.patch
new file mode 100644
index 000000000000..cb2b7a35887d
--- /dev/null
+++ b/net-analyzer/nbwmon/files/nbwmon-0.4.3-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # add -I/usr/pkg/include and -L/usr/pkg/lib to the options
+ # below.
+ CFLAGS+=-std=c99 -pedantic -Wall -Wextra
+-LDLIBS=-lncurses
++LDLIBS=$(shell $(PKG_CONFIG) --libs ncurses)
+
+ BIN=nbwmon
+
diff --git a/net-analyzer/nbwmon/nbwmon-0.4.3.ebuild b/net-analyzer/nbwmon/nbwmon-0.4.3.ebuild
new file mode 100644
index 000000000000..ee6f9acc812b
--- /dev/null
+++ b/net-analyzer/nbwmon/nbwmon-0.4.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nbwmon/nbwmon-0.4.3.ebuild,v 1.1 2014/09/20 08:07:05 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ncurses bandwidth monitor"
+HOMEPAGE="https://github.com/defer-/nbwmon"
+SRC_URI="https://github.com/defer-/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ tc-export CC PKG_CONFIG
+}