summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-11 22:49:08 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-11 22:49:08 +0000
commitd0a520984c191b967207186807313a9ecbd235ce (patch)
treee9804526278ad5360ec5cb7f1146da3592dad485 /net-analyzer/ntop
parentVersion bumped (diff)
downloadgentoo-2-d0a520984c191b967207186807313a9ecbd235ce.tar.gz
gentoo-2-d0a520984c191b967207186807313a9ecbd235ce.tar.bz2
gentoo-2-d0a520984c191b967207186807313a9ecbd235ce.zip
Version bumped
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog7
-rw-r--r--net-analyzer/ntop/Manifest4
-rw-r--r--net-analyzer/ntop/files/digest-ntop-2.2c1
-rw-r--r--net-analyzer/ntop/ntop-2.2c.ebuild76
4 files changed, 85 insertions, 3 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index ba6c52d0c970..8c87b62b218d 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ntop
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.10 2003/06/29 20:17:42 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.11 2003/07/11 22:48:58 mholzer Exp $
+
+*ntop-2.2c (12 Jul 2003)
+
+ 12 Jul 2003; Martin Holzer <mholzer@gentoo.org> ntop-2.2c.ebuild:
+ Version bumped.
29 Jun 2003; Martin Holzer <mholzer@gentoo.org> ntop-2.2.ebuild:
Marked stable on x86.
diff --git a/net-analyzer/ntop/Manifest b/net-analyzer/ntop/Manifest
index 85a73d291f60..77e4bacc1616 100644
--- a/net-analyzer/ntop/Manifest
+++ b/net-analyzer/ntop/Manifest
@@ -1,7 +1,7 @@
-MD5 1070cd958e562ae8ee11a1bbbcfb1ab6 ChangeLog 1211
+MD5 af5296f9c133be1936be8887787c13ba ChangeLog 1324
MD5 2621f553b7a2f6208843e605463b97e0 ntop-2.0.99_rc2-r2.ebuild 2686
MD5 7bc9f3c131794b927cb4ed7618c1b0da ntop-2.2.ebuild 2107
-MD5 40dd45d305cbd25552608381eb9983be ntop-2.2c.ebuild 2108
+MD5 6bd8892ac26d910f814e5582b936cdfe ntop-2.2c.ebuild 2110
MD5 c4aa8efff06387c497036191b144f9b4 files/digest-ntop-2.2c 59
MD5 e8f42646f3226a9ad43cac51773512f0 files/digest-ntop-2.0.99_rc2-r2 65
MD5 b7642cd2d05562431a2af66604275657 files/digest-ntop-2.2 58
diff --git a/net-analyzer/ntop/files/digest-ntop-2.2c b/net-analyzer/ntop/files/digest-ntop-2.2c
new file mode 100644
index 000000000000..3b805d30b627
--- /dev/null
+++ b/net-analyzer/ntop/files/digest-ntop-2.2c
@@ -0,0 +1 @@
+MD5 473c6a6c81fb03b3e28556043ab2543d ntop-2.2c.tgz 2509588
diff --git a/net-analyzer/ntop/ntop-2.2c.ebuild b/net-analyzer/ntop/ntop-2.2c.ebuild
new file mode 100644
index 000000000000..0258fc0ed242
--- /dev/null
+++ b/net-analyzer/ntop/ntop-2.2c.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.2c.ebuild,v 1.1 2003/07/11 22:48:58 mholzer Exp $
+
+IUSE="ssl readline tcpd ncurses"
+
+S=${WORKDIR}/${PN}/${PN}
+DESCRIPTION="ntop is a unix tool that shows network usage like top"
+SRC_URI="mirror://sourceforge/ntop/${P}.tgz"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=sys-libs/gdbm-1.8.0
+ >=net-libs/libpcap-0.5.2
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r4 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use readline || myconf="${myconf} --without-readline"
+ use tcpd || myconf="${myconf} --with-tcpwrap"
+ use ssl || myconf="${myconf} --without-ssl"
+ use ncurses || myconf="${myconf} --without-curses"
+
+ # ntop 2.0 ships with its own version of gdchart... gdchart should
+ # get its own package but ntop should be built with the version it
+ # shipped with just in case future versions are incompatible -- blocke
+
+ # compile gdchart
+ cd ../gdchart0.94c
+ ./configure || die "gdchart configure problem"
+
+ # subtree #1
+ cd gd-1.8.3/libpng-1.2.4
+ make -f scripts/makefile.linux || die "libpng compile problem"
+
+ # subtree #2
+ cd ../../zlib-1.1.4/
+ ./configure || die "zlib configure problem"
+ make || die "zlib compile problem"
+
+ # gdchart make
+ cd ../
+ make || die "gdchart compile problem"
+
+ # now ntop itself...
+ cd ../ntop
+ econf ${myconf} || die "configure problem"
+ make || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+
+ # fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
+ # (don't know if there is a clean way to handle it)
+
+ doman ntop.8
+
+ dodoc AUTHORS CONTENTS COPYING ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS
+
+ dohtml ntop.html
+
+ dodir /var/lib/ntop
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ntop-init ntop
+ insinto /etc/conf.d ; newins ${FILESDIR}/ntop-confd ntop
+}