summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-03-18 15:23:22 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-03-18 15:23:22 +0000
commit08c5fb9c671d188efea223d5a6a757f79c31f07b (patch)
tree1d58bf817dcaa2bfa2f8246fa02a19df4d06934c /net-analyzer/rrdtool
parentThis is committed because Weblogic distributes SP2 from their website now. (M... (diff)
downloadgentoo-2-08c5fb9c671d188efea223d5a6a757f79c31f07b.tar.gz
gentoo-2-08c5fb9c671d188efea223d5a6a757f79c31f07b.tar.bz2
gentoo-2-08c5fb9c671d188efea223d5a6a757f79c31f07b.zip
Fix amd64 issues
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/ChangeLog6
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.0.46-fPIC.patch11
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.46.ebuild9
3 files changed, 21 insertions, 5 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index e95f83108359..5afc2b4c5b90 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.31 2004/03/09 05:39:51 mboman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.32 2004/03/18 15:23:22 aliz Exp $
+
+ 18 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> rrdtool-1.0.46.ebuild,
+ files/rrdtool-1.0.46-fPIC.patch:
+ Must compile private lib with -fPIC on amd64.
*rrdtool-1.0.46 (09 Mar 2004)
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.0.46-fPIC.patch b/net-analyzer/rrdtool/files/rrdtool-1.0.46-fPIC.patch
new file mode 100644
index 000000000000..2e740dbdaf07
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.0.46-fPIC.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in 2004-03-18 14:32:51.670818448 +0000
++++ src/Makefile.in 2004-03-18 14:33:05.911258477 +0000
+@@ -336,7 +336,7 @@
+ @AMDEP_TRUE@ ./$(DEPDIR)/rrd_xport.Plo
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) \
++LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -prefer-pic $(DEFS) $(DEFAULT_INCLUDES) \
+ $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild
index 30fa21b97f6b..e85786802d10 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild,v 1.1 2004/03/09 05:39:51 mboman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.46.ebuild,v 1.2 2004/03/18 15:23:22 aliz Exp $
-inherit perl-module flag-o-matic gnuconfig
+inherit perl-module flag-o-matic gnuconfig eutils
DESCRIPTION="A system to store and display time-series data"
HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
@@ -32,6 +32,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-tcl.patch # 1.0.46 has a broke TCL Makefile
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fPIC.patch
}
src_compile() {
@@ -43,8 +46,6 @@ src_compile() {
&& myconf="${myconf} --with-tcllib=/usr/lib" \
|| myconf="${myconf} --without-tcllib"
- use amd64 && gnuconfig_update
-
if [ `use perl` ] ; then
MMSIXELEVEN=`perl -e 'use ExtUtils::MakeMaker; print( $ExtUtils::MakeMaker::VERSION ge "6.11" )'`
if [ "${MMSIXELEVEN}" ]; then