summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2005-04-29 17:44:39 +0000
committerMartin Holzer <mholzer@gentoo.org>2005-04-29 17:44:39 +0000
commit011a2572699c5af1c0f0c9ddd756eae004094726 (patch)
tree40e84057e2d66575b8a7a6d2354e3b062f009652 /net-analyzer
parentstable on amd64 (diff)
downloadgentoo-2-011a2572699c5af1c0f0c9ddd756eae004094726.tar.gz
gentoo-2-011a2572699c5af1c0f0c9ddd756eae004094726.tar.bz2
gentoo-2-011a2572699c5af1c0f0c9ddd756eae004094726.zip
Version bumped.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/Manifest20
-rw-r--r--net-analyzer/cacti/cacti-0.8.6d.ebuild59
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6d1
-rw-r--r--net-analyzer/cacti/files/postinstall-en.txt7
5 files changed, 77 insertions, 17 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 51b46230f2f4..548927093e44 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.41 2005/03/15 14:00:06 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.42 2005/04/29 17:44:39 mholzer Exp $
+
+*cacti-0.8.6d (29 Apr 2005)
+
+ 29 Apr 2005; Martin Holzer <mholzer@gentoo.org> +cacti-0.8.6d.ebuild:
+ Version bumped.
15 Mar 2005; Aaron Walker <ka0ttic@gentoo.org> files/postinstall-en.txt:
More updates to postinst-en.txt for bug 83673. Thanks to Jakub Moc for
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 1802f59cb011..084fbf7219e8 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f336eb6ba3c459b9b17078d8a317871a cacti-0.8.6c.ebuild 1358
-MD5 2c655694731b7e285fed83e0f3a7d069 cacti-0.8.6b.ebuild 1358
-MD5 51a90c1a05b1f4ec2ad722ce5fb1d384 ChangeLog 5586
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
-MD5 384a779398e56811a62445c20ddc5a72 files/postinstall-en.txt 2083
-MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
+MD5 e302e85a2fab3576e8bdc268d8d8e0c7 ChangeLog 5706
+MD5 947df7a0d357f323e19a741cc1ee9382 cacti-0.8.6d.ebuild 1413
+MD5 2c655694731b7e285fed83e0f3a7d069 cacti-0.8.6b.ebuild 1358
MD5 92214d64b7a546022d81ca37cb137262 files/digest-cacti-0.8.6c 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCNuqWEZCkKN40op4RAkeoAJ4p7WtzuTHVoSRiLFb1Ie/GcSsJAACfWJSd
-0kknWDkDvEMJjWIjzI4etho=
-=GC/v
------END PGP SIGNATURE-----
+MD5 e77a5f6b9f7c97f061348312cd9e1004 files/digest-cacti-0.8.6d 65
+MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
+MD5 384a779398e56811a62445c20ddc5a72 files/postinstall-en.txt 2083
diff --git a/net-analyzer/cacti/cacti-0.8.6d.ebuild b/net-analyzer/cacti/cacti-0.8.6d.ebuild
new file mode 100644
index 000000000000..53a981b7862e
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6d.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6d.ebuild,v 1.1 2005/04/29 17:44:39 mholzer Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc ~alpha ~amd64"
+IUSE="snmp"
+
+DEPEND=""
+
+# TODO: RDEPEND Not just apache... but there's no virtual/webserver (yet)
+
+RDEPEND="net-www/apache
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron
+ dev-php/php
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use dev-php/php mysql || \
+ die "dev-php/php must be compiled with USE=mysql"
+ built_with_use dev-php/mod_php mysql || \
+ die "dev-php/mod_php must be compiled with USE=mysql"
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ #Don't overwrite old config
+ mv include/config.php include/config-sample.php
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6d b/net-analyzer/cacti/files/digest-cacti-0.8.6d
new file mode 100644
index 000000000000..a3225a381655
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6d
@@ -0,0 +1 @@
+MD5 f149a874dd06b639a5b6b78cf994b4cb cacti-0.8.6d.tar.gz 1037551
diff --git a/net-analyzer/cacti/files/postinstall-en.txt b/net-analyzer/cacti/files/postinstall-en.txt
index 2653f5fe5903..0a59c13bf169 100644
--- a/net-analyzer/cacti/files/postinstall-en.txt
+++ b/net-analyzer/cacti/files/postinstall-en.txt
@@ -28,7 +28,10 @@ Upgrading
shell> mysqldump -l --add-drop-table cacti > mysql.cacti
2. Backup your rra/ directory and any custom scripts in your scripts/
directory.
-3. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
+3. Copy ${MY_INSTALLDIR}/include/config-sample.php to config.php
+ And modify the MySQL user, password and database for your cacti
+ configuration.
+4. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
password and database is correct for your cacti configuration.
Example:
@@ -36,7 +39,7 @@ Upgrading
\$database_hostname = "localhost";
\$database_username = "cactiuser";
\$database_password = "cacti";
-4. Point your web browser to: http://your-server/cacti/
+5. Point your web browser to: http://your-server/cacti/
Select "Upgrade:.
Make sure to fill in all of the path variables carefully and
correctly on the following screen.