summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-02 08:31:54 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-02 08:31:54 +0000
commit2198a2cf845c9511fe0052b4a230169733bf689f (patch)
tree61cb7cc59c11b86079854be338ca711bdf538032 /net-analyzer
parentAdded building of shared libs. (diff)
downloadgentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.tar.gz
gentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.tar.bz2
gentoo-2-2198a2cf845c9511fe0052b4a230169733bf689f.zip
Added dependencies
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ethereal-0.8.12.ebuild9
-rw-r--r--net-analyzer/nessus/nessus-1.0.5.ebuild9
-rw-r--r--net-analyzer/ngrep/ngrep-1.38-r1.ebuild5
-rw-r--r--net-analyzer/ntop/ntop-1.3.1-r1.ebuild9
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.5.2.ebuild5
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.3.ebuild4
6 files changed, 35 insertions, 6 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.8.12.ebuild b/net-analyzer/ethereal/ethereal-0.8.12.ebuild
index 92b4f8df0d96..4567aca827d3 100644
--- a/net-analyzer/ethereal/ethereal-0.8.12.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.8.12.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.12.ebuild,v 1.1 2000/10/05 00:13:01 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.12.ebuild,v 1.2 2000/11/02 08:31:51 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,13 @@ DESCRIPTION="ethereal"
SRC_URI="http://ethereal.zing.org/distribution/${A}
ftp://ethereal.zing.org/pub/ethereal/${A}"
HOMEPAGE="http://ethereal.zing.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8
+ >=net-libs/libpcap-0.5.2
+ >=x11-base/xfree-4.0.1"
+
src_compile() {
cd ${S}
LDFLAGS="-L/usr/lib -lz" try ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/ethereal
diff --git a/net-analyzer/nessus/nessus-1.0.5.ebuild b/net-analyzer/nessus/nessus-1.0.5.ebuild
index 7f299c3edca3..9db713bd62a9 100644
--- a/net-analyzer/nessus/nessus-1.0.5.ebuild
+++ b/net-analyzer/nessus/nessus-1.0.5.ebuild
@@ -14,13 +14,20 @@ SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/nessus-libraries-${PV}
HOMEPAGE="http://www.nessus.org/"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8
+ >=x11-base/xfree-4.0.1"
+
src_compile() {
export PATH=${D}/usr/bin:$PATH
export LD_LIBRARY_PATH=${D}/usr/lib:$LD_LIBRARY_PATH
echo "Compiling libraries..."
cd ${S}/nessus-libraries
- try ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ try ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state \
+ --enable-pthread
try make
try make prefix=${D}/usr sysconfdir=${D}/etc localstatedir=${D}/var/state install
cd ${D}/usr/bin
diff --git a/net-analyzer/ngrep/ngrep-1.38-r1.ebuild b/net-analyzer/ngrep/ngrep-1.38-r1.ebuild
index 3d2e7102c29e..10106ce67c81 100644
--- a/net-analyzer/ngrep/ngrep-1.38-r1.ebuild
+++ b/net-analyzer/ngrep/ngrep-1.38-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ngrep/ngrep-1.38-r1.ebuild,v 1.3 2000/09/15 20:09:07 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ngrep/ngrep-1.38-r1.ebuild,v 1.4 2000/11/02 08:31:52 achim Exp $
P=ngrep-1.38
A=${P}.tar.gz
@@ -10,6 +10,9 @@ DESCRIPTION="A grep for network layers"
SRC_URI="http://ngrep.datasurge.net/"${A}
HOMEPAGE="http://ngrep.datasurge.net"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=net-libs/libpcap-0.5.2"
+
src_unpack() {
unpack ${A}
}
diff --git a/net-analyzer/ntop/ntop-1.3.1-r1.ebuild b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
index 7926a9044ffe..9fa82f7d0c25 100644
--- a/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
+++ b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r1.ebuild,v 1.3 2000/09/15 20:09:07 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r1.ebuild,v 1.4 2000/11/02 08:31:52 achim Exp $
P=ntop-1.3.1
A="${P}.tar.gz"
@@ -10,6 +10,13 @@ DESCRIPTION="Unix Tool that shows networkusage like top"
SRC_URI="ftp://ftp.it.ntop.org/pub/local/ntop/snapshots/${A}"
HOMEPAGE="http://www.ntop.org/ntop.html"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-libs/openssl-0.9.6
+ >=net-libs/libpcap-0.5.2"
src_compile() {
cd ${S}
diff --git a/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild b/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
index cd03056b6354..dc5c00154110 100644
--- a/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild,v 1.2 2000/09/15 20:09:08 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild,v 1.3 2000/11/02 08:31:52 achim Exp $
P=tcpdump-3.5.2
A=${P}.tar.gz
@@ -11,6 +11,9 @@ SRC_URI="http://www.tcpdump.org/release/${A}
http://www.jp.tcpdump.org/release/${A}"
HOMEPAGE="http://www.tcpdump.org/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/zlib-1.1.3
+ >=net-libs/libpcap-0.5.2"
src_compile() {
cd ${S}
diff --git a/net-analyzer/tcpstat/tcpstat-1.3.ebuild b/net-analyzer/tcpstat/tcpstat-1.3.ebuild
index 62c9abc45c11..fcaf22d2e7b9 100644
--- a/net-analyzer/tcpstat/tcpstat-1.3.ebuild
+++ b/net-analyzer/tcpstat/tcpstat-1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.3.ebuild,v 1.3 2000/09/15 20:09:08 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.3.ebuild,v 1.4 2000/11/02 08:31:52 achim Exp $
P=tcpstat-1.3
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="Reports network interface statistics"
SRC_URI="http://www.frenchfries.net/paul/tcpstat/${A}"
HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=net-libs/libpcap-0.5.2"
src_compile() {