summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-01-28 18:44:59 +0000
committerPeter Volkov <pva@gentoo.org>2010-01-28 18:44:59 +0000
commitfdbefc4814508392bdee2802478d649be141dbf1 (patch)
tree5e3748e6d6936c3d93546ac8ae20848c66d1ec6c /net-analyzer
parentDelete older ebuild. (diff)
downloadgentoo-2-fdbefc4814508392bdee2802478d649be141dbf1.tar.gz
gentoo-2-fdbefc4814508392bdee2802478d649be141dbf1.tar.bz2
gentoo-2-fdbefc4814508392bdee2802478d649be141dbf1.zip
Version bump, bug #302650, thank David for report. Dropped old patch.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/etherape/ChangeLog10
-rw-r--r--net-analyzer/etherape/etherape-0.9.9.ebuild31
-rw-r--r--net-analyzer/etherape/files/etherape-0.9.6-pause-crash-fix.patch20
3 files changed, 39 insertions, 22 deletions
diff --git a/net-analyzer/etherape/ChangeLog b/net-analyzer/etherape/ChangeLog
index c1539087e04d..6a6d97ada88c 100644
--- a/net-analyzer/etherape/ChangeLog
+++ b/net-analyzer/etherape/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/etherape
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/etherape/ChangeLog,v 1.53 2008/11/16 15:43:49 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/etherape/ChangeLog,v 1.54 2010/01/28 18:44:58 pva Exp $
+
+*etherape-0.9.9 (28 Jan 2010)
+
+ 28 Jan 2010; Peter Volkov <pva@gentoo.org>
+ -files/etherape-0.9.6-pause-crash-fix.patch, +etherape-0.9.9.ebuild:
+ Version bump, bug #302650, thank David for report. Dropped old patch.
16 Nov 2008; Peter Volkov <pva@gentoo.org> etherape-0.9.7-r1.ebuild:
Added missing dependency, bug #239675 thank Evil Compile Person for
diff --git a/net-analyzer/etherape/etherape-0.9.9.ebuild b/net-analyzer/etherape/etherape-0.9.9.ebuild
new file mode 100644
index 000000000000..c4b7fd121a3d
--- /dev/null
+++ b/net-analyzer/etherape/etherape-0.9.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/etherape/etherape-0.9.9.ebuild,v 1.1 2010/01/28 18:44:58 pva Exp $
+
+EAPI="2"
+inherit eutils gnome2 autotools
+
+DESCRIPTION="A graphical network monitor for Unix modeled after etherman"
+HOMEPAGE="http://etherape.sourceforge.net/"
+SRC_URI="mirror://sourceforge/etherape/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=sys-devel/gettext-0.11.5
+ app-text/gnome-doc-utils
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog FAQ NEWS README* TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.9.3-res_mkquery.patch"
+ eautoreconf
+}
diff --git a/net-analyzer/etherape/files/etherape-0.9.6-pause-crash-fix.patch b/net-analyzer/etherape/files/etherape-0.9.6-pause-crash-fix.patch
deleted file mode 100644
index 4a7a0a44e28c..000000000000
--- a/net-analyzer/etherape/files/etherape-0.9.6-pause-crash-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/capture.c.orig Sat Apr 29 09:58:35 2006
-+++ src/capture.c Mon May 29 01:14:23 2006
-@@ -464,10 +464,13 @@
- return FALSE;
- }
-
-- /* preparing protocol summary and nodes/links catalogs */
-- protocol_summary_open();
-- nodes_catalog_open();
-- links_catalog_open();
-+ if (status != PAUSE)
-+ {
-+ /* preparing protocol summary and nodes/links catalogs */
-+ protocol_summary_open();
-+ nodes_catalog_open();
-+ links_catalog_open();
-+ }
-
- /*
- * See pause_capture for an explanation of why we don't always