summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-05-29 22:17:40 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-05-29 22:17:40 +0000
commit377b8be481021ec2c8e541028ca47029a0d99be0 (patch)
treebf3799f235d2a0adc004be247b8f9d44bfe6641f /net-dialup
parent1.5Mb -> 1.5Gb typo fix (diff)
downloadgentoo-2-377b8be481021ec2c8e541028ca47029a0d99be0.tar.gz
gentoo-2-377b8be481021ec2c8e541028ca47029a0d99be0.tar.bz2
gentoo-2-377b8be481021ec2c8e541028ca47029a0d99be0.zip
Update ppp to version 2.4.1
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ppp-2.4.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-dialup/ppp/ppp-2.4.1.ebuild b/net-dialup/ppp/ppp-2.4.1.ebuild
new file mode 100644
index 000000000000..eb082945815c
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1.ebuild,v 1.1 2001/05/29 22:17:40 ryan Exp $
+
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Point-to-point protocol - used for communicating with your ISP"
+SRC_URI="ftp://ftp.linuxcare.com.au/pub/ppp/${A}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ try ./configure --prefix=/usr
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" -e "s/LIBS =/LIBS = -lcrypt/" Makefile.orig > Makefile
+ cd ../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O:COPTS = ${CFLAGS}:" Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+ export CC=gcc
+ try make
+}
+
+src_install() {
+ into /usr
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+ dodir /etc/ppp
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ insinto /etc/modules
+ doins ${FILESDIR}/modules.ppp
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+}