summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-08 05:07:38 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-08 05:07:38 +0000
commit481894f9f55c50acc84fe841fb93994e0973bd37 (patch)
tree227c1ba0316220114f0a67b07431374f2cb7fc1c /net-dialup
parentChanged the first line to the proper name (diff)
downloadgentoo-2-481894f9f55c50acc84fe841fb93994e0973bd37.tar.gz
gentoo-2-481894f9f55c50acc84fe841fb93994e0973bd37.tar.bz2
gentoo-2-481894f9f55c50acc84fe841fb93994e0973bd37.zip
new pppoe-enabled ppp (closes bug #1527)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ChangeLog10
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r71
-rw-r--r--net-dialup/ppp/files/modules.ppp3
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r7.ebuild102
4 files changed, 113 insertions, 3 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 5981ed065051..e40d459aeec4 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.2 2002/04/08 05:07:37 drobbins Exp $
-*ppp-2.4.1-r6 (1 Feb 2002)
+*ppp-2.4.1-r7 (08 Apr 2002)
+
+ 08 Apr 2002; Daniel Robbins <drobbins@gentoo.org> : New release of ppp (using
+ new kernel pppoe-enabled ebuild submitted by Christian Loitsch.) Closes bug
+ #1527.
+
+*ppp-2.4.1-r6 (01 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r7 b/net-dialup/ppp/files/digest-ppp-2.4.1-r7
new file mode 100644
index 000000000000..b3c7b1676065
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r7
@@ -0,0 +1 @@
+MD5 7f655448fbb6bebcede7a515fbcd481e ppp-2.4.1-pppoe4.tgz 556218
diff --git a/net-dialup/ppp/files/modules.ppp b/net-dialup/ppp/files/modules.ppp
index a37003a251f8..86f6d410228d 100644
--- a/net-dialup/ppp/files/modules.ppp
+++ b/net-dialup/ppp/files/modules.ppp
@@ -4,4 +4,5 @@ alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
-alias ppp-compress-26 ppp_deflate \ No newline at end of file
+alias ppp-compress-26 ppp_deflate
+alias net-pf-24 pppoe
diff --git a/net-dialup/ppp/ppp-2.4.1-r7.ebuild b/net-dialup/ppp/ppp-2.4.1-r7.ebuild
new file mode 100644
index 000000000000..be761e1a038d
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r7.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+# modified by Christian Loitsch <gentoo00@loitsch.org>
+
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="http://www.shoshin.uwaterloo.ca/~mostrows/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.shoshin.uwaterloo.ca/~mostrows/index.html"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/pppd"
+
+src_compile() {
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ Makefile.orig > Makefile
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../../../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+
+ into /usr
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ doins pppd/plugins/minconn.so
+ doins pppd/plugins/passprompt.so
+ doins pppd/plugins/pppoe/pppoe.so
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This will have to be updated to work with the new net.ppp0
+# # Added a couple scripts to simplify dialing up
+# # borrowed from debian, man they got some nice little apps :-)
+# dosbin ${FILESDIR}/pon
+# dosbin ${FILESDIR}/poff
+# doman ${FILESDIR}/pon.1
+ rm ${D}/usr/lib
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /usr/sbin/update-modules
+ fi
+ einfo "to enable kernel-pppoe read html/pppoe.html in the doc-directory"
+}