summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-03 16:37:32 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-03 16:37:32 +0000
commit8690eda46b12f84dcec302ca5465e9aaf5f65fd4 (patch)
treee677f8d73a343199c31b24b17fb9f44f30e53294 /net-dns/mydns
parentremoved myself from metdata.xml (diff)
downloadgentoo-2-8690eda46b12f84dcec302ca5465e9aaf5f65fd4.tar.gz
gentoo-2-8690eda46b12f84dcec302ca5465e9aaf5f65fd4.tar.bz2
gentoo-2-8690eda46b12f84dcec302ca5465e9aaf5f65fd4.zip
Remove old.
(Portage version: 2.1.11.53/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'net-dns/mydns')
-rw-r--r--net-dns/mydns/ChangeLog8
-rw-r--r--net-dns/mydns/files/04-update-smash-fix.dpatch43
-rw-r--r--net-dns/mydns/files/mydns-1.1.0-gcc41.patch240
-rw-r--r--net-dns/mydns/files/mydns-1.1.0-gentoo.patch55
-rw-r--r--net-dns/mydns/files/mydns-1.1.0-m4.patch81
-rw-r--r--net-dns/mydns/files/mydns-1.2.8.27-gentoo.patch55
-rw-r--r--net-dns/mydns/files/mydns.rc637
-rw-r--r--net-dns/mydns/mydns-1.1.0-r1.ebuild88
8 files changed, 7 insertions, 600 deletions
diff --git a/net-dns/mydns/ChangeLog b/net-dns/mydns/ChangeLog
index 6e3a5b1e1a51..9a132cdf235c 100644
--- a/net-dns/mydns/ChangeLog
+++ b/net-dns/mydns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/mydns
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.44 2013/03/03 16:18:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/ChangeLog,v 1.45 2013/03/03 16:37:31 kensington Exp $
+
+ 03 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+ -files/04-update-smash-fix.dpatch, -files/mydns-1.1.0-gcc41.patch,
+ -files/mydns-1.1.0-gentoo.patch, -files/mydns-1.1.0-m4.patch,
+ -files/mydns-1.2.8.27-gentoo.patch, -files/mydns.rc6, -mydns-1.1.0-r1.ebuild:
+ Remove old.
03 Mar 2013; Agostino Sarubbo <ago@gentoo.org> mydns-1.2.8.31.ebuild:
Stable for sparc, wrt bug #426684
diff --git a/net-dns/mydns/files/04-update-smash-fix.dpatch b/net-dns/mydns/files/04-update-smash-fix.dpatch
deleted file mode 100644
index 3db6b566f9b7..000000000000
--- a/net-dns/mydns/files/04-update-smash-fix.dpatch
+++ /dev/null
@@ -1,43 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 04-update-smash-fix.dpatch by Philipp Kern <pkern@debian.org>
-##
-## DP: Prevent attackers to smash the heap on DNS updates and fix a
-## DP: stack-based off-by-one overflow.
-
-@DPATCH@
-diff -urNad mydns-1.1.0~/src/mydns/update.c mydns-1.1.0/src/mydns/update.c
---- mydns-1.1.0~/src/mydns/update.c 2005-12-18 20:16:41.000000000 +0100
-+++ mydns-1.1.0/src/mydns/update.c 2007-04-28 11:14:15.000000000 +0200
-@@ -228,6 +228,9 @@
- DNS_GET16(rr->class, src);
- DNS_GET32(rr->ttl, src);
- DNS_GET16(rr->rdlength, src);
-+ if(rr->rdlength > sizeof rr->rdata)
-+ rr->rdlength = sizeof rr->rdata;
-+
- memcpy(rr->rdata, src, rr->rdlength);
- src += rr->rdlength;
-
-@@ -328,19 +331,16 @@
- {
- int n, x; /* Offset in 'data' */
-
-- for (n = 0; src < end && n < datalen; )
-+ for (n = 0; src < end && n < datalen - 1; )
- {
- int len = *src++;
-
- if (n)
- data[n++] = ' ';
-- for (x = 0; x < len && src < end && n < datalen; x++)
-+ for (x = 0; x < len && src < end && n < datalen - 1; x++)
- data[n++] = *src++;
- if (one_word_only)
-- {
-- data[n] = '\0';
-- return (src);
-- }
-+ break;
- }
- data[n] = '\0';
- return (src);
diff --git a/net-dns/mydns/files/mydns-1.1.0-gcc41.patch b/net-dns/mydns/files/mydns-1.1.0-gcc41.patch
deleted file mode 100644
index 683630516002..000000000000
--- a/net-dns/mydns/files/mydns-1.1.0-gcc41.patch
+++ /dev/null
@@ -1,240 +0,0 @@
-diff -Naur mydns-1.1.0.orig/src/lib/rr.c mydns-1.1.0.new/src/lib/rr.c
---- mydns-1.1.0.orig/src/lib/rr.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/lib/rr.c 2006-10-22 18:20:59.000000000 +0000
-@@ -438,9 +438,9 @@
- {
- MYDNS_RR *first = NULL, *last = NULL;
- size_t querylen;
-- uchar query[DNS_QUERYBUFSIZ],
-+ char query[DNS_QUERYBUFSIZ],
- namequery[DNS_MAXNAMELEN + DNS_MAXNAMELEN + DNS_MAXNAMELEN + 25] = "";
-- uchar *wheretype;
-+ char *wheretype;
- register char *c, *cp;
- SQL_RES *res;
- SQL_ROW row;
-diff -Naur mydns-1.1.0.orig/src/lib/sql.c mydns-1.1.0.new/src/lib/sql.c
---- mydns-1.1.0.orig/src/lib/sql.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/lib/sql.c 2006-10-22 18:20:59.000000000 +0000
-@@ -155,7 +155,7 @@
- int
- sql_istable(SQL *sqlConn, const char *tablename)
- {
-- unsigned char *xtablename;
-+ char *xtablename;
- #if !USE_PGSQL
- SQL_RES *res;
- #endif
-@@ -163,7 +163,7 @@
-
- if (!(xtablename = calloc(strlen(tablename) * 2 + 1, sizeof(unsigned char))))
- Err(_("out of memory"));
-- sql_escstr(sqlConn, xtablename, (uchar *)tablename, strlen(tablename));
-+ sql_escstr(sqlConn, xtablename, (char *)tablename, strlen(tablename));
-
- #if USE_PGSQL
- if (sql_count(sqlConn, "SELECT COUNT(*) FROM pg_class"
-@@ -191,7 +191,7 @@
- int
- sql_iscolumn(SQL *sqlConn, const char *tablename, const char *columnname)
- {
-- unsigned char *xtablename, *xcolumnname;
-+ char *xtablename, *xcolumnname;
- #if !USE_PGSQL
- SQL_RES *res;
- #endif
-@@ -201,8 +201,8 @@
- Err(_("out of memory"));
- if (!(xcolumnname = calloc(strlen(columnname) * 2 + 1, sizeof(unsigned char))))
- Err(_("out of memory"));
-- sql_escstr(sqlConn, xtablename, (uchar *)tablename, strlen(tablename));
-- sql_escstr(sqlConn, xcolumnname, (uchar *)columnname, strlen(columnname));
-+ sql_escstr(sqlConn, xtablename, (char *)tablename, strlen(tablename));
-+ sql_escstr(sqlConn, xcolumnname, (char *)columnname, strlen(columnname));
-
- #if USE_PGSQL
- if (sql_count(sqlConn,
-diff -Naur mydns-1.1.0.orig/src/mydns/alias.c mydns-1.1.0.new/src/mydns/alias.c
---- mydns-1.1.0.orig/src/mydns/alias.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/alias.c 2006-10-22 18:20:59.000000000 +0000
-@@ -67,7 +67,7 @@
- of the label with `*' and check for wildcard matches. */
- if (*label)
- {
-- uchar wclabel[DNS_MAXNAMELEN+1], *c;
-+ char wclabel[DNS_MAXNAMELEN+1], *c;
-
- /* Generate wildcarded label, i.e. `*.example' or maybe just `*'. */
- if (!(c = strchr(label, '.')))
-diff -Naur mydns-1.1.0.orig/src/mydns/listen.c mydns-1.1.0.new/src/mydns/listen.c
---- mydns-1.1.0.orig/src/mydns/listen.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/listen.c 2006-10-22 18:20:59.000000000 +0000
-@@ -264,7 +264,7 @@
- if (!(buf = malloc(buflen)))
- Err(_("out of memory"));
- ifc.ifc_len = buflen;
-- ifc.ifc_buf = buf;
-+ ifc.ifc_buf = (char *)buf;
-
- if ((n = ioctl(sockfd, SIOCGIFCONF, (char *)&ifc)) != -1)
- {
-diff -Naur mydns-1.1.0.orig/src/mydns/named.h mydns-1.1.0.new/src/mydns/named.h
---- mydns-1.1.0.orig/src/mydns/named.h 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/named.h 2006-10-22 18:20:59.000000000 +0000
-@@ -204,7 +204,7 @@
-
-
- /* task.c */
--extern int new_task(TASK *, unsigned char *, size_t);
-+extern int new_task(TASK *, char *, size_t);
- extern void task_init_header(TASK *);
- extern char *clientaddr(TASK *);
- extern char *desctask(TASK *);
-diff -Naur mydns-1.1.0.orig/src/mydns/recursive.c mydns-1.1.0.new/src/mydns/recursive.c
---- mydns-1.1.0.orig/src/mydns/recursive.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/recursive.c 2006-10-22 18:20:59.000000000 +0000
-@@ -143,9 +143,10 @@
- int
- recursive_fwd_read(TASK *t)
- {
-- char reply[DNS_MAXPACKETLEN_UDP + 2], *r;
-- int replylen, addrlen = sizeof(struct sockaddr_in);
-- uint16_t id, qdcount, ancount, nscount, arcount;
-+ char reply[DNS_MAXPACKETLEN_UDP + 2], *r;
-+ int replylen;
-+ socklen_t addrlen = sizeof(struct sockaddr_in);
-+ uint16_t id, qdcount, ancount, nscount, arcount;
- DNS_HEADER hdr;
-
- #if DEBUG_ENABLED && DEBUG_RECURSIVE
-diff -Naur mydns-1.1.0.orig/src/mydns/task.c mydns-1.1.0.new/src/mydns/task.c
---- mydns-1.1.0.orig/src/mydns/task.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/task.c 2006-10-22 18:20:59.000000000 +0000
-@@ -35,9 +35,9 @@
- Returns 0 on success, -1 on error, -2 if the task is now invalid.
- **************************************************************************************************/
- int
--new_task(TASK *t, unsigned char *data, size_t len)
-+new_task(TASK *t, char *data, size_t len)
- {
-- unsigned char qname[DNS_MAXNAMELEN+1], *src, *qdtop;
-+ char qname[DNS_MAXNAMELEN+1], *src, *qdtop;
-
- #if DEBUG_ENABLED && DEBUG_TASK
- Debug("new_task(%p, %p, %u)", t, data, len);
-diff -Naur mydns-1.1.0.orig/src/mydns/task.h mydns-1.1.0.new/src/mydns/task.h
---- mydns-1.1.0.orig/src/mydns/task.h 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/task.h 2006-10-22 18:20:59.000000000 +0000
-@@ -44,7 +44,7 @@
- {
- dns_rrtype_t rrtype; /* Record type (what table this data came from) */
- uint32_t id; /* ID associated with RR */
-- unsigned char name[DNS_MAXNAMELEN];/* Name to send with reply */
-+ char name[DNS_MAXNAMELEN];/* Name to send with reply */
- off_t offset; /* The offset within the reply data (t->rdata) */
- size_t length; /* The length of data within the reply */
- uint8_t sort_level; /* Primary sort order */
-@@ -104,7 +104,7 @@
-
- uint32_t Cnames[MAX_CNAME_LEVEL]; /* Array of CNAMEs found */
-
-- unsigned char *qd; /* Question section data */
-+ char *qd; /* Question section data */
- size_t qdlen; /* Size of question section */
- uint16_t qdcount; /* "qdcount", from header */
- uint16_t ancount; /* "ancount", from header */
-diff -Naur mydns-1.1.0.orig/src/mydns/tcp.c mydns-1.1.0.new/src/mydns/tcp.c
---- mydns-1.1.0.orig/src/mydns/tcp.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/tcp.c 2006-10-22 18:20:59.000000000 +0000
-@@ -118,7 +118,7 @@
- int
- read_tcp_query(TASK *t)
- {
-- unsigned char *end;
-+ char *end;
- int rv;
-
- /* Read packet length if we haven't already */
-diff -Naur mydns-1.1.0.orig/src/mydns/update.c mydns-1.1.0.new/src/mydns/update.c
---- mydns-1.1.0.orig/src/mydns/update.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/mydns/update.c 2006-10-22 18:20:59.000000000 +0000
-@@ -34,7 +34,7 @@
- dns_class_t class;
- uint32_t ttl;
- uint16_t rdlength;
-- unsigned char rdata[DNS_MAXPACKETLEN_UDP + 1];
-+ char rdata[DNS_MAXPACKETLEN_UDP + 1];
- } UQRR;
-
-
-diff -Naur mydns-1.1.0.orig/src/util/check.c mydns-1.1.0.new/src/util/check.c
---- mydns-1.1.0.orig/src/util/check.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/util/check.c 2006-10-22 18:20:59.000000000 +0000
-@@ -386,16 +386,16 @@
- static void
- check_rr_cname(void)
- {
-- unsigned char *xname;
-+ char *xname;
- int found = 0;
-
- EXPAND_DATA(data);
- check_name(data, "rr.data", 1);
-
- /* A CNAME record can't have any other type of RR data for the same name */
-- if (!(xname = calloc(strlen(name) * 2 + 1, sizeof(unsigned char))))
-+ if (!(xname = calloc(strlen(name) * 2 + 1, sizeof(char))))
- Err(_("out of memory"));
-- sql_escstr(sql, xname, (unsigned char *)name, strlen(name));
-+ sql_escstr(sql, xname, (char *)name, strlen(name));
- found = sql_count(sql, "SELECT COUNT(*) FROM %s WHERE zone=%u AND name='%s' AND type != 'CNAME'",
- mydns_rr_table_name, rr->zone, xname);
-
-@@ -404,9 +404,9 @@
- {
- Free(xname);
- shortname(name, 1);
-- if (!(xname = calloc(strlen(name) * 2 + 1, sizeof(unsigned char))))
-+ if (!(xname = calloc(strlen(name) * 2 + 1, sizeof(char))))
- Err(_("out of memory"));
-- sql_escstr(sql, xname, (unsigned char *)name, strlen(name));
-+ sql_escstr(sql, xname, (char *)name, strlen(name));
- found = sql_count(sql, "SELECT COUNT(*) FROM %s WHERE zone=%u AND name='%s' AND type != 'CNAME'",
- mydns_rr_table_name, rr->zone, xname);
- EXPAND_DATA(name);
-diff -Naur mydns-1.1.0.orig/src/util/export.c mydns-1.1.0.new/src/util/export.c
---- mydns-1.1.0.orig/src/util/export.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/util/export.c 2006-10-22 18:20:59.000000000 +0000
-@@ -270,7 +270,7 @@
- printf("%s %s\n", rr->data, rr->rp_txt);
- else if (rr->type == DNS_QTYPE_TXT)
- {
-- register unsigned char *c;
-+ register char *c;
- putc('"', stdout);
- for (c = rr->data; *c; c++)
- {
-diff -Naur mydns-1.1.0.orig/src/util/import-axfr.c mydns-1.1.0.new/src/util/import-axfr.c
---- mydns-1.1.0.orig/src/util/import-axfr.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/util/import-axfr.c 2006-10-22 18:20:59.000000000 +0000
-@@ -462,7 +462,7 @@
- void
- import_axfr(char *hostport, char *import_zone)
- {
-- unsigned char *reply, len[2];
-+ char *reply, len[2];
- int fd;
- size_t replylen;
-
-diff -Naur mydns-1.1.0.orig/src/util/ptrconvert.c mydns-1.1.0.new/src/util/ptrconvert.c
---- mydns-1.1.0.orig/src/util/ptrconvert.c 2006-10-22 18:20:08.000000000 +0000
-+++ mydns-1.1.0.new/src/util/ptrconvert.c 2006-10-22 18:20:59.000000000 +0000
-@@ -290,7 +290,7 @@
- else /* Insert new record */
- {
- long id;
-- uchar query[DNS_QUERYBUFSIZ];
-+ char query[DNS_QUERYBUFSIZ];
- int querylen;
- char esc_origin[DNS_MAXNAMELEN + DNS_MAXNAMELEN + 1];
- char esc_ns[520], esc_mbox[520];
diff --git a/net-dns/mydns/files/mydns-1.1.0-gentoo.patch b/net-dns/mydns/files/mydns-1.1.0-gentoo.patch
deleted file mode 100644
index e27acf6978d5..000000000000
--- a/net-dns/mydns/files/mydns-1.1.0-gentoo.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -Naur mydns-1.1.0.orig/doc/Makefile.am mydns-1.1.0/doc/Makefile.am
---- mydns-1.1.0.orig/doc/Makefile.am 2004-02-28 03:28:06.000000000 +0900
-+++ mydns-1.1.0/doc/Makefile.am 2008-12-28 09:48:57.000000000 +0900
-@@ -33,25 +33,25 @@
- fi
-
- mydns.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnscheck.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydns.conf.5: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydns-conf.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsexport.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsimport.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsptrconvert.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- html:
- if [ -x /usr/local/bin/mydns-texi2html ]; then /usr/local/bin/mydns-texi2html mydns.texi; fi
-diff -Naur mydns-1.1.0.orig/m4/mydns.m4 mydns-1.1.0/m4/mydns.m4
---- mydns-1.1.0.orig/m4/mydns.m4 2006-01-19 07:08:14.000000000 +0900
-+++ mydns-1.1.0/m4/mydns.m4 2008-12-28 09:29:30.000000000 +0900
-@@ -363,7 +363,6 @@
- AC_C_CFLAGS(-fomit-frame-pointer)
- AC_C_CFLAGS(-finline-functions)
- AC_C_CFLAGS(-ffast-math)
-- LDFLAGS="$LDFLAGS -static"
- fi
- fi
- ], [
-@@ -372,7 +371,6 @@
- AC_C_CFLAGS(-fomit-frame-pointer)
- AC_C_CFLAGS(-finline-functions)
- AC_C_CFLAGS(-ffast-math)
-- LDFLAGS="$LDFLAGS -static"
- fi
- ]
- )
diff --git a/net-dns/mydns/files/mydns-1.1.0-m4.patch b/net-dns/mydns/files/mydns-1.1.0-m4.patch
deleted file mode 100644
index c8f86dff1bb2..000000000000
--- a/net-dns/mydns/files/mydns-1.1.0-m4.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naur mydns-1.1.0.orig/m4/mydns.m4 mydns-1.1.0/m4/mydns.m4
---- mydns-1.1.0.orig/m4/mydns.m4 2006-01-19 07:08:14.000000000 +0900
-+++ mydns-1.1.0/m4/mydns.m4 2006-01-22 13:09:39.000000000 +0900
-@@ -517,47 +517,10 @@
- ##
- AC_DEFUN([AC_LIB_MYSQLCLIENT],
- [
-- libmysqlclient_dirs="/usr/local/mysql/lib /usr/local/lib/mysql /usr/local/lib /usr/lib/mysql /usr/lib /lib"
-- AC_ARG_WITH(mysql-lib,
-- AC_HELP_STRING([--with-mysql-lib=DIR], [look for the MySQL client library in DIR]),
-- libmysqlclient_dirs="$withval $libmysqlclient_dirs")
-- libmysqlclient_found=no, libmysqlclient_ok=no
-- for libmysqlclient_dir in $libmysqlclient_dirs; do
-- if test "$libmysqlclient_found" != yes; then
-- AC_CHECK_FILE($libmysqlclient_dir/libmysqlclient.a, libmysqlclient_found=yes, libmysqlclient_found=no)
-- if test "$libmysqlclient_found" != yes; then
-- AC_CHECK_FILE($libmysqlclient_dir/libmysqlclient.so.10, libmysqlclient_found=yes, libmysqlclient_found=no)
-- fi
-- if test "$libmysqlclient_found" != yes; then
-- AC_CHECK_FILE($libmysqlclient_dir/libmysqlclient.so.12, libmysqlclient_found=yes, libmysqlclient_found=no)
-- fi
-- if test "$libmysqlclient_found" = yes; then
-- ## libmysqlclient depends on libz
-- if ! test -n "$LIBZ"; then
-- AC_LIB_Z
-- fi
-- if ! test -n "$LIBZ"; then
-- ## No zlib
-- AC_MSG_ERROR([
--
--][ ###
--][ ### zlib compression library (libz.a) not found.
--][ ###
--][ ### Please download and install the zlib compression
--][ ### library from the following URL:
--][ ###
--][ ### http://www.gzip.org/zlib/
--][ ###
--][ ### (Error detail might be available in `config.log')
--][ ###
--])
-- fi
-- LIBMYSQLCLIENT="-L$libmysqlclient_dir -lmysqlclient"
-- #LIBMYSQLCLIENT="$libmysqlclient_dir/libmysqlclient.a"
-- libmysqlclient_found=yes
-- fi
-- fi
-- done
-+ AC_CHECK_PROG(LIBMYSQLCLIENT,mysql_config,`mysql_config --libs`)
-+ if test -z "$LIBMYSQLCLIENT"; then
-+ AC_MSG_ERROR([Could not find mysql_config script. Make sure the mysql client libraries are installed])
-+ fi
- AC_SUBST(LIBMYSQLCLIENT)
- ]
- )
-@@ -567,21 +530,10 @@
- ##
- AC_DEFUN([AC_HEADER_MYSQL],
- [
-- ac_mydns_header_dirs="/usr/include /usr/include/mysql /usr/local/include \
-- /usr/local/include/mysql /usr/local/mysql/include"
-- ac_mydns_header_found=no, ac_mydns_header_ok=no
-- AC_ARG_WITH(mysql-include,
-- AC_HELP_STRING([--with-mysql-include=DIR],
-- [look for MySQL include files in DIR]),
-- ac_mydns_header_dirs="$withval $ac_mydns_header_dirs")
-- for dir in $ac_mydns_header_dirs
-- do
-- if test "$ac_mydns_header_found" != yes
-- then
-- AC_CHECK_FILE($dir/mysql.h, ac_mydns_header_found=yes, ac_mydns_header_found=no)
-- test "$ac_mydns_header_found" = yes && MYSQL_INCLUDE="-I$dir"
-- fi
-- done
-+ AC_CHECK_PROG(MYSQL_INCLUDE,mysql_config,`mysql_config --include`)
-+ if test -z "$MYSQL_INCLUDE"; then
-+ AC_MSG_ERROR([Could not find mysql_config script. Make sure the mysql headers are installed])
-+ fi
- AC_SUBST(MYSQL_INCLUDE)
- ]
- )
diff --git a/net-dns/mydns/files/mydns-1.2.8.27-gentoo.patch b/net-dns/mydns/files/mydns-1.2.8.27-gentoo.patch
deleted file mode 100644
index c4d9c132840c..000000000000
--- a/net-dns/mydns/files/mydns-1.2.8.27-gentoo.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -Naur mydns-1.1.0.orig/doc/Makefile.am mydns-1.1.0/doc/Makefile.am
---- mydns-1.1.0.orig/doc/Makefile.am 2004-02-28 03:28:06.000000000 +0900
-+++ mydns-1.1.0/doc/Makefile.am 2008-12-28 09:48:57.000000000 +0900
-@@ -33,25 +33,25 @@
- fi
-
- mydns.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnscheck.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydns.conf.5: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydns-conf.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsexport.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsimport.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- mydnsptrconvert.8: sedfile ${@:=.in}
-- $(SHELL) @top_srcdir@/missing --run sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-+ sed -f @SEDFILE@ ${@:=.in} | tr -s '\n' > $@
-
- html:
- if [ -x /usr/local/bin/mydns-texi2html ]; then /usr/local/bin/mydns-texi2html mydns.texi; fi
---- mydns-1.2.8/m4/mydns.m4.orig 2009-02-02 14:52:34.000000000 +0100
-+++ mydns-1.2.8/m4/mydns.m4 2010-12-01 22:31:20.000000000 +0100
-@@ -357,16 +357,12 @@
- AC_MSG_RESULT([no])
- if test -z "$PROFILE_ENABLED"; then
- AC_C_CFLAGS(-finline-functions)
-- else
-- LDFLAGS="$LDFLAGS -static"
- fi
- fi
- ], [
- AC_MSG_RESULT([no])
- if test -z "$PROFILE_ENABLED"; then
- AC_C_CFLAGS(-finline-functions)
-- else
-- LDFLAGS="$LDFLAGS -static"
- fi
- ]
- )
diff --git a/net-dns/mydns/files/mydns.rc6 b/net-dns/mydns/files/mydns.rc6
deleted file mode 100644
index e79248da31b2..000000000000
--- a/net-dns/mydns/files/mydns.rc6
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/files/mydns.rc6,v 1.6 2007/04/30 10:32:09 matsuu Exp $
-
-depend() {
- need net
- use logger __db__
-}
-
-checkconfig() {
- if [ ! -f /etc/mydns.conf ] ; then
- eerror "No /etc/mydns.conf file exists!"
- eerror "You should now run these commands:"
- eerror "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
- eerror "# chmod 0600 /etc/mydns.conf"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting mydns"
- start-stop-daemon --start --quiet --exec /usr/sbin/mydns -- -b
- eend $?
-}
-
-stop () {
- ebegin "Stopping mydns"
- PIDFILE=`cat /etc/mydns.conf | grep pidfile | awk '{ print $3 }'`
- if [ $PIDFILE == "" ]; then
- PIDFILE=/var/run/mydns.pid
- fi
- start-stop-daemon --stop --quiet \
- --pidfile=${PIDFILE}
- eend $?
-}
diff --git a/net-dns/mydns/mydns-1.1.0-r1.ebuild b/net-dns/mydns/mydns-1.1.0-r1.ebuild
deleted file mode 100644
index 96fc667edb1a..000000000000
--- a/net-dns/mydns/mydns-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/mydns/mydns-1.1.0-r1.ebuild,v 1.9 2010/06/17 21:47:22 patrick Exp $
-
-inherit eutils
-
-DESCRIPTION="A DNS-Server which gets its data from mysql-databases"
-HOMEPAGE="http://mydns.bboy.net/"
-SRC_URI="http://mydns.bboy.net/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ~ppc sparc x86"
-IUSE="debug nls postgres ssl static zlib"
-
-RDEPEND="ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- postgres? ( dev-db/postgresql-server )
- !postgres? ( virtual/mysql )"
-DEPEND="${RDEPEND}
- sys-devel/bison"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-m4.patch
- epatch "${FILESDIR}"/04-update-smash-fix.dpatch
- autoconf || die
-}
-
-src_compile() {
- local myconf
-
- if ! use postgres; then
- myconf="${myconf} --with-mysql"
- else
- myconf="${myconf} --without-mysql --with-pgsql"
- fi
-
- econf --enable-alias \
- `use_enable nls` \
- `use_enable debug` \
- `use_enable static static-build` \
- `use_with ssl openssl` \
- `use_with zlib` \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- dodoc AUTHORS BUGS ChangeLog NEWS README TODO
-
- newinitd "${FILESDIR}"/mydns.rc6 mydns || die
-
- if ! use postgres; then
- sed -i -e 's/__db__/mysql/g' "${D}"/etc/init.d/mydns || die
- dodoc QUICKSTART.mysql README.mysql
- else
- sed -i -e 's/__db__/postgresql/g' "${D}"/etc/init.d/mydns || die
- dodoc QUICKSTART.postgres
- fi
-}
-
-pkg_postinst() {
- elog
- elog "You should now run these commands:"
- elog
- elog "# /usr/sbin/mydns --dump-config > /etc/mydns.conf"
- elog "# chmod 0600 /etc/mydns.conf"
- if ! use postgres; then
- elog "# mysqladmin -u <useruname> -p create mydns"
- elog "# /usr/sbin/mydns --create-tables | mysql -u <username> -p mydns"
- elog
- elog "to create the tables in the MySQL-Database."
- elog "For more info see QUICKSTART.mysql."
- else
- elog "# createdb mydns"
- elog "# /usr/sbin/mydns --create-tables | psql mydns"
- elog
- elog "to create the tables in the PostgreSQL-Database."
- elog "For more info see QUICKSTART.postgres."
- fi
- elog
-}