summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-17 01:56:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-17 01:56:12 +0000
commit74aec6507b50117a7cfc1a68d79367ec2ede5fe0 (patch)
treef0286249c4da654b6fbea85e1012f9c0a6d27aeb /net-dns
parentAdded missing files. (diff)
downloadgentoo-2-74aec6507b50117a7cfc1a68d79367ec2ede5fe0.tar.gz
gentoo-2-74aec6507b50117a7cfc1a68d79367ec2ede5fe0.tar.bz2
gentoo-2-74aec6507b50117a7cfc1a68d79367ec2ede5fe0.zip
bug fixes and doc support
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/ChangeLog10
-rw-r--r--net-dns/bind/bind-9.2.2_rc1-r1.ebuild126
-rw-r--r--net-dns/bind/files/127.0.02
-rw-r--r--net-dns/bind/files/digest-bind-9.2.2_rc1-r11
-rw-r--r--net-dns/bind/files/localhost6
5 files changed, 139 insertions, 6 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index ade091bc430e..9d54ba3eca9b 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-dns/bind
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.7 2002/08/16 09:02:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.8 2002/08/17 01:56:12 seemant Exp $
+
+*bind-9.2.2_rc1-r1 (16 Aug 2002)
+
+ 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> bind-9.2.2_rc1-r1.ebuild :
+
+ Many bugfixes with config files, and optional documentation installation
+ (doc USE flag). Thanks again to kevin@aptbasilicata.it (Maurizio
+ Disimino) in bug #6590.
*bind-9.2.2_rc1 (16 Aug 2002)
diff --git a/net-dns/bind/bind-9.2.2_rc1-r1.ebuild b/net-dns/bind/bind-9.2.2_rc1-r1.ebuild
new file mode 100644
index 000000000000..023235be78a4
--- /dev/null
+++ b/net-dns/bind/bind-9.2.2_rc1-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2_rc1-r1.ebuild,v 1.1 2002/08/17 01:56:12 seemant Exp $
+
+MY_P=${P/_}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BIND - Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV/_}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9-beta.html"
+
+KEYWORDS="x86"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="sys-apps/groff
+ ssl? ( >=dev-libs/openssl-0.9.6e )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --enable-threads \
+ --with-libtool \
+ ${myconf} || die "failed to configure bind"
+
+ make || die "failed to compile bind"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "failed to install bind"
+
+ for x in `grep -l -d recurse -e '/etc/named.conf' -e '/etc/rndc.conf' -e '/etc/rndc.key' ${D}/usr/share/man`; do
+ cp ${x} ${x}.orig
+ sed -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' ${x}.orig > ${x}
+ rm ${x}.orig
+ done
+
+ find ${D}/usr/share/man ! -name "*[1-8]gz" -type f -exec gzip -f "{}" \;
+ insinto /usr/share/man/man5 ; doins ${FILESDIR}/named.conf.5.gz
+ doman ${FILESDIR}/nslookup.8
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc ; dodoc doc/misc/*
+ docinto html ; dodoc doc/arm/*
+ docinto draft ; dodoc doc/draft/*
+ docinto rfc ; dodoc doc/rfc/*
+ docinto contrib ; dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+ }
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${FILESDIR}/dyndns-samples.tbz2
+
+ dodir /etc/bind /var/bind /var/bind/pri /var/bind/sec
+
+ insinto /etc/bind ; doins ${FILESDIR}/named.conf
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+ insinto /var/bind/pri ; doins ${FILESDIR}/{127.0.0,localhost}
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/named.rc6 named
+ insinto /etc/conf.d ; newins ${FILESDIR}/named.confd named
+
+ dosym /var/bind/named.ca /var/bind/root.cache
+ dosym /var/bind/pri /etc/bind/pri
+ dosym /var/bind/sec /etc/bind/sec
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ /usr/sbin/rndc-confgen -a -u named
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ echo
+ einfo "Bind-9.2.2_rc1 version and higher now include chroot support."
+ einfo "If you would like to run bind in chroot, run:"
+ einfo "\`ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\`"
+ echo
+}
+
+pkg_config() {
+ # chroot concept contributed by j2ee (kevin@aptbasilicata.it)
+
+ mkdir -p /chroot/{dns/{dev,etc,var/run/named}}
+ chown -R named:named /chroot/dns/var/run/named
+ cp -R /etc/bind /chroot/dns/etc/
+ cp /etc/localtime /chroot/dns/etc/localtime
+ chown named:named /chroot/dns/etc/bind/rndc.key
+ chgrp named /chroot/dns/etc/bind/named.conf
+ cp -R /var/bind /chroot/dns/var/
+ chown -R named:named /chroot/dns/var/bind/{pri,sec}
+ mknod /chroot/dns/dev/zero c 1 5
+ mknod /chroot/dns/dev/random c 1 8
+ chmod 666 /chroot/dns/dev/{random,zero}
+
+ chmod 700 /{chroot,chroot/dns}
+ chown named:named /chroot/dns
+
+ cp /etc/conf.d/named /etc/conf.d/named.orig
+ sed -e 's:^#CHROOT="/chroot/dns"$:CHROOT="/chroot/dns":' \
+ /etc/conf.d/named.orig > /etc/conf.d/named
+ rm -f /etc/conf.d/named.orig
+
+ echo
+ einfo "Check your config files in /chroot/dns"
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k /chroot/dns/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ echo
+}
diff --git a/net-dns/bind/files/127.0.0 b/net-dns/bind/files/127.0.0
index f356ed6299aa..8fb59140cee9 100644
--- a/net-dns/bind/files/127.0.0
+++ b/net-dns/bind/files/127.0.0
@@ -1,7 +1,7 @@
$ORIGIN 0.0.127.in-addr.arpa.
$TTL 1W
@ 1D IN SOA localhost. root.localhost. (
- 42 ; serial (d. adams)
+ 2002081601 ; serial
3H ; refresh
15M ; retry
1W ; expiry
diff --git a/net-dns/bind/files/digest-bind-9.2.2_rc1-r1 b/net-dns/bind/files/digest-bind-9.2.2_rc1-r1
new file mode 100644
index 000000000000..f599f5e0e918
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.2.2_rc1-r1
@@ -0,0 +1 @@
+MD5 e591be8890c53845133577ac7e042fb6 bind-9.2.2rc1.tar.gz 5049320
diff --git a/net-dns/bind/files/localhost b/net-dns/bind/files/localhost
index be5b6feb4e9e..7e858ae8b4a2 100644
--- a/net-dns/bind/files/localhost
+++ b/net-dns/bind/files/localhost
@@ -1,11 +1,9 @@
-$ORIGIN localhost
$TTL 1W
@ IN SOA localhost. root.localhost. (
- 1999081701 ; Serial
+ 2002081601 ; Serial
28800 ; Refresh
14400 ; Retry
604800 ; Expire - 1 week
86400 ) ; Minimum
- IN NS localhost.
-
+ IN NS localhost.
1 IN PTR localhost.