summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-01-26 10:40:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-01-26 10:40:53 +0000
commit6fb3cc523c851c299d5e74e128eee3fd7ecd60cf (patch)
tree75e3ff772d3b8bf85ca84be2bc8e05db11595601 /net-firewall/iptables/iptables-1.2.9.ebuild
parentupdate cvs snapshot (diff)
downloadgentoo-2-6fb3cc523c851c299d5e74e128eee3fd7ecd60cf.tar.gz
gentoo-2-6fb3cc523c851c299d5e74e128eee3fd7ecd60cf.tar.bz2
gentoo-2-6fb3cc523c851c299d5e74e128eee3fd7ecd60cf.zip
Unmask and bugs fixed
Diffstat (limited to 'net-firewall/iptables/iptables-1.2.9.ebuild')
-rw-r--r--net-firewall/iptables/iptables-1.2.9.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-firewall/iptables/iptables-1.2.9.ebuild b/net-firewall/iptables/iptables-1.2.9.ebuild
index bac33962564f..6d0ebe8aa809 100644
--- a/net-firewall/iptables/iptables-1.2.9.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9.ebuild,v 1.3 2003/12/03 23:03:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9.ebuild,v 1.4 2004/01/26 10:40:42 aliz Exp $
inherit eutils flag-o-matic
@@ -16,7 +16,7 @@ SRC_URI="http://www.iptables.org/files/${P}.tar.bz2"
HOMEPAGE="http://www.iptables.org/"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~arm ~mips ~ia64 ~amd64"
+KEYWORDS="x86 ~ppc ~alpha ~sparc ~hppa ~arm ~mips ~ia64 amd64"
LICENSE="GPL-2"
# iptables is dependent on kernel sources. Strange but true.
@@ -40,8 +40,7 @@ src_unpack() {
chmod +x extensions/.IMQ-test*
- cp Makefile Makefile.new
- sed -e "s:-O2:${CFLAGS} -Iinclude:g" -e "s:/usr/local::g" -e "s:-Iinclude/::" Makefile.new > Makefile
+ sed -i -e "s:-O2:${CFLAGS} -Iinclude:g" -e "s:/usr/local::g" -e "s:-Iinclude/::" Makefile
}
src_compile() {
@@ -68,7 +67,7 @@ src_install() {
INCDIR=/usr/include \
install-devel
- dodoc COPYING KNOWN_BUGS
+ dodoc COPYING
dodir /var/lib/iptables ; keepdir /var/lib/iptables
exeinto /etc/init.d
newexe ${FILESDIR}/iptables.init iptables
@@ -88,5 +87,8 @@ pkg_postinst() {
einfo "This package now includes an initscript which loads and saves"
einfo "rules stored in /var/lib/iptables/rules-save"
einfo "This location can be changed in /etc/conf.d/iptables"
+
+ einfo "If you are using the iptables initsscript you should save your"
+ einfo "rules using the new iptables version before rebooting."
}