summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
commit541f14235634ec9414e89e8089beca533ffca899 (patch)
tree86d726368da8d5082e4e7b43278d3a356de0605c /net-fs/autofs
parent*** empty log message *** (diff)
downloadgentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.gz
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.bz2
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.zip
*** empty log message ***
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/autofs-3.1.7.ebuild44
-rw-r--r--net-fs/autofs/files/digest-autofs-3.1.71
2 files changed, 45 insertions, 0 deletions
diff --git a/net-fs/autofs/autofs-3.1.7.ebuild b/net-fs/autofs/autofs-3.1.7.ebuild
new file mode 100644
index 000000000000..61b99bcb93ed
--- /dev/null
+++ b/net-fs/autofs/autofs-3.1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-3.1.7.ebuild,v 1.1 2000/11/26 20:54:18 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Automounter"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/daemons/autofs/${A}
+ ftp://ftp.de.kernel.org/pub/linux/daemons/autofs/${A}
+ ftp://ftp.uk.kernel.org/pub/linux/daemons/autofs/${A}"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${HOST} --prefix=/usr
+ try make
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dosbin daemon/automount
+ insinto /usr/lib/autofs
+ insopts -m 755
+ doins modules/*.so
+ dodoc COPYING COPYRIGHT NEWS README* TODO
+ cd man
+ doman auto.master.5 autofs.5 autofs.8 automount.8
+ cd ../samples
+ dodir /etc/autofs
+ cp ${O}/files/auto.master ${D}/etc/autofs
+ cp ${O}/files/auto.misc ${D}/etc/autofs
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/autofs ${D}/etc/rc.d/init.d
+}
+
+pkg_config() {
+ . ${ROOT}/etc/rc.d/config/functions
+ echo "Activating autofs..."
+ ${ROOT}/usr/sbin/rc-update add autofs
+}
+
diff --git a/net-fs/autofs/files/digest-autofs-3.1.7 b/net-fs/autofs/files/digest-autofs-3.1.7
new file mode 100644
index 000000000000..55137064ccd8
--- /dev/null
+++ b/net-fs/autofs/files/digest-autofs-3.1.7
@@ -0,0 +1 @@
+MD5 4f602f82442b48ce9c2e0005d59c3408 autofs-3.1.7.tar.bz2