summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-03 23:31:34 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-03 23:31:34 +0000
commitca3e06049d72f3f43d394a382fcd124dbedffba3 (patch)
tree1f33a7110b5859babd241f958e63afd0c1eeb515 /net-fs/openafs
parentNew version, masked for testing. (diff)
downloadgentoo-2-ca3e06049d72f3f43d394a382fcd124dbedffba3.tar.gz
gentoo-2-ca3e06049d72f3f43d394a382fcd124dbedffba3.tar.bz2
gentoo-2-ca3e06049d72f3f43d394a382fcd124dbedffba3.zip
Version bump and security fix.
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/ChangeLog8
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.61
-rw-r--r--net-fs/openafs/openafs-1.2.6.ebuild95
3 files changed, 103 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 1e952030fbe6..4b91caeb5bd5 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.5 2002/08/02 23:08:25 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.6 2002/08/03 23:31:34 aliz Exp $
+
+*openafs-1.2.6 (03 Aug 2002)
+
+ 03 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> openafs-1.2.6.ebuild :
+
+ Security fix.
*openafs-1.2.5-r1 (03 Aug 2002)
diff --git a/net-fs/openafs/files/digest-openafs-1.2.6 b/net-fs/openafs/files/digest-openafs-1.2.6
new file mode 100644
index 000000000000..b00313ecd518
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.6
@@ -0,0 +1 @@
+MD5 c97e19c398d169538c4d852a6304722a openafs-1.2.6-src.tar.bz2 10229773
diff --git a/net-fs/openafs/openafs-1.2.6.ebuild b/net-fs/openafs/openafs-1.2.6.ebuild
new file mode 100644
index 000000000000..b83964630e36
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.5.ebuild,v 1.0 2002/07/10 09:52:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://openafs.org/dl/openafs/${PV}/${P}-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/config
+ cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
+ rm Makefile.i386_linux24.in.old
+}
+
+src_compile() {
+ ./configure \
+ --with-afs-sysname=i386_linux24 \
+ --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}