summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-02 22:47:20 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-02 22:47:20 +0000
commit5e69093a7cdd10623fe3f3f157b68e74ae2ec675 (patch)
tree4d0c7c824358eed5dcc3990f8acd4f3cf3b72913 /net-fs
parentAdded sunprc overflow patch (diff)
downloadgentoo-2-5e69093a7cdd10623fe3f3f157b68e74ae2ec675.tar.gz
gentoo-2-5e69093a7cdd10623fe3f3f157b68e74ae2ec675.tar.bz2
gentoo-2-5e69093a7cdd10623fe3f3f157b68e74ae2ec675.zip
Security update.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs/ChangeLog14
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.5-r11
-rw-r--r--net-fs/openafs/files/digest-openafs-1.3.2-r11
-rw-r--r--net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch24
-rw-r--r--net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch58
-rw-r--r--net-fs/openafs/openafs-1.2.5-r1.ebuild93
-rw-r--r--net-fs/openafs/openafs-1.3.2-r1.ebuild92
7 files changed, 282 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 2a8c91258af5..35e2cf460c34 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.3 2002/07/30 08:02:31 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.4 2002/08/02 22:47:20 aliz Exp $
+
+*openafs-1.3.2-r1 (03 Aug 2002)
+
+ 02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> openafs-1.3.2-r1.ebuild :
+
+ Security fix.
+
+*openafs-1.2.5-r1 (03 Aug 2002)
+
+ 02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> openafs-1.2.5-r1.ebuild :
+
+ Security fix.
*openafs-1.3.2 (29 Jul 2002)
diff --git a/net-fs/openafs/files/digest-openafs-1.2.5-r1 b/net-fs/openafs/files/digest-openafs-1.2.5-r1
new file mode 100644
index 000000000000..36c605500ab8
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.5-r1
@@ -0,0 +1 @@
+MD5 2d3380bc226fdedb9a74804412743349 openafs-1.2.5-src.tar.bz2 10223247
diff --git a/net-fs/openafs/files/digest-openafs-1.3.2-r1 b/net-fs/openafs/files/digest-openafs-1.3.2-r1
new file mode 100644
index 000000000000..80848ade5cd3
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.3.2-r1
@@ -0,0 +1 @@
+MD5 5057634d9f6c44d5ca9a6dd9fdd84184 openafs-1.3.2-src.tar.gz 12578259
diff --git a/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch b/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
new file mode 100644
index 000000000000..e28f1006c0ff
--- /dev/null
+++ b/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
@@ -0,0 +1,24 @@
+--- openafs/src/rx/xdr_array.c 2001/08/08 00:03:57 1.4
++++ openafs/src/rx/xdr_array.c 2002/07/31 23:13:49 1.4.2.1
+@@ -29,7 +29,7 @@
+ #include <afsconfig.h>
+ #include <afs/param.h>
+
+-RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch,v 1.1 2002/08/02 22:47:20 aliz Exp $");
++RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch,v 1.1 2002/08/02 22:47:20 aliz Exp $");
+
+ #ifndef NeXT
+
+@@ -84,7 +84,10 @@
+ register caddr_t target = *addrp;
+ register u_int c; /* the actual element count */
+ register bool_t stat = TRUE;
+- register int nodesize;
++ register u_int nodesize;
++
++ i = ((~0) >> 1) / elsize;
++ if (maxsize > i) maxsize = i;
+
+ /* like strings, arrays are really counted arrays */
+ if (! xdr_u_int(xdrs, sizep)) {
+
diff --git a/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch b/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch
new file mode 100644
index 000000000000..0b93136ed616
--- /dev/null
+++ b/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch
@@ -0,0 +1,58 @@
+--- openafs/src/rx/xdr_array.c 2001/08/08 00:03:57 1.4
++++ openafs/src/rx/xdr_array.c 2002/07/31 23:13:28 1.4.6.3
+@@ -29,7 +29,7 @@
+ #include <afsconfig.h>
+ #include <afs/param.h>
+
+-RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch,v 1.1 2002/08/02 22:47:20 aliz Exp $");
++RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch,v 1.1 2002/08/02 22:47:20 aliz Exp $");
+
+ #ifndef NeXT
+
+@@ -57,10 +57,6 @@
+ #endif
+ #include "xdr.h"
+
+-#ifndef osi_alloc
+-char *osi_alloc();
+-#endif
+-
+ #define LASTUNSIGNED ((u_int)0-1)
+
+
+@@ -71,20 +67,25 @@
+ * elsize is the size (in bytes) of each element, and elproc is the
+ * xdr procedure to call to handle each element of the array.
+ */
+-bool_t
+-xdr_array(xdrs, addrp, sizep, maxsize, elsize, elproc)
+- register XDR *xdrs;
+- caddr_t *addrp; /* array pointer */
+- u_int *sizep; /* number of elements */
+- u_int maxsize; /* max numberof elements */
+- u_int elsize; /* size in bytes of each element */
+- xdrproc_t elproc; /* xdr routine to handle each element */
++/*
++ caddr_t *addrp; * array pointer *
++ u_int *sizep; * number of elements *
++ u_int maxsize; * max numberof elements *
++ u_int elsize; * size in bytes of each element *
++ xdrproc_t elproc; * xdr routine to handle each element *
++*/
++
++bool_t xdr_array(register XDR *xdrs, caddr_t *addrp, u_int *sizep,
++ u_int maxsize, u_int elsize, xdrproc_t elproc)
+ {
+ register u_int i;
+ register caddr_t target = *addrp;
+ register u_int c; /* the actual element count */
+ register bool_t stat = TRUE;
+- register int nodesize;
++ register u_int nodesize;
++
++ i = ((~0) >> 1) / elsize;
++ if (maxsize > i) maxsize = i;
+
+ /* like strings, arrays are really counted arrays */
+ if (! xdr_u_int(xdrs, sizep)) {
+
diff --git a/net-fs/openafs/openafs-1.2.5-r1.ebuild b/net-fs/openafs/openafs-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..cda5dcc5057a
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.5-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.5.ebuild,v 1.0 2002/07/10 09:52:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system"
+
+SRC_URI="http://openafs.org/dl/openafs/1.2.5/openafs-1.2.5-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/${P}-sunrpc-overflow.patch || die
+
+ cd ${S}/src/config
+ cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
+ rm Makefile.i386_linux24.in.old
+}
+
+src_compile() {
+ ./configure \
+ --with-afs-sysname=i386_linux24 \
+ --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}
diff --git a/net-fs/openafs/openafs-1.3.2-r1.ebuild b/net-fs/openafs/openafs-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..51e52c4a867e
--- /dev/null
+++ b/net-fs/openafs/openafs-1.3.2-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.1.1.ebuild,v 1.3 2001/08/31 03:23:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system"
+
+SRC_URI="http://www.openafs.org/dl/openafs/${PV}/openafs-${PV}-src.tar.gz"
+HOMEPAGE="http://www.openafs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-sunrpc-overflow.patch || die
+
+ cd ${S}/src/config
+ cp Makefile.in Makefile.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.in.old > Makefile.in
+ rm Makefile.in.old
+}
+
+src_compile() {
+ ./configure \
+ --with-afs-sysname=i386_linux24 \
+ --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}