summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-01 19:22:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-01 19:22:19 +0000
commit66f66f728ef4f281798acc478d18edf8af94454f (patch)
tree9388cc97dc07750ed954de4fde7d781a3d23dcb8 /net-fs
parentAdded netatalk till I can test it (diff)
downloadgentoo-2-66f66f728ef4f281798acc478d18edf8af94454f.tar.gz
gentoo-2-66f66f728ef4f281798acc478d18edf8af94454f.tar.bz2
gentoo-2-66f66f728ef4f281798acc478d18edf8af94454f.zip
*** empty log message ***
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/netatalk/files/digest-netatalk-1.5_pre61
-rw-r--r--net-fs/netatalk/netatalk-1.5_pre6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-fs/netatalk/files/digest-netatalk-1.5_pre6 b/net-fs/netatalk/files/digest-netatalk-1.5_pre6
new file mode 100644
index 000000000000..9ee9022de84d
--- /dev/null
+++ b/net-fs/netatalk/files/digest-netatalk-1.5_pre6
@@ -0,0 +1 @@
+MD5 e875b55c649caa02ff5f1eea698c3d15 netatalk-1.5pre6.tar.bz2
diff --git a/net-fs/netatalk/netatalk-1.5_pre6.ebuild b/net-fs/netatalk/netatalk-1.5_pre6.ebuild
new file mode 100644
index 000000000000..9bb0daf925e1
--- /dev/null
+++ b/net-fs/netatalk/netatalk-1.5_pre6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.5_pre6.ebuild,v 1.1 2001/07/01 19:22:19 achim Exp $
+
+P=netatalk-1.5pre6
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Apple-Talk"
+SRC_URI="http://download.sourceforge.net/netatalk/${A}"
+HOMEPAGE="http://netatakl.sourceforge.net"
+
+DEPEND="virtual/glibc
+ pam? ( sys-libs/pam-0.7 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ssl? ( dev-libs/openssl )
+ sys-apps/shadow
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake
+ >=sys-libs/db-3"
+
+RDEPEND="virtual/glibc
+ pam? ( sys-libs/pam-0.7 )
+ sys-apps/shadow
+ >=sys-libs/db-3"
+
+src_compile() {
+
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ fi
+ if [ "`use tcpd`" ] ; then
+ myconf="$myconf --with-tcp-wrappers"
+ fi
+ if [ -z "`use ssl`" ] ; then
+ myconf="$myconf --disable-ssl"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --enable-fhs $myconf
+
+ try make
+
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ rm ${D}/etc/rc.d/init.d/*
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/atalk
+ dodoc BUGS CHANGES README* COPYRIGHT VERSION
+
+}
+
+
+
+