summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-08 05:53:21 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-08 05:53:21 +0000
commitb89a665aee7e58d52cce8c8b67352e734a869f73 (patch)
tree6f15b52702ffc5dc643f18c5f95508dfb7f964d9 /net-fs
parentSet proper python modname. (diff)
downloadgentoo-2-b89a665aee7e58d52cce8c8b67352e734a869f73.tar.gz
gentoo-2-b89a665aee7e58d52cce8c8b67352e734a869f73.tar.bz2
gentoo-2-b89a665aee7e58d52cce8c8b67352e734a869f73.zip
Fix building with arches that do not support nfsctl syscalls.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog6
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.2.4-no-nfsctl.patch43
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.4.ebuild3
3 files changed, 50 insertions, 2 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 4363f5b716d8..0a98f7b819ab 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.190 2011/10/17 18:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.191 2011/12/08 05:53:21 vapier Exp $
+
+ 08 Dec 2011; Mike Frysinger <vapier@gentoo.org> nfs-utils-1.2.4.ebuild,
+ +files/nfs-utils-1.2.4-no-nfsctl.patch:
+ Fix building with arches that do not support nfsctl syscalls.
17 Oct 2011; Mike Frysinger <vapier@gentoo.org> nfs-utils-1.2.4.ebuild:
Pull in pkg-config since we use it #387365 by bay.
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.2.4-no-nfsctl.patch b/net-fs/nfs-utils/files/nfs-utils-1.2.4-no-nfsctl.patch
new file mode 100644
index 000000000000..e36ac25547f3
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-1.2.4-no-nfsctl.patch
@@ -0,0 +1,43 @@
+From b02133aaa4feec085627172b5466d8c64a11a5a6 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 8 Dec 2011 00:10:27 -0500
+Subject: [PATCH] nfsctl: fix building with newer arches
+
+Newer arches omitting both nfsctl and nfsservctl which breaks nfsctl.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ support/nfs/nfsctl.c | 8 +++++++-
+ 1 files changed, 7 insertions(+), 1 deletions(-)
+
+diff --git a/support/nfs/nfsctl.c b/support/nfs/nfsctl.c
+index 89fa1a4..fec775f 100644
+--- a/support/nfs/nfsctl.c
++++ b/support/nfs/nfsctl.c
+@@ -11,16 +11,22 @@
+ #endif
+
+ #include <unistd.h>
++#include <errno.h>
+ #include <asm/unistd.h>
+ #include "nfslib.h"
+
+ /* compatibility hack... */
+-#ifndef __NR_nfsctl
++#if !defined(__NR_nfsctl) && defined(__NR_nfsservctl)
+ #define __NR_nfsctl __NR_nfsservctl
+ #endif
+
+ int
+ nfsctl (int cmd, struct nfsctl_arg * argp, union nfsctl_res * resp)
+ {
++#ifdef __NR_nfsctl
+ return syscall (__NR_nfsctl, cmd, argp, resp);
++#else
++ errno = ENOSYS;
++ return -1;
++#endif
+ }
+--
+1.7.6.1
+
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild
index d705f447f3cf..20cef1d1b28e 100644
--- a/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild,v 1.5 2011/10/17 18:56:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.4.ebuild,v 1.6 2011/12/08 05:53:21 vapier Exp $
EAPI="2"
@@ -52,6 +52,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-conditional.patch
epatch "${FILESDIR}"/${PN}-1.2.4-nfsidmap.patch
epatch "${FILESDIR}"/${PN}-1.2.4-cross-build.patch
+ epatch "${FILESDIR}"/${PN}-1.2.4-no-nfsctl.patch
eautoreconf
}