summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-05 00:30:13 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-05 00:30:13 +0000
commitc64ba2795822ff49c8bbebc7e39a990b5f867101 (patch)
treeff20a788c1a903c362e5f7704950c91aec419746 /net-ftp
parentnew version (kde3-enabled) (diff)
downloadgentoo-2-c64ba2795822ff49c8bbebc7e39a990b5f867101.tar.gz
gentoo-2-c64ba2795822ff49c8bbebc7e39a990b5f867101.tar.bz2
gentoo-2-c64ba2795822ff49c8bbebc7e39a990b5f867101.zip
New version
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog9
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.5.41
-rw-r--r--net-ftp/lftp/lftp-2.5.4.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 1454bdee0101..ce153eaf8fea 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.2 2002/07/05 00:30:13 stroke Exp $
+
+*lftp-2.5.4 (05 Jul 2002)
+
+ 05 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> lftp-2.5.4.ebuild :
+
+ new version.
+
*lftp-2.4.9 (1 Feb 2002)
diff --git a/net-ftp/lftp/files/digest-lftp-2.5.4 b/net-ftp/lftp/files/digest-lftp-2.5.4
new file mode 100644
index 000000000000..66bc16db4974
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.5.4
@@ -0,0 +1 @@
+MD5 94bff81a84bac8c9029b2f4f8262c1f0 lftp-2.5.4.tar.bz2 1106183
diff --git a/net-ftp/lftp/lftp-2.5.4.ebuild b/net-ftp/lftp/lftp-2.5.4.ebuild
new file mode 100644
index 000000000000..3a5dc0cb71b8
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.5.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.5.4.ebuild,v 1.1 2002/07/05 00:30:13 stroke Exp $
+
+DESCRIPTION="Groovy little ftp client"
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${P}.tar.bz2"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+DEPEND="${RDEPEND} nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ #hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}