summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-10-19 17:18:30 +0000
committerTilman Klar <phoenix@gentoo.org>2002-10-19 17:18:30 +0000
commitf0cc1f51a15a05bde59305b1777ffb96c607b50a (patch)
tree1242f944867415866975815c4dec0199b8ba7831 /net-im/gaim-cvs
parentstuff for the alpha 1.4rc1-r1 release (diff)
downloadgentoo-2-f0cc1f51a15a05bde59305b1777ffb96c607b50a.tar.gz
gentoo-2-f0cc1f51a15a05bde59305b1777ffb96c607b50a.tar.bz2
gentoo-2-f0cc1f51a15a05bde59305b1777ffb96c607b50a.zip
Initial import of gaim-cvs
Diffstat (limited to 'net-im/gaim-cvs')
-rw-r--r--net-im/gaim-cvs/ChangeLog9
-rw-r--r--net-im/gaim-cvs/files/digest-gaim-cvs-0.600
-rw-r--r--net-im/gaim-cvs/gaim-cvs-0.60.ebuild97
3 files changed, 106 insertions, 0 deletions
diff --git a/net-im/gaim-cvs/ChangeLog b/net-im/gaim-cvs/ChangeLog
new file mode 100644
index 000000000000..7ee80b5a7949
--- /dev/null
+++ b/net-im/gaim-cvs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/gaim-cvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/ChangeLog,v 1.1 2002/10/19 17:18:30 phoenix Exp $
+
+*gaim-cvs-0.60 (19 Oct 2002)
+
+ 19 Oct 2002; phoen][x <phoenix@gentoo.org> gaim-cvs-0.60.ebuild:
+
+ Initial import. This is the gaim CVS ebuild.
diff --git a/net-im/gaim-cvs/files/digest-gaim-cvs-0.60 b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60
diff --git a/net-im/gaim-cvs/gaim-cvs-0.60.ebuild b/net-im/gaim-cvs/gaim-cvs-0.60.ebuild
new file mode 100644
index 000000000000..c7c0eff27236
--- /dev/null
+++ b/net-im/gaim-cvs/gaim-cvs-0.60.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/gaim-cvs-0.60.ebuild,v 1.1 2002/10/19 17:18:30 phoenix Exp $
+
+IUSE="nas nls esd gnome arts gtk2 perl"
+
+MY_P=${PN/-cvs/}
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/gaim"
+ECVS_MODULE="${MY_P}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${ECVS_BRANCH}"
+
+inherit cvs
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GTK Instant Messenger client - CVS ebuild"
+HOMEPAGE="http://gaim.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( >=sys-devel/gettext-0.11.4 )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gtk2? ( =x11-libs/gtk+-2.0* =dev-libs/glib-2.0* )
+ || ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2*
+ ( gnome? ( =gnome-base/gnome-panel-1.4* >=media-libs/gdk-pixbuf-0.16.0 ) ) )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+
+ local myconf gnomeopts
+ echo ${S}
+ cd ${S}
+
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ if [ "` use arts`" ]; then
+ inherit kde-functions
+ set-kdedir 3
+ # $KDEDIR now points to arts location
+ else
+ myconf="${myconf} --disable-artsc"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ gnomeopts="${myconf}"
+
+ if [ "`use gtk2`" ];
+ then
+
+ # GTK+ 2 support
+ myconf="${myconf} --enable-gtk2"
+
+ fi
+
+ gnomeopts="${myconf}"
+
+ # Gnome is disabled for GTK+ 2.0 build and first build of GTK 1.4 version
+ myconf="${myconf} --disable-gnome"
+
+ # always build standalone gaim program
+ #econf ${myconf} || die
+ ./autogen.sh ${myconf} || die
+ emake || die
+
+ # if gnome support is enabled (and gtk2 disabled), then build gaim_applet
+ if [ "`use gnome`" -a -z "`use gtk2`" ];
+ then
+ gnomeopts="${gnomeopts} --with-gnome=${GNOME_PATH} --enable-panel"
+
+ # save appletless version and clean up
+ cp src/gaim ${S}/gaim || die "standalone version failed to build"
+ make distclean || die
+
+ econf ${gnomeopts} || die
+ emake || die
+ fi
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ # if gnome enabled, make sure to install standalone version also
+ use gnome && dobin ${S}/gaim
+
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}