summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-11-10 18:40:34 +0000
committerDon Seiler <rizzo@gentoo.org>2004-11-10 18:40:34 +0000
commitd56420c85933ac5f2021bfb36708d20ab3143160 (patch)
tree363cf9980d638d8c74c0c3124abb07b0eb958799 /net-im/gaim
parentppc-macos doesn't like elibtoolize --reverse-deps (Manifest recommit) (diff)
downloadgentoo-2-d56420c85933ac5f2021bfb36708d20ab3143160.tar.gz
gentoo-2-d56420c85933ac5f2021bfb36708d20ab3143160.tar.bz2
gentoo-2-d56420c85933ac5f2021bfb36708d20ab3143160.zip
Adding patch to fix bug with IRC chatrooms in buddy lists
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/Manifest13
-rw-r--r--net-im/gaim/files/digest-gaim-1.0.2-r11
-rw-r--r--net-im/gaim/files/gaim-1.0.3cvs-ircbuddylist.patch123
-rw-r--r--net-im/gaim/gaim-1.0.2-r1.ebuild122
5 files changed, 255 insertions, 11 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index f9ca1dcbb08c..60eab8f37201 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.263 2004/10/21 15:52:44 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.264 2004/11/10 18:40:34 rizzo Exp $
+
+*gaim-1.0.2-r1 (10 Nov 2004)
+
+ 10 Nov 2004; Don Seiler <rizzo@gentoo.org> +gaim-1.0.2-r1.ebuild:
+ Adding patch to fix bug with IRC chatrooms in buddy lists
21 Oct 2004; Don Seiler <rizzo@gentoo.org>
-files/gaim-0.81-security2.diff,
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 22c17c6cf601..307e650e863c 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 9e55dcc2aa271b99061bd4f0085e21e7 ChangeLog 40960
+MD5 eeb4bf040e4f1ef9d70ba28ce97b8c1c gaim-1.0.2-r1.ebuild 3592
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 9a750c10b3ecf56646c18bb40985b9f7 gaim-1.0.2.ebuild 3539
+MD5 5a965d7dbdfe4f077deabcee9695526b files/gaim-1.0.3cvs-ircbuddylist.patch 4051
+MD5 f9039f6cb5717109cf48a9f7e5d51a32 files/digest-gaim-1.0.2-r1 64
MD5 afc682711efed5d09a9229bd06a7a13b files/gaim-0.76-xinput.patch 644
MD5 f9039f6cb5717109cf48a9f7e5d51a32 files/digest-gaim-1.0.2 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBirLwHTu7gpaalycRAlToAKCk2UvsTRLlzXGyx4NGHZbGf/mInACgolC5
-pJnz2NeCHkkEJBoQyWhjzkY=
-=Smfj
------END PGP SIGNATURE-----
diff --git a/net-im/gaim/files/digest-gaim-1.0.2-r1 b/net-im/gaim/files/digest-gaim-1.0.2-r1
new file mode 100644
index 000000000000..3245e384dee3
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-1.0.2-r1
@@ -0,0 +1 @@
+MD5 80fbe23c6206ca6c0c62c30d5091d7e4 gaim-1.0.2.tar.bz2 4809084
diff --git a/net-im/gaim/files/gaim-1.0.3cvs-ircbuddylist.patch b/net-im/gaim/files/gaim-1.0.3cvs-ircbuddylist.patch
new file mode 100644
index 000000000000..5825a875e453
--- /dev/null
+++ b/net-im/gaim/files/gaim-1.0.3cvs-ircbuddylist.patch
@@ -0,0 +1,123 @@
+? AUTHORS.recv
+? NEWS.stu
+? gaim-1.0.0.tar.gz
+? gaim-1.0.1cvs.tar.gz
+? gaim.bin.rcv
+? gaim.rcv-foo-blah
+? stugen.sh
+? plugins/newline.c
+? plugins/yahoo_im_buzz.c
+Index: plugins/statenotify.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/plugins/statenotify.c,v
+retrieving revision 1.21.2.1
+diff -u -p -r1.21.2.1 statenotify.c
+--- plugins/statenotify.c 3 Sep 2004 21:34:04 -0000 1.21.2.1
++++ plugins/statenotify.c 10 Nov 2004 16:41:38 -0000
+@@ -18,6 +18,7 @@ write_status(GaimBuddy *buddy, const cha
+ GaimConversation *conv;
+ const char *who;
+ char buf[256];
++ char *escaped;
+
+ conv = gaim_find_conversation_with_account(buddy->name, buddy->account);
+
+@@ -25,8 +26,10 @@ write_status(GaimBuddy *buddy, const cha
+ return;
+
+ who = gaim_buddy_get_alias(buddy);
++ escaped = g_markup_escape_text(who, -1);
+
+- g_snprintf(buf, sizeof(buf), message, who);
++ g_snprintf(buf, sizeof(buf), message, escaped);
++ g_free(escaped);
+
+ gaim_conversation_write(conv, NULL, buf, GAIM_MESSAGE_SYSTEM, time(NULL));
+ }
+Index: src/gtkdialogs.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/gtkdialogs.c,v
+retrieving revision 1.11.2.11
+diff -u -p -r1.11.2.11 gtkdialogs.c
+--- src/gtkdialogs.c 23 Oct 2004 15:25:33 -0000 1.11.2.11
++++ src/gtkdialogs.c 10 Nov 2004 16:41:40 -0000
+@@ -874,15 +874,18 @@ static void
+ gaim_gtkdialogs_remove_chat_cb(GaimChat *chat)
+ {
+ char *name = NULL;
++ GaimAccount *account;
+ GaimConversation *conv = NULL;
+
+- if (GAIM_PLUGIN_PROTOCOL_INFO(chat->account->gc->prpl)->get_chat_name != NULL)
+- name = GAIM_PLUGIN_PROTOCOL_INFO(chat->account->gc->prpl)->get_chat_name(chat->components);
++ account = chat->account;
++
++ if (GAIM_PLUGIN_PROTOCOL_INFO(account->gc->prpl)->get_chat_name != NULL)
++ name = GAIM_PLUGIN_PROTOCOL_INFO(account->gc->prpl)->get_chat_name(chat->components);
+
+ gaim_blist_remove_chat(chat);
+
+ if (name != NULL) {
+- conv = gaim_find_conversation_with_account(name, chat->account);
++ conv = gaim_find_conversation_with_account(name, account);
+ g_free(name);
+ }
+
+Index: src/gtkpounce.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/gtkpounce.c,v
+retrieving revision 1.60
+diff -u -p -r1.60 gtkpounce.c
+--- src/gtkpounce.c 30 Aug 2004 01:40:07 -0000 1.60
++++ src/gtkpounce.c 10 Nov 2004 16:41:40 -0000
+@@ -948,6 +948,9 @@ pounce_cb(GaimPounce *pounce, GaimPounce
+ {
+ char tmp[1024];
+ const char *name_shown;
++ char *escaped;
++
++ escaped = g_markup_escape_text(alias, -1);
+
+ /*
+ * Here we place the protocol name in the pounce dialog to lessen
+@@ -971,7 +974,9 @@ pounce_cb(GaimPounce *pounce, GaimPounce
+ (events & GAIM_POUNCE_AWAY) ?
+ _("%s has gone away. (%s)") :
+ _("Unknown pounce event. Please report this!"),
+- alias, gaim_account_get_protocol_name(account));
++ escaped, gaim_account_get_protocol_name(account));
++
++ g_free(escaped);
+
+ /*
+ * Ok here is where I change the second argument, title, from
+Index: src/gtkprefs.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/gtkprefs.c,v
+retrieving revision 1.204.2.3
+diff -u -p -r1.204.2.3 gtkprefs.c
+--- src/gtkprefs.c 2 Oct 2004 00:11:54 -0000 1.204.2.3
++++ src/gtkprefs.c 10 Nov 2004 16:41:40 -0000
+@@ -636,7 +636,7 @@ gint gaim_sort_smileys (GtkTreeModel *mo
+ gpointer userdata)
+ {
+ gint ret = 0;
+- gchar *name1, *name2;
++ gchar *name1 = NULL, *name2 = NULL;
+
+ gtk_tree_model_get(model, a, 3, &name1, -1);
+ gtk_tree_model_get(model, b, 3, &name2, -1);
+@@ -645,8 +645,11 @@ gint gaim_sort_smileys (GtkTreeModel *mo
+ if (!(name1 == NULL && name2 == NULL))
+ ret = (name1 == NULL) ? -1: 1;
+ } else if (!g_ascii_strcasecmp(name1, "none")) {
+- /* Sort name1 first */
+- ret = -1;
++ if (!g_utf8_collate(name1, name2))
++ ret = 0;
++ else
++ /* Sort name1 first */
++ ret = -1;
+ } else if (!g_ascii_strcasecmp(name2, "none")) {
+ /* Sort name2 first */
+ ret = 1;
diff --git a/net-im/gaim/gaim-1.0.2-r1.ebuild b/net-im/gaim/gaim-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..8533899b5f24
--- /dev/null
+++ b/net-im/gaim/gaim-1.0.2-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.0.2-r1.ebuild,v 1.1 2004/11/10 18:40:34 rizzo Exp $
+
+inherit flag-o-matic eutils gcc debug
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86"
+#IUSE="nls perl spell nas crypt cjk gnutls silc eds debug"
+IUSE="nls perl spell nas crypt cjk gnutls silc debug"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ dev-util/pkgconfig
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.8.2-r1
+ !<dev-perl/ExtUtils-MakeMaker-6.17 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ dev-libs/nss
+ gnutls? ( net-libs/gnutls )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )"
+ #eds? ( gnome-extra/evolution-data-server )"
+
+PDEPEND="crypt? ( >=x11-plugins/gaim-encryption-2.32 )"
+
+# List of plugins
+# net-im/gaim-blogger
+# net-im/gaim-meanwhile
+# net-im/gaim-snpp
+# x11-plugins/autoprofile
+# x11-plugins/gaim-encryption
+# x11-plugins/gaim-extprefs
+# x11-plugins/gaim-rhythmbox
+# x11-plugins/gaim-xmms-remote
+# x11-plugins/gaimosd
+# x11-plugins/guifications
+
+
+print_gaim_warning() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ einfo
+ einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
+ einfo
+ ebeep 5
+ epause 3
+}
+
+pkg_setup() {
+ print_gaim_warning
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
+ epatch ${FILESDIR}/gaim-1.0.3cvs-ircbuddylist.patch
+}
+
+src_compile() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use debug && myconf="${myconf} --enable-debug"
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ myconf="${myconf} --disable-gevolution"
+ #use eds || myconf="${myconf} --disable-gevolution"
+
+ if use gnutls ; then
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/lib"
+ else
+ myconf="${myconf} --enable-gnutls=no"
+ fi
+
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib"
+ myconf="${myconf} --with-nss-libs=/usr/lib/nss"
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ print_gaim_warning
+}