summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-12-26 08:30:41 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-12-26 08:30:41 +0000
commit765c5dd3b8152ec1a2ba272c3526bc2aa321115a (patch)
tree949522b1a7e447c7920959d5658f9164639983df /net-im/licq
parentadd bug number (diff)
downloadgentoo-2-765c5dd3b8152ec1a2ba272c3526bc2aa321115a.tar.gz
gentoo-2-765c5dd3b8152ec1a2ba272c3526bc2aa321115a.tar.bz2
gentoo-2-765c5dd3b8152ec1a2ba272c3526bc2aa321115a.zip
bug #12623 (c++ fix)
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog10
-rw-r--r--net-im/licq/files/1.2.0a-gcc3-gentoo.patch51
-rw-r--r--net-im/licq/files/digest-licq-1.2.0a-r31
-rw-r--r--net-im/licq/licq-1.2.0a-r3.ebuild75
4 files changed, 136 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 39262af99519..41880c5a4aa7 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.6 2002/12/01 21:20:42 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.7 2002/12/26 08:30:41 mkennedy Exp $
+
+*licq-1.2.0a-r3 (26 Dec 2002)
+
+ 26 Dec 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ licq-1.2.0a-r3.ebuild, files/digest-licq-1.2.0a-r3, ChangeLog,
+ files/1.2.0a-gcc3-gentoo.patch :
+
+ C++ fix for gcc3. Resolves bug 12623. (Marking ~x86 until tested).
*licq-1.2.0a-r2 (01 Dec 2002)
diff --git a/net-im/licq/files/1.2.0a-gcc3-gentoo.patch b/net-im/licq/files/1.2.0a-gcc3-gentoo.patch
new file mode 100644
index 000000000000..6b751847b07d
--- /dev/null
+++ b/net-im/licq/files/1.2.0a-gcc3-gentoo.patch
@@ -0,0 +1,51 @@
+diff -ur licq-1.2.0a/src/icqd-filetransfer.cpp licq-1.2.0a~/src/icqd-filetransfer.cpp
+--- licq-1.2.0a/src/icqd-filetransfer.cpp 2002-07-25 21:21:11.000000000 -0500
++++ licq-1.2.0a~/src/icqd-filetransfer.cpp 2002-12-25 13:16:06.000000000 -0600
+@@ -377,7 +377,7 @@
+ m_nSpeed = b.UnpackUnsignedLong();
+ b.UnpackString(m_szRemoteName, sizeof(m_szRemoteName));
+
+- m_nBatchStartTime = time(TIME_NOW);
++ m_nBatchStartTime = time(NULL);
+ m_nBatchBytesTransfered = m_nBatchPos = 0;
+
+ PushFileTransferEvent(FT_STARTxBATCH);
+@@ -451,7 +451,7 @@
+ // if this is the first call to this function...
+ if (m_nBytesTransfered == 0)
+ {
+- m_nStartTime = time(TIME_NOW);
++ m_nStartTime = time(NULL);
+ m_nBatchPos += m_nFilePos;
+ gLog.Info("%sFile Transfer: Receiving %s (%ld bytes).\n", L_TCPxSTR,
+ m_szFileName, m_nFileSize);
+@@ -569,7 +569,7 @@
+ m_nFileSize = p.GetFileSize();
+ strcpy(m_szFileName, p.GetFileName());
+
+- m_nBatchStartTime = time(TIME_NOW);
++ m_nBatchStartTime = time(NULL);
+ m_nBatchBytesTransfered = m_nBatchPos = 0;
+
+ PushFileTransferEvent(FT_STARTxBATCH);
+@@ -722,7 +722,7 @@
+
+ if (m_nBytesTransfered == 0)
+ {
+- m_nStartTime = time(TIME_NOW);
++ m_nStartTime = time(NULL);
+ m_nBatchPos += m_nFilePos;
+ gLog.Info("%sFile Transfer: Sending %s (%ld bytes).\n", L_TCPxSTR,
+ m_szPathName, m_nFileSize);
+diff -ur licq-1.2.0a/src/licq.cpp licq-1.2.0a~/src/licq.cpp
+--- licq-1.2.0a/src/licq.cpp 2002-07-22 22:59:24.000000000 -0500
++++ licq-1.2.0a~/src/licq.cpp 2002-12-25 13:15:09.000000000 -0600
+@@ -681,7 +681,7 @@
+ if (bDaemonShutdown)
+ {
+ struct timespec abstime;
+- abstime.tv_sec = time(TIME_NOW) + MAX_WAIT_PLUGIN;
++ abstime.tv_sec = time(NULL) + (time_t) MAX_WAIT_PLUGIN;
+ abstime.tv_nsec = 0;
+ if (pthread_cond_timedwait(&LP_IdSignal, &LP_IdMutex, &abstime) == ETIMEDOUT)
+ break;
diff --git a/net-im/licq/files/digest-licq-1.2.0a-r3 b/net-im/licq/files/digest-licq-1.2.0a-r3
new file mode 100644
index 000000000000..7b91e3648cbf
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.0a-r3
@@ -0,0 +1 @@
+MD5 3f977d83b36b26d1bc716be3e3336315 licq-1.2.0a.tar.bz2 1741476
diff --git a/net-im/licq/licq-1.2.0a-r3.ebuild b/net-im/licq/licq-1.2.0a-r3.ebuild
new file mode 100644
index 000000000000..1885923b9faf
--- /dev/null
+++ b/net-im/licq/licq-1.2.0a-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.0a-r3.ebuild,v 1.1 2002/12/26 08:30:41 mkennedy Exp $
+
+IUSE="ssl socks5 qt kde"
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="~x86"
+S=${WORKDIR}/${P}
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PV}-config.patch || die
+ patch -p1 < ${FILESDIR}/${PV}-qt31.patch || die
+ patch -p1 < ${FILESDIR}/${PV}-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui-1.2.0
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.2.0
+ make DESTDIR=${D} install || die
+ fi
+
+}