summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-31 20:30:54 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-31 20:30:54 +0000
commitf7bfcdb5ea59ce35695dd014a1cbccddecd5c3cb (patch)
treed68bf8b786d9cc5b1868de766da0db5cbcd304d2 /net-im
parentMarked stable on x86. (diff)
downloadgentoo-2-f7bfcdb5ea59ce35695dd014a1cbccddecd5c3cb.tar.gz
gentoo-2-f7bfcdb5ea59ce35695dd014a1cbccddecd5c3cb.tar.bz2
gentoo-2-f7bfcdb5ea59ce35695dd014a1cbccddecd5c3cb.zip
Version bump due security bug #99173
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skype/ChangeLog7
-rw-r--r--net-im/skype/files/digest-skype-1.2.0.113
-rw-r--r--net-im/skype/skype-1.2.0.11.ebuild101
3 files changed, 110 insertions, 1 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index cb38d9cf430e..90da84573dd0 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/skype
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.42 2005/07/25 17:49:09 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.43 2005/07/31 20:30:54 sekretarz Exp $
+
+*skype-1.2.0.11 (31 Jul 2005)
+
+ 31 Jul 2005; <sekretarz@gentoo.org> +skype-1.2.0.11.ebuild:
+ Version bump due security bug #99173
25 Jul 2005; Caleb Tennis <caleb@gentoo.org> skype-1.1.0.3.ebuild,
skype-1.1.0.3-r1.ebuild, skype-1.1.0.13.ebuild, skype-1.1.0.20.ebuild,
diff --git a/net-im/skype/files/digest-skype-1.2.0.11 b/net-im/skype/files/digest-skype-1.2.0.11
new file mode 100644
index 000000000000..b41140232f25
--- /dev/null
+++ b/net-im/skype/files/digest-skype-1.2.0.11
@@ -0,0 +1,3 @@
+MD5 5b3195993d01ed0d439a28b505665382 skype-avatars-1.0.tgz 377763
+MD5 f37cc472615113fe8c58971b58aa4a54 skype-1.2.0.11.tar.bz2 6844323
+MD5 080f3a4a16133a2b3c6f1589bd5255c3 skype_staticQT-1.2.0.11.tar.bz2 681707
diff --git a/net-im/skype/skype-1.2.0.11.ebuild b/net-im/skype/skype-1.2.0.11.ebuild
new file mode 100644
index 000000000000..674ba29228e2
--- /dev/null
+++ b/net-im/skype/skype-1.2.0.11.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-1.2.0.11.ebuild,v 1.1 2005/07/31 20:30:54 sekretarz Exp $
+
+inherit eutils qt3
+
+
+#If you want to know when this package will be marked stable please see the Changelog
+RESTRICT="nomirror"
+AVATARV="1.0"
+DESCRIPTION="${PN} is a P2P-VoiceIP client."
+HOMEPAGE="http://www.${PN}.com/"
+SRC_URI="http://dev.gentoo.org/~humpback/skype-avatars-${AVATARV}.tgz
+ !static? ( http://download.skype.com/linux/${P}.tar.bz2 )
+ static? ( http://download.skype.com/linux/${PN}_staticQT-${PV}.tar.bz2 )"
+LICENSE="skype-eula"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="static arts esd"
+DEPEND="
+ amd64? ( app-emulation/emul-linux-x86-glibc
+ >=app-emulation/emul-linux-x86-xlibs-1.2
+ >=app-emulation/emul-linux-x86-baselibs-2.1.1
+ !static? ( >=app-emulation/emul-linux-x86-qtlibs-1.1 ) )
+ x86? ( !static? ( $(qt_min_version 3.2) )
+ >=sys-libs/glibc-2.3.2 )"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-0.23.4"
+
+src_unpack() {
+ if use static;
+ then
+ unpack ${PN}_staticQT-${PV}.tar.bz2
+ mv ${PN}_staticQT-${PV} ${S}
+ else
+ unpack ${P}.tar.bz2
+ fi
+ cd ${P}
+ unpack skype-avatars-${AVATARV}.tgz
+}
+
+src_install() {
+ ## Install the wrapper script
+ mv skype skype.bin
+ cp ${FILESDIR}/sDaemonWrapper-r1 skype
+
+ dodir /opt/${PN}
+ exeopts -m0755
+ exeinto /opt/${PN}
+ doexe skype
+ doexe skype.bin
+ doexe skype-callto-handler
+ insinto /opt/${PN}/sound
+ doins sound/*.wav
+
+ insinto /opt/${PN}/lang
+ doins lang/*.qm
+ #Skype still shows ALL languagues no matter what were installed
+ #for i in ${LINGUAS}; do
+ # if [ -f lang/${PN}_${i}.qm ]; then
+ # doins lang/${PN}_${i}.qm
+ # fi;
+ #done;
+ insinto /etc/dbus-1/system.d
+ doins skype.conf
+
+ insinto /opt/${PN}/avatars
+ doins avatars/*.jpg
+
+ insinto /opt/${PN}
+ make_desktop_entry skype "Skype VoIP" skype
+ for SIZE in 16 32 48
+ do
+ insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
+ newins ${S}/icons/${PN}_${SIZE}_32.png ${PN}.png
+ done
+ fowners root:audio /opt/skype/skype.bin
+ fowners root:audio /opt/skype/skype
+ fowners root:audio /opt/skype/skype-callto-handler
+ dodir /usr/bin/
+ dosym /opt/skype/skype.bin /usr/bin/skype
+ # Install the Documentation
+ dodoc README LICENSE
+
+ # TODO: Optional configuration of callto:// in KDE, Mozilla and friends
+}
+
+pkg_postinst() {
+ einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
+ einfo "If you have sound problems please visit: "
+ einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
+ if ( use arts );
+ then
+ ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
+ ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
+ ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
+ fi
+ ##I do not know if this is true for this version. But will leave the note here
+ ewarn "If you are upgrading and skype does not autologin do a manual login"
+ ewarn "you will not lose your contacts."
+}